Update to 0.28.1

epel9
Josh Stone 5 years ago
parent f0f7e06b40
commit de85f36887

1
.gitignore vendored

@ -6,3 +6,4 @@
/clang-sys-0.26.4.crate
/clang-sys-0.27.0.crate
/clang-sys-0.28.0.crate
/clang-sys-0.28.1.crate

@ -1,35 +0,0 @@
From 7a6a33fc6290dbb712f6c2682f6054ec467d718d Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Tue, 7 May 2019 14:06:40 +0200
Subject: [PATCH] chore: Update glob to 0.3
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
build/common.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/build/common.rs b/build/common.rs
index 44e58e0..ed69d4b 100644
--- a/build/common.rs
+++ b/build/common.rs
@@ -77,7 +77,7 @@ fn search_directory(directory: &Path, filenames: &[String]) -> Vec<(PathBuf, Str
options.require_literal_separator = true;
paths.flat_map(|p| {
- if let Ok(paths) = glob::glob_with(&p, &options) {
+ if let Ok(paths) = glob::glob_with(&p, options) {
paths.filter_map(Result::ok).collect()
} else {
vec![]
@@ -155,7 +155,7 @@ pub fn search_libclang_directories(files: &[String], variable: &str) -> Vec<(Pat
options.case_sensitive = false;
options.require_literal_separator = true;
for directory in directories.iter().rev() {
- if let Ok(directories) = glob::glob_with(directory, &options) {
+ if let Ok(directories) = glob::glob_with(directory, options) {
for directory in directories.filter_map(Result::ok).filter(|p| p.is_dir()) {
found.extend(search_directories(&directory, files));
}
--
2.21.0

@ -1,22 +1,10 @@
--- clang-sys-0.28.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ clang-sys-0.28.0/Cargo.toml 2019-05-07T12:25:04.096136+00:00
@@ -21,8 +21,9 @@
--- clang-sys-0.28.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ clang-sys-0.28.1/Cargo.toml 2019-11-23T00:05:36.674266+00:00
@@ -21,6 +21,7 @@
readme = "README.md"
license = "Apache-2.0"
repository = "https://github.com/KyleMayes/clang-sys"
+exclude = ["/appveyor.yml", "/ci/*", "/clippy.toml"]
[dependencies.glob]
-version = "0.2.11"
+version = "0.3"
version = "0.3"
[dependencies.libc]
version = "0.2.39"
@@ -32,7 +33,7 @@
version = "0.5.0"
optional = true
[build-dependencies.glob]
-version = "0.2.11"
+version = "0.3"
[features]
clang_3_5 = []

@ -1,12 +1,12 @@
# Generated by rust2rpm-9-1.fc31
# Generated by rust2rpm 10
%bcond_with check
%global debug_package %{nil}
%global crate clang-sys
Name: rust-%{crate}
Version: 0.28.0
Release: 3%{?dist}
Version: 0.28.1
Release: 1%{?dist}
Summary: Rust bindings for libclang
# Upstream license specification: Apache-2.0
@ -15,20 +15,17 @@ URL: https://crates.io/crates/clang-sys
Source: %{crates_source}
# Initial patched metadata
# * Exclude unneeded files
# * Update glob to 0.3, https://github.com/KyleMayes/clang-sys/pull/90
Patch0: clang-sys-fix-metadata.diff
# Make it work with new glob
Patch1: 0001-chore-Update-glob-to-0.3.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: (crate(glob/default) >= 0.3.0 with crate(glob/default) < 0.4.0)
BuildRequires: (crate(libc) >= 0.2.39 with crate(libc) < 0.3.0)
BuildRequires: clang-devel >= 3.5
%global _description \
Rust bindings for libclang.
%global _description %{expand:
Rust bindings for libclang.}
%description %{_description}
@ -337,6 +334,10 @@ which use "static" feature of "%{crate}" crate.
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
echo 'clang-devel >= 3.5'
%build
%cargo_build
@ -349,6 +350,9 @@ which use "static" feature of "%{crate}" crate.
%endif
%changelog
* Sat Nov 23 2019 Josh Stone <jistone@redhat.com> - 0.28.1-1
- Update to 0.28.1
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.28.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (clang-sys-0.28.0.crate) = f55b5dc0aa595619e59f456970621c115aa629d9550b1e2d62c45d8c29f16e66b540b41fcc2bdb8160ead0272c73bd1cb0eb2a7d911f91737f95647d889a4fec
SHA512 (clang-sys-0.28.1.crate) = 56818d67a45e807e651ce2426b61b8c5e026087d5709cc0cfbef26eb162177746ecb13bf07126615bf41ce0b95b515a5e29aad3b65058f714d37979fe6582a98

Loading…
Cancel
Save