parent
6733bbc184
commit
4424d93c05
@ -0,0 +1 @@
|
||||
/clang-sys-0.24.0.crate
|
@ -0,0 +1,10 @@
|
||||
--- clang-sys-0.24.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ clang-sys-0.24.0/Cargo.toml 2018-10-04T14:29:57.027994+02:00
|
||||
@@ -21,6 +21,7 @@
|
||||
readme = "README.md"
|
||||
license = "Apache-2.0"
|
||||
repository = "https://github.com/KyleMayes/clang-sys"
|
||||
+exclude = ["/appveyor.yml", "/ci/*", "/clippy.toml"]
|
||||
[dependencies.glob]
|
||||
version = "0.2.11"
|
||||
|
@ -0,0 +1,68 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate clang-sys
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.24.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Rust bindings for libclang
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/clang-sys
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Exclude unneeded files
|
||||
Patch0: clang-sys-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(glob) >= 0.2.11 with crate(glob) < 0.3.0)
|
||||
BuildRequires: (crate(libc) >= 0.2.39 with crate(libc) < 0.3.0)
|
||||
BuildRequires: (crate(libloading) >= 0.5.0 with crate(libloading) < 0.6.0)
|
||||
# [build-dependencies]
|
||||
BuildRequires: (crate(glob) >= 0.2.11 with crate(glob) < 0.3.0)
|
||||
|
||||
BuildRequires: clang-devel >= 3.5
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
Requires: clang-devel >= 3.5
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Rust bindings for libclang.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE.txt
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Thu Oct 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.24.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue