Update to version 0.4.31; Fixes RHBZ#2236287

epel9 imports/e9/rust-chrono-0.4.31-1.el9
Fabio Valentini 1 year ago
parent 18b094ed90
commit 657712cdf4
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -20,3 +20,4 @@
/chrono-0.4.25.crate
/chrono-0.4.26.crate
/chrono-0.4.27.crate
/chrono-0.4.31.crate

@ -1,6 +1,6 @@
--- chrono-0.4.27/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.27/Cargo.toml 2023-08-29T21:05:55.635779+00:00
@@ -125,34 +125,11 @@
--- chrono-0.4.31/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.31/Cargo.toml 2023-09-19T18:29:35.649694+00:00
@@ -100,34 +100,11 @@
"alloc",
]
wasmbind = [

@ -1,38 +1,10 @@
--- chrono-0.4.27/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.27/Cargo.toml 2023-08-29T21:07:07.280031+00:00
@@ -41,26 +41,9 @@
[lib]
name = "chrono"
-[[bench]]
-name = "chrono"
-harness = false
-required-features = ["__internal_bench"]
-
-[[bench]]
-name = "serde"
-harness = false
-required-features = [
- "__internal_bench",
- "serde",
-]
-
[dependencies.arbitrary]
version = "1.0.0"
features = ["derive"]
-optional = true
-
-[dependencies.criterion]
-version = "0.4.0"
optional = true
[dependencies.num-traits]
@@ -102,20 +85,15 @@
--- chrono-0.4.31/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.31/Cargo.toml 2023-09-19T18:30:04.789787+00:00
@@ -78,19 +78,15 @@
version = "1"
[features]
-__doctest = []
-__internal_bench = ["criterion"]
-__internal_bench = []
alloc = []
clock = [
"std",
@ -47,8 +19,8 @@
- "wasmbind",
]
libc = []
oldtime = ["time"]
@@ -124,9 +102,6 @@
oldtime = []
@@ -99,9 +95,6 @@
"pure-rust-locales",
"alloc",
]

@ -5,7 +5,7 @@
%global crate chrono
Name: rust-chrono
Version: 0.4.27
Version: 0.4.31
Release: %autorelease
Summary: Date and time library for Rust
@ -185,18 +185,6 @@ use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-locales-devel
Summary: %{summary}
BuildArch: noarch
@ -224,9 +212,7 @@ use the "unstable-locales" feature of the "%{crate}" crate.
%if %{with check}
%check
# * skip a test that hard-codes 64-bit arch-specific type sizes:
# https://github.com/chronotope/chrono/issues/1234
%cargo_test -a -- -- --skip format::strftime::tests::test_type_sizes
%cargo_test -a
%endif
%changelog

@ -1 +1 @@
SHA512 (chrono-0.4.27.crate) = 19c86589c11905ca16d68e59b500717329d08a9a431bbb51eabc2e1b15d1ab8902188e05337b0ec6fccc0c268a073c4e280dbd6605e80d4d4fcb17a4fdc5d9f0
SHA512 (chrono-0.4.31.crate) = 23276daa2c1bc3b7b2327dc84200fb40cc995a8b599d1a537e92e08138ab8a0d1548a510a8155dcdda18820120d7204e89a4686c866fc3a8d2460cdb30ac6089

Loading…
Cancel
Save