Update to 0.1.7

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 583c518ed5
commit fa49aac8a4
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -3,3 +3,4 @@
/cfg-if-0.1.4.crate
/cfg-if-0.1.5.crate
/cfg-if-0.1.6.crate
/cfg-if-0.1.7.crate

@ -1,29 +0,0 @@
From 5cd2f3066c344415c61e0bd91f23820ec413e49e Mon Sep 17 00:00:00 2001
From: Alex Crichton <alex@alexcrichton.com>
Date: Fri, 11 Jan 2019 09:02:32 -0800
Subject: [PATCH] Document macro
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Jan Staněk <jstanek@redhat.com>
---
src/lib.rs | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/lib.rs b/src/lib.rs
index ff144f6..e867e65 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -32,6 +32,8 @@
#![deny(missing_docs)]
#![cfg_attr(test, deny(warnings))]
+/// The main macro provided by this crate. See crate documentation for more
+/// information.
#[macro_export(local_inner_macros)]
macro_rules! cfg_if {
// match if/else chains with a final `else`
--
2.20.1

@ -6,16 +6,14 @@
%global crate cfg-if
Name: rust-%{crate}
Version: 0.1.6
Release: 5%{?dist}
Version: 0.1.7
Release: 1%{?dist}
Summary: Macro to ergonomically define an item depending on a large number of #[cfg] parameters
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/cfg-if
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# https://github.com/alexcrichton/cfg-if/commit/5cd2f3066c344415c61e0bd91f23820ec413e49e
Patch0001: 0001-Document-macro.patch
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
@ -55,7 +53,7 @@ which use "default" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -70,6 +68,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Tue Mar 05 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.7-1
- Update to 0.1.7
* Mon Mar 04 2019 Jan Staněk <jstanek@redhat.com> - 0.1.6-5
- Import upstream fix for build failure from missing docs

@ -1 +1 @@
SHA512 (cfg-if-0.1.6.crate) = e393816f659bb5b1e64ebc72a4b6e3e673afd00cba302c3c92c6f2e98db341a29197f6cf413107e569175a86aad85e74a93e2cd3a9fa9fa2d1b70b01c3fcf378
SHA512 (cfg-if-0.1.7.crate) = 30a1510f0a217e588e9a2c1ef51e6188d7437c63641284782262fa9a2ec78f04d0bbdac7ce32c0e8282e2e518d4b6c9d6ed0c2658baac412133ad1cc1f8d43a4

Loading…
Cancel
Save