Update to 0.3.1

epel9
Josh Stone 6 years ago
parent 995d8c59a0
commit 4ec76c04d3

1
.gitignore vendored

@ -1 +1,2 @@
/cexpr-0.3.0.crate /cexpr-0.3.0.crate
/cexpr-0.3.1.crate

@ -1,31 +0,0 @@
From 4102a9e624596828aa36f4b9c487be928687b561 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Thu, 4 Oct 2018 14:43:07 +0200
Subject: [PATCH] bump clang-sys to 0.24
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
tests/clang.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/clang.rs b/tests/clang.rs
index 8578811..93cb8dc 100644
--- a/tests/clang.rs
+++ b/tests/clang.rs
@@ -149,11 +149,11 @@ unsafe fn visit_children<F>(cursor: CXCursor, mut f: F)
unsafe fn location_in_scope(r: CXSourceRange) -> bool {
let start=clang_getRangeStart(r);
- let mut file=CXFile(ptr::null_mut());
+ let mut file: CXFile=ptr::null_mut();
clang_getSpellingLocation(start,&mut file,ptr::null_mut(),ptr::null_mut(),ptr::null_mut());
clang_Location_isFromMainFile(start)!=0
&& clang_Location_isInSystemHeader(start)==0
- && file.0!=ptr::null_mut()
+ && file!=ptr::null_mut()
}
/// tokenize_range_adjust can be used to work around LLVM bug 9069
--
2.19.0

@ -1,8 +0,0 @@
--- cexpr-0.3.0/Cargo.toml 1969-12-31T16:00:00-08:00
+++ cexpr-0.3.0/Cargo.toml 2018-10-08T16:03:37.087519-07:00
@@ -23,4 +23,4 @@
version = "^4"
features = ["verbose-errors"]
[dev-dependencies.clang-sys]
-version = "0.11.0"
+version = "0.26"

@ -5,18 +5,14 @@
%global crate cexpr %global crate cexpr
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.3.0 Version: 0.3.1
Release: 2%{?dist} Release: 1%{?dist}
Summary: C expression parser and evaluator Summary: C expression parser and evaluator
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/cexpr URL: https://crates.io/crates/cexpr
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump clang-sys to 0.26 and fix tests
Patch0: cexpr-fix-metadata.diff
Patch0001: 0001-bump-clang-sys-to-0.24.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -25,7 +21,7 @@ BuildRequires: rust-packaging
BuildRequires: ((crate(nom) >= 4.0.0 with crate(nom) < 5.0.0) with crate(nom/verbose-errors)) BuildRequires: ((crate(nom) >= 4.0.0 with crate(nom) < 5.0.0) with crate(nom/verbose-errors))
%if %{with check} %if %{with check}
# [dev-dependencies] # [dev-dependencies]
BuildRequires: (crate(clang-sys) >= 0.26.0 with crate(clang-sys) < 0.27.0) BuildRequires: (crate(clang-sys) >= 0.13.0 with crate(clang-sys) <= 0.26.0)
%endif %endif
%description %description
@ -61,6 +57,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version}/
%changelog %changelog
* Tue Oct 09 2018 Josh Stone <jistone@redhat.com> - 0.3.1-1
- Update to 0.3.1
* Mon Oct 08 2018 Josh Stone <jistone@redhat.com> - 0.3.0-2 * Mon Oct 08 2018 Josh Stone <jistone@redhat.com> - 0.3.0-2
- Bump to clang-sys 0.26 - Bump to clang-sys 0.26

@ -1 +1 @@
SHA512 (cexpr-0.3.0.crate) = e658eae2643c4b82005c812859caa92576eafcaeb5aa7dc6c438e8d2b562bb249c9b4fa5d365011db9c4e057ff85a90b3e55e2efa662c161bd0e196b0a2eb6c7 SHA512 (cexpr-0.3.1.crate) = d0c41291d3c898304af2856a8915ce4bfa7cf992a942e785006c32439480744d316cfe287e0b0f48793fd736107333d8992faac8b70f975b14e0c1a4453befb0

Loading…
Cancel
Save