parent
d67902e9c9
commit
348da692ff
@ -0,0 +1 @@
|
|||||||
|
/cbindgen-0.26.0.crate
|
@ -0,0 +1,20 @@
|
|||||||
|
--- cbindgen-0.26.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ cbindgen-0.26.0/Cargo.toml 2024-10-09T17:58:26.638747+00:00
|
||||||
|
@@ -50,7 +50,7 @@
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
[dependencies.heck]
|
||||||
|
-version = "0.4"
|
||||||
|
+version = "0.5"
|
||||||
|
|
||||||
|
[dependencies.indexmap]
|
||||||
|
version = "1"
|
||||||
|
@@ -91,7 +91,7 @@
|
||||||
|
version = "0.5"
|
||||||
|
|
||||||
|
[dev-dependencies.serial_test]
|
||||||
|
-version = "0.5.0"
|
||||||
|
+version = "3.1"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
default = ["clap"]
|
@ -0,0 +1,95 @@
|
|||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
# prevent executables from being installed
|
||||||
|
%global cargo_install_bin 0
|
||||||
|
|
||||||
|
%global crate cbindgen
|
||||||
|
|
||||||
|
Name: rust-cbindgen0.26
|
||||||
|
Version: 0.26.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Tool for generating C bindings to Rust code
|
||||||
|
|
||||||
|
License: MPL-2.0
|
||||||
|
URL: https://crates.io/crates/cbindgen
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump heck dependency from 0.4 to 0.5
|
||||||
|
# * bump serial_test dev-dependency from 0.5 to 3.1
|
||||||
|
Patch: cbindgen-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 26
|
||||||
|
%if %{with check}
|
||||||
|
BuildRequires: /usr/bin/cython
|
||||||
|
BuildRequires: /usr/bin/gcc
|
||||||
|
BuildRequires: /usr/bin/g++
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A tool for generating C bindings to Rust code.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/contributing.md
|
||||||
|
%doc %{crate_instdir}/docs.md
|
||||||
|
%doc %{crate_instdir}/internals.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+clap-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+clap-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "clap" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+clap-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,14 @@
|
|||||||
|
[package]
|
||||||
|
cargo-install-bin = false
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"bump heck dependency from 0.4 to 0.5",
|
||||||
|
"bump serial_test dev-dependency from 0.5 to 3.1",
|
||||||
|
]
|
||||||
|
|
||||||
|
[requires]
|
||||||
|
test = [
|
||||||
|
"/usr/bin/cython",
|
||||||
|
"/usr/bin/gcc",
|
||||||
|
"/usr/bin/g++",
|
||||||
|
]
|
||||||
|
|
Loading…
Reference in new issue