commit
c77b54ffa8
Binary file not shown.
@ -0,0 +1,11 @@
|
|||||||
|
--- cargo_metadata-0.15.4/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ cargo_metadata-0.15.4/Cargo.toml 2023-05-25T16:47:36.950773+00:00
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
version = "0.1.2"
|
||||||
|
|
||||||
|
[dependencies.derive_builder]
|
||||||
|
-version = "0.11.1"
|
||||||
|
+version = "0.12"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
[dependencies.semver]
|
@ -0,0 +1,112 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate cargo_metadata
|
||||||
|
|
||||||
|
Name: rust-cargo_metadata0.15
|
||||||
|
Version: 0.15.4
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Structured access to the output of cargo metadata
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/cargo_metadata
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump derive_builder dependency from 0.11.1 to 0.12:
|
||||||
|
# https://github.com/oli-obk/cargo_metadata/pull/230
|
||||||
|
Patch: cargo_metadata-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Structured access to the output of `cargo metadata`.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+builder-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+builder-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "builder" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+builder-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+derive_builder-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+derive_builder-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "derive_builder" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+derive_builder-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires -a
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build -a
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install -a
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# * skip tests that depend on fixtures which are not included in published crates
|
||||||
|
%cargo_test -a -- -- --skip advanced_feature_configuration --skip all_the_fields --skip basic_workspace_root_package_exists --skip current_dir
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.15.4-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Tue Sep 05 2023 Fabio Valentini <decathorpe@gmail.com> - 0.15.4-1
|
||||||
|
- Initial import (cargo_metadata 0.15 compat package)
|
Loading…
Reference in new issue