commit
9917488494
@ -0,0 +1 @@
|
|||||||
|
SOURCES/bytesize-1.3.0.crate
|
@ -0,0 +1 @@
|
|||||||
|
a4c0bfeebba75c8c25977e352ec6bd08b611dbf8 SOURCES/bytesize-1.3.0.crate
|
@ -0,0 +1,28 @@
|
|||||||
|
From 566c1b27883ef1ee2d9708985cfe3651855c3954 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Thu, 8 Aug 2024 14:16:03 +0200
|
||||||
|
Subject: [PATCH] fix typo in doc code block annotation that caused test
|
||||||
|
failures
|
||||||
|
|
||||||
|
Since Rust 1.80, rustdoc seems to be more strict about which code block
|
||||||
|
annotations result in code blocks to be treated as non-Rust code.
|
||||||
|
---
|
||||||
|
src/lib.rs | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib.rs b/src/lib.rs
|
||||||
|
index 01c4440..21ec699 100644
|
||||||
|
--- a/src/lib.rs
|
||||||
|
+++ b/src/lib.rs
|
||||||
|
@@ -22,7 +22,7 @@
|
||||||
|
//!
|
||||||
|
//! It also provides its human readable string as follows:
|
||||||
|
//!
|
||||||
|
-//! ```ignore=
|
||||||
|
+//! ```ignore
|
||||||
|
//! assert_eq!("482 GiB".to_string(), ByteSize::gb(518).to_string(true));
|
||||||
|
//! assert_eq!("518 GB".to_string(), ByteSize::gb(518).to_string(false));
|
||||||
|
//! ```
|
||||||
|
--
|
||||||
|
2.46.0
|
||||||
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- bytesize-1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ bytesize-1.3.0/Cargo.toml 2024-09-21T11:28:23.094321+00:00
|
||||||
|
@@ -39,7 +39,7 @@
|
||||||
|
version = "1.0.105"
|
||||||
|
|
||||||
|
[dev-dependencies.toml]
|
||||||
|
-version = "0.7.6"
|
||||||
|
+version = "0.8"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
default = []
|
@ -0,0 +1,159 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 5;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate bytesize
|
||||||
|
|
||||||
|
Name: rust-bytesize
|
||||||
|
Version: 1.3.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Utility for human-readable bytes representations
|
||||||
|
|
||||||
|
License: Apache-2.0
|
||||||
|
URL: https://crates.io/crates/bytesize
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump toml dev-dependency from 0.7 to 0.8
|
||||||
|
Patch: bytesize-fix-metadata.diff
|
||||||
|
# * patch to fix doctests with Rust 1.80+
|
||||||
|
Patch: 0001-fix-typo-in-doc-code-block-annotation-that-caused-te.patch
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
An utility for human-readable bytes representations.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.3.0-5
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Sep 21 2024 Fabio Valentini <decathorpe@gmail.com> - 1.3.0-5
|
||||||
|
- Bump toml dev-dependency from 0.7 to 0.8
|
||||||
|
|
||||||
|
* Thu Aug 08 2024 Fabio Valentini <decathorpe@gmail.com> - 1.3.0-4
|
||||||
|
- Include patch to fix doctests with Rust 1.80+
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 31 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.0-1
|
||||||
|
- Update to version 1.3.0; Fixes RHBZ#2234030
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 27 2023 Fabio Valentini <decathorpe@gmail.com> - 1.2.0-1
|
||||||
|
- Update to version 1.2.0; Fixes RHBZ#2173143
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 31 2021 Fabio Valentini <decathorpe@gmail.com> - 1.1.0-1
|
||||||
|
- Update to version 1.1.0; Fixes RHBZ#1988584
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 23 21:25:50 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.0.1-1
|
||||||
|
- Update to 1.0.1
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 11 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.0-3
|
||||||
|
- Run tests in infrastructure
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 06 2018 Josh Stone <jistone@redhat.com> - 1.0.0-1
|
||||||
|
- Initial package
|
||||||
|
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue