Update to 0.5.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent ff9a90aba0
commit dd2cb6b541
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -2,3 +2,4 @@
/bytecount-0.3.0.crate /bytecount-0.3.0.crate
/bytecount-0.3.1.crate /bytecount-0.3.1.crate
/bytecount-0.3.2.crate /bytecount-0.3.2.crate
/bytecount-0.5.0.crate

@ -1,30 +1,20 @@
--- bytecount-0.3.2/Cargo.toml 1970-01-01T01:00:00+01:00 --- bytecount-0.5.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ bytecount-0.3.2/Cargo.toml 2018-10-28T02:02:14.813005+01:00 +++ bytecount-0.5.0/Cargo.toml 2019-02-10T09:24:13.905416+01:00
@@ -19,6 +19,7 @@ @@ -27,9 +27,6 @@
categories = ["algorithms", "no-std"]
license = "Apache-2.0/MIT"
repository = "https://github.com/llogiq/bytecount"
+exclude = ["/.travis.yml", "/appveyor.yml"]
[lib]
bench = false
@@ -26,9 +27,6 @@
[[bench]] [[bench]]
name = "bench" name = "bench"
harness = false harness = false
-[dependencies.simd] -[dependencies.packed_simd]
-version = "0.2.0" -version = "0.3.1"
-optional = true -optional = true
[dev-dependencies.criterion] [dev-dependencies.criterion]
version = "0.2.4" version = "0.2.7"
default-features = false
@@ -39,9 +37,7 @@ @@ -41,7 +38,6 @@
version = "0.4" version = "0.6"
[features] [features]
-avx-accel = ["simd-accel"] -generic-simd = ["packed_simd"]
html_report = [] html_report = []
-simd-accel = ["simd"] runtime-dispatch-simd = []
[badges.appveyor] [badges.appveyor]
repository = "llogiq/bytecount"

@ -6,31 +6,30 @@
%global crate bytecount %global crate bytecount
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.3.2 Version: 0.5.0
Release: 3%{?dist} Release: 1%{?dist}
Summary: Count occurrences of a byte, or the UTF-8 code points, in a byte slice, fast Summary: Count occurrences of a byte, or the UTF-8 code points, in a byte slice, fast
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/bytecount URL: https://crates.io/crates/bytecount
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No simd # * No simd
# * Exclude CI files, https://github.com/llogiq/bytecount/pull/47
Patch0: bytecount-fix-metadata.diff Patch0: bytecount-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
%if %{with check} %if %{with check}
BuildRequires: (crate(criterion/default) >= 0.2.4 with crate(criterion/default) < 0.3.0) BuildRequires: (crate(criterion) >= 0.2.7 with crate(criterion) < 0.3.0)
BuildRequires: (crate(quickcheck/default) >= 0.6.0 with crate(quickcheck/default) < 0.7.0) BuildRequires: (crate(quickcheck/default) >= 0.8.0 with crate(quickcheck/default) < 0.9.0)
BuildRequires: (crate(rand/default) >= 0.4.0 with crate(rand/default) < 0.5.0) BuildRequires: (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
%endif %endif
%global _description \ %global _description \
Count occurrences of a given byte, or the number of UTF-8 code points,\ Count occurrences of a given byte, or the number of UTF-8 code points, in a\
in a byte slice, fast. byte slice, fast.
%description %{_description} %description %{_description}
@ -60,8 +59,32 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+html_report-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+html_report-devel %{_description}
This package contains library source intended for building other packages
which use "html_report" feature of "%{crate}" crate.
%files -n %{name}+html_report-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+runtime-dispatch-simd-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+runtime-dispatch-simd-devel %{_description}
This package contains library source intended for building other packages
which use "runtime-dispatch-simd" feature of "%{crate}" crate.
%files -n %{name}+runtime-dispatch-simd-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%build %build
@ -76,6 +99,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
- Update to 0.5.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-3 * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1 +1 @@
SHA512 (bytecount-0.3.2.crate) = fa3453f220112f83280dd3a123b25cf3ec07d2487c89cb80dc383f12e9f4d759e316d1eb05bcb0633186dc3f26d2ed58d979ba4ca86404a7f6edc4c174ae0edc SHA512 (bytecount-0.5.0.crate) = ebbb10f8655c96ce68e94cb73ed920460779566d69c9b7ae6cc1f6041f40cbbccc3b3d1524eb96e380d17c823b51e9169361967cda594f604685ec819dcd9889

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-bytecount
Loading…
Cancel
Save