Update to 0.3.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent d7d53efd1d
commit c08447b1d6

1
.gitignore vendored

@ -1 +1,2 @@
/bytecount-0.2.0.crate /bytecount-0.2.0.crate
/bytecount-0.3.0.crate

@ -1,26 +0,0 @@
--- bytecount-0.2.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ bytecount-0.2.0/Cargo.toml 2017-12-31T18:58:51.977027+01:00
@@ -26,21 +26,16 @@
name = "bench"
path = "benches/bench.rs"
harness = false
-[dependencies.simd]
-version = "0.2.0"
-optional = true
[dev-dependencies.bencher]
version = "0.1.4"
[dev-dependencies.quickcheck]
-version = "0.4.1"
+version = "0.6"
[dev-dependencies.rand]
-version = "0.3.16"
+version = "0.4"
[features]
-avx-accel = ["simd-accel"]
-simd-accel = ["simd"]
[badges.travis-ci]
repository = "llogiq/bytecount"

@ -0,0 +1,21 @@
--- bytecount-0.3.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ bytecount-0.3.0/Cargo.toml 2018-01-09T08:09:51.832939+01:00
@@ -26,9 +26,6 @@
name = "bench"
path = "benches/bench.rs"
harness = false
-[dependencies.simd]
-version = "0.2.0"
-optional = true
[dev-dependencies.bencher]
version = "0.1.4"
@@ -39,8 +36,6 @@
version = "0.4"
[features]
-avx-accel = ["simd-accel"]
-simd-accel = ["simd"]
[badges.appveyor]
repository = "llogiq/bytecount"

@ -5,18 +5,16 @@
%global crate bytecount %global crate bytecount
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.0 Version: 0.3.0
Release: 4%{?dist} Release: 1%{?dist}
Summary: Count occurrences of a byte in a byte slice, fast Summary: Count occurrences of a byte, or the UTF-8 code points, in a byte slice, fast
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/bytecount URL: https://crates.io/crates/bytecount
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * No simd # * No simd
# * Bump quickcheck to 0.6, https://github.com/llogiq/bytecount/pull/34 Patch0: bytecount-0.3.0-fix-metadata.diff
# * Bump rand to 0.4, https://github.com/llogiq/bytecount/pull/33
Patch0: bytecount-0.2.0-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -36,7 +34,8 @@ Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description devel %description devel
Count occurrences of a byte in a byte slice, fast. Count occurrences of a given byte, or the number of UTF-8 code points, in a
byte slice, fast.
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use %{crate} from crates.io. which use %{crate} from crates.io.
@ -63,6 +62,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml %exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
%changelog %changelog
* Tue Jan 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-1
- Update to 0.3.0
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-4 * Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-4
- Rebuild for rust-packaging v5 - Rebuild for rust-packaging v5

@ -1 +1 @@
SHA512 (bytecount-0.2.0.crate) = 3200a6b4ada54aed679b1ac105a39c59f5b52a77d421514a2c254097f20d0768dbd089722929c603290b60e69aa0d9a4229815a1ad2692aa27256b5822c699f6 SHA512 (bytecount-0.3.0.crate) = 1dd789537500ccc469a9e95db55cc05b803cc96fcbcdebd89a8b0104a38bfcae7410e15119888674028aa6354e50fc4fd9908a9164a8fd42555ad58ceb59d454

Loading…
Cancel
Save