parent
3c7adedd82
commit
3ef06189ce
@ -0,0 +1 @@
|
|||||||
|
/bytecount-0.2.0.crate
|
@ -0,0 +1,21 @@
|
|||||||
|
--- bytecount-0.2.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ bytecount-0.2.0/Cargo.toml 2017-11-10T09:34:03.968372+01:00
|
||||||
|
@@ -26,9 +26,6 @@
|
||||||
|
name = "bench"
|
||||||
|
path = "benches/bench.rs"
|
||||||
|
harness = false
|
||||||
|
-[dependencies.simd]
|
||||||
|
-version = "0.2.0"
|
||||||
|
-optional = true
|
||||||
|
[dev-dependencies.bencher]
|
||||||
|
version = "0.1.4"
|
||||||
|
|
||||||
|
@@ -39,8 +36,6 @@
|
||||||
|
version = "0.3.16"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-avx-accel = ["simd-accel"]
|
||||||
|
-simd-accel = ["simd"]
|
||||||
|
[badges.travis-ci]
|
||||||
|
repository = "llogiq/bytecount"
|
||||||
|
|
@ -0,0 +1,77 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate bytecount
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.2.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Count occurrences of a byte in a byte slice, fast
|
||||||
|
|
||||||
|
License: ASL 2.0 or MIT
|
||||||
|
URL: https://crates.io/crates/bytecount
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No simd
|
||||||
|
Patch0: bytecount-0.2.0-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(bencher) >= 0.1.4 with crate(bencher) < 0.2.0)
|
||||||
|
BuildRequires: (crate(quickcheck) >= 0.4.1 with crate(quickcheck) < 0.5.0)
|
||||||
|
BuildRequires: (crate(rand) >= 0.3.16 with crate(rand) < 0.4.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Count occurrences of a byte in a byte slice, fast.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE.Apache2 LICENSE.MIT
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Nov 10 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-1
|
||||||
|
- Update to 0.2.0
|
||||||
|
|
||||||
|
* Fri Jul 21 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.7-1
|
||||||
|
- Update to 0.1.7
|
||||||
|
|
||||||
|
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.6-3
|
||||||
|
- Relax quickcheck version
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.6-2
|
||||||
|
- Port to use rust-packaging
|
||||||
|
|
||||||
|
* Sat Feb 25 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.6-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue