parent
5bc184181d
commit
9969bdecc1
@ -0,0 +1 @@
|
||||
/build-fs-tree-0.3.1.crate
|
@ -0,0 +1,20 @@
|
||||
--- build-fs-tree-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ build-fs-tree-0.3.1/Cargo.toml 2023-02-28T16:52:13.091863+00:00
|
||||
@@ -29,17 +29,6 @@
|
||||
path = "lib.rs"
|
||||
doc = true
|
||||
|
||||
-[[bin]]
|
||||
-name = "build-fs-tree"
|
||||
-path = "_cli/build-fs-tree.rs"
|
||||
-doc = false
|
||||
-required-features = ["cli"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "build-fs-tree-completions"
|
||||
-path = "_cli/build-fs-tree-completions.rs"
|
||||
-doc = false
|
||||
-required-features = ["cli-completions"]
|
||||
[dependencies.derive_more]
|
||||
version = "^0.99.17"
|
||||
|
@ -0,0 +1,83 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate build-fs-tree
|
||||
|
||||
Name: rust-build-fs-tree
|
||||
Version: 0.3.1
|
||||
Release: %autorelease
|
||||
Summary: Generate a filesystem tree from a macro or a YAML tree
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/build-fs-tree
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * don't compile binaries, we don't need them yet
|
||||
Patch: build-fs-tree-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Generate a filesystem tree from a macro or a YAML tree.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+structopt-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+structopt-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "structopt" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+structopt-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue