commit
402556282d
Binary file not shown.
@ -0,0 +1,11 @@
|
||||
--- bstr-0.2.17/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ bstr-0.2.17/Cargo.toml 2023-02-20T16:02:54.049868+00:00
|
||||
@@ -21,7 +21,7 @@
|
||||
readme = "README.md"
|
||||
keywords = ["string", "str", "byte", "bytes", "text"]
|
||||
categories = ["text-processing", "encoding"]
|
||||
-license = "MIT OR Apache-2.0"
|
||||
+license = "(MIT OR Apache-2.0) AND Unicode-DFS-2016"
|
||||
repository = "https://github.com/BurntSushi/bstr"
|
||||
[profile.release]
|
||||
debug = true
|
@ -0,0 +1,173 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate bstr
|
||||
|
||||
Name: rust-bstr0.2
|
||||
Version: 0.2.17
|
||||
Release: %autorelease
|
||||
Summary: String type that is not required to be valid UTF-8
|
||||
|
||||
License: (MIT OR Apache-2.0) AND Unicode-DFS-2016
|
||||
URL: https://crates.io/crates/bstr
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * add missing Unicode license terms to crate metadata:
|
||||
# https://github.com/BurntSushi/bstr/issues/129
|
||||
Patch: bstr-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
A string type that is not required to be valid UTF-8.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/COPYING
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%license %{crate_instdir}/src/unicode/data/LICENSE-UNICODE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+lazy_static-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+lazy_static-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "lazy_static" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+lazy_static-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+regex-automata-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+regex-automata-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "regex-automata" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+regex-automata-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde1-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde1-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde1" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde1-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde1-nostd-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde1-nostd-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde1-nostd" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde1-nostd-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unicode-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unicode-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "unicode" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unicode-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.2.17-1
|
||||
- Rebuilt for MSVSphere 9.2
|
||||
|
||||
* Tue Feb 21 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.17-1
|
||||
- Initial import (bstr 0.2 compat package)
|
Loading…
Reference in new issue