Update to version 3.3.4; Fixes RHBZ#2070425

epel9
Fabio Valentini 3 years ago
parent 43e14ceda5
commit c35f9307a5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/brotli-3.3.0.crate /brotli-3.3.0.crate
/brotli-3.3.2.crate /brotli-3.3.2.crate
/brotli-3.3.3.crate /brotli-3.3.3.crate
/brotli-3.3.4.crate

@ -1,10 +1,14 @@
--- brotli-3.3.3/Cargo.toml 1970-01-01T00:00:01+00:00 --- brotli-3.3.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ brotli-3.3.3/Cargo.toml 2022-01-26T22:42:36.376000+00:00 +++ brotli-3.3.4/Cargo.toml 2022-08-10T20:41:04.497620+00:00
@@ -22,17 +22,11 @@ @@ -19,36 +19,27 @@
documentation = "https://docs.rs/brotli/"
readme = "README.md"
keywords = ["brotli", "decompression", "lz77", "huffman", "nostd"] keywords = ["brotli", "decompression", "lz77", "huffman", "nostd"]
license = "BSD-3-Clause/MIT" -license = "BSD-3-Clause/MIT"
+license = "BSD-3-Clause"
repository = "https://github.com/dropbox/rust-brotli" repository = "https://github.com/dropbox/rust-brotli"
+exclude = ["/ci/", "/research/", "/.travis.yml", "/appveyor.yml", "uncorrode.py"] +exclude = ["/ci/", "/research/", "/.travis.yml", "/appveyor.yml", "uncorrode.py"]
+
[profile.release] [profile.release]
lto = true lto = true
incremental = false incremental = false
@ -19,8 +23,14 @@
[dependencies.alloc-no-stdlib] [dependencies.alloc-no-stdlib]
version = "2.0" version = "2.0"
@@ -44,12 +38,8 @@ [dependencies.alloc-stdlib]
version = "~2.3" -version = "~0.2"
+version = "0.2"
optional = true
[dependencies.brotli-decompressor]
-version = "~2.3"
+version = "2.3"
default-features = false default-features = false
-[dependencies.packed_simd_2] -[dependencies.packed_simd_2]
@ -29,11 +39,11 @@
- -
[dependencies.sha2] [dependencies.sha2]
-version = "~0.8" -version = "~0.8"
+version = "~0.9" +version = "0.9"
optional = true optional = true
[features] [features]
@@ -60,7 +50,6 @@ @@ -59,7 +50,6 @@
ffi-api = [] ffi-api = []
pass-through-ffi-panics = [] pass-through-ffi-panics = []
seccomp = ["brotli-decompressor/seccomp"] seccomp = ["brotli-decompressor/seccomp"]

@ -1,4 +1,5 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 22
# * tests fail with OOM problems on 32-bit architectures:
# https://github.com/dropbox/rust-brotli/issues/42 # https://github.com/dropbox/rust-brotli/issues/42
%if 0%{?__isa_bits} == 32 %if 0%{?__isa_bits} == 32
%bcond_with check %bcond_with check
@ -9,26 +10,27 @@
%global crate brotli %global crate brotli
Name: rust-%{crate} Name: rust-brotli
Version: 3.3.3 Version: 3.3.4
Release: %autorelease Release: %autorelease
Summary: Brotli compressor and decompressor with no_std support Summary: Brotli compressor and decompressor with no_std support
# Upstream license specification: BSD-3-Clause/MIT License: BSD-3-Clause
# * https://github.com/dropbox/rust-brotli/issues/41
License: BSD
URL: https://crates.io/crates/brotli URL: https://crates.io/crates/brotli
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Manually created patch for downstream crate metadata changes
# * Drop unwanted binaries # * fix license in crate metadata:
# * Exclude unneeded files, https://github.com/dropbox/rust-brotli/pull/43 # https://github.com/dropbox/rust-brotli/issues/41
# * Exclude simd feature (missing dependencies) # * bump sha2 dependency from 0.8 to 0.9
# * Bump sha2 dependency from 0.8 to 0.9 # * drop unwanted brotli and catbrotli binaries
Patch0: brotli-fix-metadata.diff # * drop simd feature (missing packed_simd2 dependency)
# * exclude files that are only useful for upstream development:
# https://github.com/dropbox/rust-brotli/pull/43
Patch: brotli-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Brotli compressor and decompressor with an interface avoiding the rust Brotli compressor and decompressor with an interface avoiding the rust
@ -49,9 +51,9 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc README.md %doc %{crate_instdir}/README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -63,7 +65,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-stdlib-devel %package -n %{name}+alloc-stdlib-devel
Summary: %{summary} Summary: %{summary}
@ -75,7 +77,7 @@ This package contains library source intended for building other packages which
use the "alloc-stdlib" feature of the "%{crate}" crate. use the "alloc-stdlib" feature of the "%{crate}" crate.
%files -n %{name}+alloc-stdlib-devel %files -n %{name}+alloc-stdlib-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+benchmark-devel %package -n %{name}+benchmark-devel
Summary: %{summary} Summary: %{summary}
@ -87,7 +89,7 @@ This package contains library source intended for building other packages which
use the "benchmark" feature of the "%{crate}" crate. use the "benchmark" feature of the "%{crate}" crate.
%files -n %{name}+benchmark-devel %files -n %{name}+benchmark-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+disable-timer-devel %package -n %{name}+disable-timer-devel
Summary: %{summary} Summary: %{summary}
@ -99,7 +101,7 @@ This package contains library source intended for building other packages which
use the "disable-timer" feature of the "%{crate}" crate. use the "disable-timer" feature of the "%{crate}" crate.
%files -n %{name}+disable-timer-devel %files -n %{name}+disable-timer-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+external-literal-probability-devel %package -n %{name}+external-literal-probability-devel
Summary: %{summary} Summary: %{summary}
@ -111,7 +113,7 @@ This package contains library source intended for building other packages which
use the "external-literal-probability" feature of the "%{crate}" crate. use the "external-literal-probability" feature of the "%{crate}" crate.
%files -n %{name}+external-literal-probability-devel %files -n %{name}+external-literal-probability-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ffi-api-devel %package -n %{name}+ffi-api-devel
Summary: %{summary} Summary: %{summary}
@ -123,7 +125,7 @@ This package contains library source intended for building other packages which
use the "ffi-api" feature of the "%{crate}" crate. use the "ffi-api" feature of the "%{crate}" crate.
%files -n %{name}+ffi-api-devel %files -n %{name}+ffi-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pass-through-ffi-panics-devel %package -n %{name}+pass-through-ffi-panics-devel
Summary: %{summary} Summary: %{summary}
@ -135,7 +137,7 @@ This package contains library source intended for building other packages which
use the "pass-through-ffi-panics" feature of the "%{crate}" crate. use the "pass-through-ffi-panics" feature of the "%{crate}" crate.
%files -n %{name}+pass-through-ffi-panics-devel %files -n %{name}+pass-through-ffi-panics-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+seccomp-devel %package -n %{name}+seccomp-devel
Summary: %{summary} Summary: %{summary}
@ -147,7 +149,7 @@ This package contains library source intended for building other packages which
use the "seccomp" feature of the "%{crate}" crate. use the "seccomp" feature of the "%{crate}" crate.
%files -n %{name}+seccomp-devel %files -n %{name}+seccomp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha2-devel %package -n %{name}+sha2-devel
Summary: %{summary} Summary: %{summary}
@ -159,7 +161,7 @@ This package contains library source intended for building other packages which
use the "sha2" feature of the "%{crate}" crate. use the "sha2" feature of the "%{crate}" crate.
%files -n %{name}+sha2-devel %files -n %{name}+sha2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -171,7 +173,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+validation-devel %package -n %{name}+validation-devel
Summary: %{summary} Summary: %{summary}
@ -183,7 +185,7 @@ This package contains library source intended for building other packages which
use the "validation" feature of the "%{crate}" crate. use the "validation" feature of the "%{crate}" crate.
%files -n %{name}+validation-devel %files -n %{name}+validation-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+vector_scratch_space-devel %package -n %{name}+vector_scratch_space-devel
Summary: %{summary} Summary: %{summary}
@ -195,10 +197,11 @@ This package contains library source intended for building other packages which
use the "vector_scratch_space" feature of the "%{crate}" crate. use the "vector_scratch_space" feature of the "%{crate}" crate.
%files -n %{name}+vector_scratch_space-devel %files -n %{name}+vector_scratch_space-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
# * remove executable bits from Rust source files:
# https://github.com/dropbox/rust-brotli/pull/40 # https://github.com/dropbox/rust-brotli/pull/40
find -type f -name '*.rs' -executable -exec chmod -x '{}' + find -type f -name '*.rs' -executable -exec chmod -x '{}' +
%cargo_prep %cargo_prep

@ -1 +1 @@
SHA512 (brotli-3.3.3.crate) = 6ef94342504a94fbf0f579388c20ff5c639a3a156973187907a13487afc3cf449f7082a5c03e51a7307b91364a1a931f4f19bc1af363eb3aac3d92f61ff9a854 SHA512 (brotli-3.3.4.crate) = e312842abd713b5dd750ae92dbac297136291bef22b95572b52141c7d991f9d8bc84dc605f30c062a9cdd42d610ba5eb2f8e1ce3a8489f4ba816fca5eca7e5d8

Loading…
Cancel
Save