Update to version 3.4.0; Fixes RHBZ#2241463

epel9 imports/e9/rust-brotli-3.4.0-1.el9
Fabio Valentini 1 year ago
parent f50a251e2a
commit 79a040406b
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/brotli-3.3.2.crate /brotli-3.3.2.crate
/brotli-3.3.3.crate /brotli-3.3.3.crate
/brotli-3.3.4.crate /brotli-3.3.4.crate
/brotli-3.4.0.crate

@ -1,3 +0,0 @@
# rust-brotli
The rust-brotli package

@ -1,14 +1,22 @@
--- brotli-3.3.4/Cargo.toml 1970-01-01T00:00:01+00:00 --- brotli-3.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ brotli-3.3.4/Cargo.toml 2022-08-10T20:41:04.497620+00:00 +++ brotli-3.4.0/Cargo.toml 2024-01-14T22:09:14.729914+00:00
@@ -19,36 +19,27 @@ @@ -28,34 +28,35 @@
documentation = "https://docs.rs/brotli/" "huffman",
readme = "README.md" "nostd",
keywords = ["brotli", "decompression", "lz77", "huffman", "nostd"] ]
-license = "BSD-3-Clause/MIT" -license = "BSD-3-Clause/MIT"
+license = "BSD-3-Clause" +license = "BSD-3-Clause"
repository = "https://github.com/dropbox/rust-brotli" repository = "https://github.com/dropbox/rust-brotli"
+exclude = ["/ci/", "/research/", "/.travis.yml", "/appveyor.yml", "uncorrode.py"] +exclude = [
+ + "/ci/",
+ "/corrosion/",
+ "/research/",
+ "/testdata/",
+ "/appveyor.yml",
+ "/rustfmt.toml",
+ "/uncorrode.py",
+]
[profile.release] [profile.release]
lto = true lto = true
incremental = false incremental = false
@ -20,6 +28,7 @@
-[[bin]] -[[bin]]
-name = "catbrotli" -name = "catbrotli"
-doc = false -doc = false
-
[dependencies.alloc-no-stdlib] [dependencies.alloc-no-stdlib]
version = "2.0" version = "2.0"
@ -29,25 +38,13 @@
optional = true optional = true
[dependencies.brotli-decompressor] [dependencies.brotli-decompressor]
-version = "~2.3" -version = "~2.5"
+version = "2.3" +version = "2.5"
default-features = false default-features = false
-[dependencies.packed_simd_2]
-version = "0.3"
-optional = true
-
[dependencies.sha2] [dependencies.sha2]
-version = "~0.8" -version = "~0.10"
+version = "0.9" +version = "0.10"
optional = true optional = true
[features] [features]
@@ -59,7 +50,6 @@
ffi-api = []
pass-through-ffi-panics = []
seccomp = ["brotli-decompressor/seccomp"]
-simd = ["packed_simd_2/into_bits"]
std = ["alloc-stdlib", "brotli-decompressor/std"]
validation = ["sha2"]
vector_scratch_space = []

@ -1,4 +1,4 @@
# Generated by rust2rpm 22 # Generated by rust2rpm 25
# * tests fail with OOM problems on 32-bit architectures: # * tests fail with OOM problems on 32-bit architectures:
# https://github.com/dropbox/rust-brotli/issues/42 # https://github.com/dropbox/rust-brotli/issues/42
%if 0%{?__isa_bits} == 32 %if 0%{?__isa_bits} == 32
@ -11,7 +11,7 @@
%global crate brotli %global crate brotli
Name: rust-brotli Name: rust-brotli
Version: 3.3.4 Version: 3.4.0
Release: %autorelease Release: %autorelease
Summary: Brotli compressor and decompressor with no_std support Summary: Brotli compressor and decompressor with no_std support
@ -21,23 +21,20 @@ Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * fix license in crate metadata: # * fix license in crate metadata:
# https://github.com/dropbox/rust-brotli/issues/41 # https://github.com/dropbox/rust-brotli/issues/41
# * bump sha2 dependency from 0.8 to 0.9
# * drop unwanted brotli and catbrotli binaries # * drop unwanted brotli and catbrotli binaries
# * drop simd feature (missing packed_simd2 dependency)
# * exclude files that are only useful for upstream development: # * exclude files that are only useful for upstream development:
# https://github.com/dropbox/rust-brotli/pull/43 # https://github.com/dropbox/rust-brotli/pull/43
Patch: brotli-fix-metadata.diff Patch: brotli-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: cargo-rpm-macros >= 24
BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Brotli compressor and decompressor with an interface avoiding the rust A brotli compressor and decompressor that with an interface avoiding the
stdlib. This makes it suitable for embedded devices and kernels. It is designed rust stdlib. This makes it suitable for embedded devices and kernels. It
with a pluggable allocator so that the standard lib's allocator may be is designed with a pluggable allocator so that the standard lib's
employed. The default build also includes a stdlib allocator and stream allocator may be employed. The default build also includes a stdlib
interface. Disable this with --features=no-stdlib. All included code is safe.} allocator and stream interface. Disable this with --features=no-stdlib.
All included code is safe.}
%description %{_description} %description %{_description}
@ -200,11 +197,11 @@ use the "vector_scratch_space" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep
# * remove executable bits from Rust source files: # * remove executable bits from Rust source files:
# https://github.com/dropbox/rust-brotli/pull/40 # https://github.com/dropbox/rust-brotli/pull/40
find -type f -name '*.rs' -executable -exec chmod -x '{}' + find -type f -name '*.rs' -executable -exec chmod -x '{}' +
%cargo_prep
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires

@ -0,0 +1,3 @@
[package]
summary = "Brotli compressor and decompressor with no_std support"

@ -1 +1 @@
SHA512 (brotli-3.3.4.crate) = e312842abd713b5dd750ae92dbac297136291bef22b95572b52141c7d991f9d8bc84dc605f30c062a9cdd42d610ba5eb2f8e1ce3a8489f4ba816fca5eca7e5d8 SHA512 (brotli-3.4.0.crate) = 4f08f274f1fa00d8b40b713e4deeff0eafdbfe8621c5478777df6efd72690cb214974fc9f8fd3f070b3f587c99e3f4396c2409f7c7289f6c7225238e1f14b302

Loading…
Cancel
Save