Update to version 3.3.3; Fixes RHBZ#2041012

epel9
Fabio Valentini 3 years ago
parent 3ea3f80d0d
commit 183b3a3b65
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,2 +1,3 @@
/brotli-3.3.0.crate
/brotli-3.3.2.crate
/brotli-3.3.3.crate

@ -1,6 +1,6 @@
--- brotli-3.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ brotli-3.3.2/Cargo.toml 2021-08-01T09:36:59.757364+00:00
@@ -22,6 +22,7 @@
--- brotli-3.3.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ brotli-3.3.3/Cargo.toml 2022-01-26T22:42:36.376000+00:00
@@ -22,17 +22,11 @@
keywords = ["brotli", "decompression", "lz77", "huffman", "nostd"]
license = "BSD-3-Clause/MIT"
repository = "https://github.com/dropbox/rust-brotli"
@ -8,25 +8,36 @@
[profile.release]
lto = true
incremental = false
@@ -44,12 +45,8 @@
-[[bin]]
-name = "brotli"
-doc = false
-
-[[bin]]
-name = "catbrotli"
-doc = false
[dependencies.alloc-no-stdlib]
version = "2.0"
@@ -44,12 +38,8 @@
version = "~2.3"
default-features = false
-[dependencies.packed_simd]
-[dependencies.packed_simd_2]
-version = "0.3"
-optional = true
-
[dependencies.sha2]
-version = "~0.8"
+version = "0.9"
+version = "~0.9"
optional = true
[features]
@@ -60,7 +57,6 @@
@@ -60,7 +50,6 @@
ffi-api = []
pass-through-ffi-panics = []
seccomp = ["brotli-decompressor/seccomp"]
-simd = ["packed_simd/into_bits"]
-simd = ["packed_simd_2/into_bits"]
std = ["alloc-stdlib", "brotli-decompressor/std"]
validation = ["sha2"]
vector_scratch_space = []

@ -1,4 +1,4 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 20
# https://github.com/dropbox/rust-brotli/issues/42
%if 0%{?__isa_bits} == 32
%bcond_with check
@ -7,15 +7,12 @@
%endif
%global debug_package %{nil}
# The binary is useless and conflicts with original brotli
%global __cargo_is_bin() false
%global crate brotli
Name: rust-%{crate}
Version: 3.3.2
Version: 3.3.3
Release: %autorelease
Summary: Brotli compressor and decompressor avoiding the rust stdlib
Summary: Brotli compressor and decompressor with no_std support
# Upstream license specification: BSD-3-Clause/MIT
# * https://github.com/dropbox/rust-brotli/issues/41
@ -23,15 +20,13 @@ License: BSD
URL: https://crates.io/crates/brotli
Source: %{crates_source}
# Initial patched metadata
# * Drop unwanted binaries
# * Exclude unneeded files, https://github.com/dropbox/rust-brotli/pull/43
# * Exclude simd feature (broken dependencies)
# * Exclude simd feature (missing dependencies)
# * Bump sha2 dependency from 0.8 to 0.9
Patch0: brotli-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -50,8 +45,8 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
@ -64,8 +59,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -76,8 +71,8 @@ BuildArch: noarch
%description -n %{name}+alloc-stdlib-devel %{_description}
This package contains library source intended for building other packages
which use "alloc-stdlib" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "alloc-stdlib" feature of the "%{crate}" crate.
%files -n %{name}+alloc-stdlib-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -88,8 +83,8 @@ BuildArch: noarch
%description -n %{name}+benchmark-devel %{_description}
This package contains library source intended for building other packages
which use "benchmark" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "benchmark" feature of the "%{crate}" crate.
%files -n %{name}+benchmark-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -100,8 +95,8 @@ BuildArch: noarch
%description -n %{name}+disable-timer-devel %{_description}
This package contains library source intended for building other packages
which use "disable-timer" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "disable-timer" feature of the "%{crate}" crate.
%files -n %{name}+disable-timer-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -112,8 +107,8 @@ BuildArch: noarch
%description -n %{name}+external-literal-probability-devel %{_description}
This package contains library source intended for building other packages
which use "external-literal-probability" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "external-literal-probability" feature of the "%{crate}" crate.
%files -n %{name}+external-literal-probability-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -124,8 +119,8 @@ BuildArch: noarch
%description -n %{name}+ffi-api-devel %{_description}
This package contains library source intended for building other packages
which use "ffi-api" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "ffi-api" feature of the "%{crate}" crate.
%files -n %{name}+ffi-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -136,8 +131,8 @@ BuildArch: noarch
%description -n %{name}+pass-through-ffi-panics-devel %{_description}
This package contains library source intended for building other packages
which use "pass-through-ffi-panics" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "pass-through-ffi-panics" feature of the "%{crate}" crate.
%files -n %{name}+pass-through-ffi-panics-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -148,8 +143,8 @@ BuildArch: noarch
%description -n %{name}+seccomp-devel %{_description}
This package contains library source intended for building other packages
which use "seccomp" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "seccomp" feature of the "%{crate}" crate.
%files -n %{name}+seccomp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -160,8 +155,8 @@ BuildArch: noarch
%description -n %{name}+sha2-devel %{_description}
This package contains library source intended for building other packages
which use "sha2" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "sha2" feature of the "%{crate}" crate.
%files -n %{name}+sha2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -172,8 +167,8 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -184,8 +179,8 @@ BuildArch: noarch
%description -n %{name}+validation-devel %{_description}
This package contains library source intended for building other packages
which use "validation" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "validation" feature of the "%{crate}" crate.
%files -n %{name}+validation-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -196,8 +191,8 @@ BuildArch: noarch
%description -n %{name}+vector_scratch_space-devel %{_description}
This package contains library source intended for building other packages
which use "vector_scratch_space" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "vector_scratch_space" feature of the "%{crate}" crate.
%files -n %{name}+vector_scratch_space-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (brotli-3.3.2.crate) = 8d577b615bb3a818cc33c738e9dbf1561bc4a8d5bf70ecf03b936ccb6aac3dd317a0efc1200b41ce5f4ec09dfb407e3f6663e73b6fc1752be25dee96507d80a6
SHA512 (brotli-3.3.3.crate) = 6ef94342504a94fbf0f579388c20ff5c639a3a156973187907a13487afc3cf449f7082a5c03e51a7307b91364a1a931f4f19bc1af363eb3aac3d92f61ff9a854

Loading…
Cancel
Save