import rust-brotli-3.4.0-1.el9

i9ce changed/i9ce/rust-brotli-3.4.0-1.el9
MSVSphere Packaging Team 1 year ago
parent e8f06c789e
commit 11ed894723

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/brotli-3.4.0.crate

@ -0,0 +1 @@
964880c06bd4d3e747d4a2ee762b79930ac35e0b SOURCES/brotli-3.4.0.crate

Binary file not shown.

@ -1,14 +1,22 @@
--- brotli-3.3.4/Cargo.toml 1970-01-01T00:00:01+00:00 --- brotli-3.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ brotli-3.3.4/Cargo.toml 2022-08-10T20:41:04.497620+00:00 +++ brotli-3.4.0/Cargo.toml 2024-01-14T22:09:14.729914+00:00
@@ -19,36 +19,27 @@ @@ -28,34 +28,35 @@
documentation = "https://docs.rs/brotli/" "huffman",
readme = "README.md" "nostd",
keywords = ["brotli", "decompression", "lz77", "huffman", "nostd"] ]
-license = "BSD-3-Clause/MIT" -license = "BSD-3-Clause/MIT"
+license = "BSD-3-Clause" +license = "BSD-3-Clause"
repository = "https://github.com/dropbox/rust-brotli" repository = "https://github.com/dropbox/rust-brotli"
+exclude = ["/ci/", "/research/", "/.travis.yml", "/appveyor.yml", "uncorrode.py"] +exclude = [
+ + "/ci/",
+ "/corrosion/",
+ "/research/",
+ "/testdata/",
+ "/appveyor.yml",
+ "/rustfmt.toml",
+ "/uncorrode.py",
+]
[profile.release] [profile.release]
lto = true lto = true
incremental = false incremental = false
@ -20,6 +28,7 @@
-[[bin]] -[[bin]]
-name = "catbrotli" -name = "catbrotli"
-doc = false -doc = false
-
[dependencies.alloc-no-stdlib] [dependencies.alloc-no-stdlib]
version = "2.0" version = "2.0"
@ -29,25 +38,13 @@
optional = true optional = true
[dependencies.brotli-decompressor] [dependencies.brotli-decompressor]
-version = "~2.3" -version = "~2.5"
+version = "2.3" +version = "2.5"
default-features = false default-features = false
-[dependencies.packed_simd_2]
-version = "0.3"
-optional = true
-
[dependencies.sha2] [dependencies.sha2]
-version = "~0.8" -version = "~0.10"
+version = "0.9" +version = "0.10"
optional = true optional = true
[features] [features]
@@ -59,7 +50,6 @@
ffi-api = []
pass-through-ffi-panics = []
seccomp = ["brotli-decompressor/seccomp"]
-simd = ["packed_simd_2/into_bits"]
std = ["alloc-stdlib", "brotli-decompressor/std"]
validation = ["sha2"]
vector_scratch_space = []

@ -0,0 +1,3 @@
[package]
summary = "Brotli compressor and decompressor with no_std support"

@ -1,5 +1,6 @@
## START: Set by rpmautospec ## START: Set by rpmautospec
## (rpmautospec version 0.3.0) ## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua: %define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1; release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}")); base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
@ -7,7 +8,7 @@
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}} }%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec ## END: Set by rpmautospec
# Generated by rust2rpm 22 # Generated by rust2rpm 25
# * tests fail with OOM problems on 32-bit architectures: # * tests fail with OOM problems on 32-bit architectures:
# https://github.com/dropbox/rust-brotli/issues/42 # https://github.com/dropbox/rust-brotli/issues/42
%if 0%{?__isa_bits} == 32 %if 0%{?__isa_bits} == 32
@ -20,7 +21,7 @@
%global crate brotli %global crate brotli
Name: rust-brotli Name: rust-brotli
Version: 3.3.4 Version: 3.4.0
Release: %autorelease Release: %autorelease
Summary: Brotli compressor and decompressor with no_std support Summary: Brotli compressor and decompressor with no_std support
@ -30,23 +31,20 @@ Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * fix license in crate metadata: # * fix license in crate metadata:
# https://github.com/dropbox/rust-brotli/issues/41 # https://github.com/dropbox/rust-brotli/issues/41
# * bump sha2 dependency from 0.8 to 0.9
# * drop unwanted brotli and catbrotli binaries # * drop unwanted brotli and catbrotli binaries
# * drop simd feature (missing packed_simd2 dependency)
# * exclude files that are only useful for upstream development: # * exclude files that are only useful for upstream development:
# https://github.com/dropbox/rust-brotli/pull/43 # https://github.com/dropbox/rust-brotli/pull/43
Patch: brotli-fix-metadata.diff Patch: brotli-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: cargo-rpm-macros >= 24
BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Brotli compressor and decompressor with an interface avoiding the rust A brotli compressor and decompressor that with an interface avoiding the
stdlib. This makes it suitable for embedded devices and kernels. It is designed rust stdlib. This makes it suitable for embedded devices and kernels. It
with a pluggable allocator so that the standard lib's allocator may be is designed with a pluggable allocator so that the standard lib's
employed. The default build also includes a stdlib allocator and stream allocator may be employed. The default build also includes a stdlib
interface. Disable this with --features=no-stdlib. All included code is safe.} allocator and stream interface. Disable this with --features=no-stdlib.
All included code is safe.}
%description %{_description} %description %{_description}
@ -209,11 +207,11 @@ use the "vector_scratch_space" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep
# * remove executable bits from Rust source files: # * remove executable bits from Rust source files:
# https://github.com/dropbox/rust-brotli/pull/40 # https://github.com/dropbox/rust-brotli/pull/40
find -type f -name '*.rs' -executable -exec chmod -x '{}' + find -type f -name '*.rs' -executable -exec chmod -x '{}' +
%cargo_prep
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires
@ -230,22 +228,31 @@ find -type f -name '*.rs' -executable -exec chmod -x '{}' +
%endif %endif
%changelog %changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 3.3.4-1 * Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 3.4.0-1
- Rebuilt for MSVSphere 9.3 - Rebuilt for MSVSphere 9.3
* Wed Aug 10 2022 Fabio Valentini <decathorpe@gmail.com> 3.3.4-1 * Mon Jan 15 2024 Fabio Valentini <decathorpe@gmail.com> - 3.4.0-1
- Update to version 3.4.0; Fixes RHBZ#2241463
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Wed Aug 10 2022 Fabio Valentini <decathorpe@gmail.com> - 3.3.4-1
- Update to version 3.3.4; Fixes RHBZ#2070425 - Update to version 3.3.4; Fixes RHBZ#2070425
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 3.3.3-2 * Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Wed Jan 26 2022 Fabio Valentini <decathorpe@gmail.com> 3.3.3-1 * Wed Jan 26 2022 Fabio Valentini <decathorpe@gmail.com> - 3.3.3-1
- Update to version 3.3.3; Fixes RHBZ#2041012 - Update to version 3.3.3; Fixes RHBZ#2041012
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 3.3.2-2 * Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Sun Aug 01 2021 Fabio Valentini <decathorpe@gmail.com> 3.3.2-1 * Sun Aug 01 2021 Fabio Valentini <decathorpe@gmail.com> - 3.3.2-1
- Update to version 3.3.2; Fixes RHBZ#1988749 - Update to version 3.3.2; Fixes RHBZ#1988749
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.0-6 * Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.0-6

Loading…
Cancel
Save