parent
2244fe9457
commit
c367b84f59
@ -0,0 +1 @@
|
||||
/block-modes-0.3.2.crate
|
@ -0,0 +1,11 @@
|
||||
--- block-modes-0.3.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ block-modes-0.3.2/Cargo.toml 2019-04-28T09:42:52.939035+00:00
|
||||
@@ -28,7 +28,7 @@
|
||||
version = "0.3"
|
||||
|
||||
[dev-dependencies.hex-literal]
|
||||
-version = "0.1"
|
||||
+version = "0.2"
|
||||
|
||||
[features]
|
||||
default = ["std"]
|
@ -0,0 +1,89 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate block-modes
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.3.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Block cipher modes of operation
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
# https://github.com/RustCrypto/block-ciphers/issues/46
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/block-modes
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Update hex-literal to 0.2, https://github.com/RustCrypto/block-ciphers/pull/45
|
||||
Patch0: block-modes-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
BuildRequires: (crate(block-cipher-trait/default) >= 0.6.0 with crate(block-cipher-trait/default) < 0.7.0)
|
||||
BuildRequires: (crate(block-padding/default) >= 0.1.0 with crate(block-padding/default) < 0.2.0)
|
||||
%if %{with check}
|
||||
BuildRequires: (crate(aes-soft/default) >= 0.3.0 with crate(aes-soft/default) < 0.4.0)
|
||||
BuildRequires: (crate(hex-literal/default) >= 0.2.0 with crate(hex-literal/default) < 0.3.0)
|
||||
%endif
|
||||
|
||||
%global _description \
|
||||
Block cipher modes of operation.
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "std" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Apr 27 19:48:07 EEST 2019 Artem Polishchuk <ego.cordatus@gmail.com> - 0.3.2-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (block-modes-0.3.2.crate) = fe91a3f10a605b19d7bd86f1863ddee34965b708fb0f5700e954a19053b98e41db4cd7dc6031e0422315721d7d4913db89b3846fb08d90b5d30b90ce93861cb0
|
@ -0,0 +1 @@
|
||||
1
|
@ -0,0 +1,5 @@
|
||||
---
|
||||
standard-inventory-qcow2:
|
||||
qemu:
|
||||
# `cargo test` usually eats more than 1G.
|
||||
m: 4G
|
@ -0,0 +1,13 @@
|
||||
---
|
||||
- hosts: localhost
|
||||
roles:
|
||||
- role: standard-test-basic
|
||||
tags:
|
||||
- classic
|
||||
repositories:
|
||||
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||
dest: rust
|
||||
tests:
|
||||
- rust/cargo-test
|
||||
environment:
|
||||
pkg: rust-block-modes
|
Loading…
Reference in new issue