Release 0.51.0

Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
epel9
Robert-André Mauchin 6 years ago
parent 18d7215aae
commit 8e0854afe7

1
.gitignore vendored

@ -7,3 +7,4 @@
/bindgen-0.47.0.crate
/bindgen-0.48.1.crate
/bindgen-0.49.0.crate
/bindgen-0.51.0.crate

@ -1,11 +0,0 @@
--- bindgen-0.49.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ bindgen-0.49.0/Cargo.toml 2019-05-15T06:38:03.373873+00:00
@@ -53,7 +53,7 @@
optional = true
[dependencies.hashbrown]
-version = "0.1"
+version = "0.3"
[dependencies.lazy_static]
version = "1"

@ -1,52 +1,31 @@
# Generated by rust2rpm 9
# Generated by rust2rpm 10
%bcond_without check
%global crate bindgen
Name: rust-%{crate}
Version: 0.49.0
Release: 4%{?dist}
Version: 0.51.0
Release: 1%{?dist}
Summary: Automatically generates Rust FFI bindings to C and C++ libraries
# Upstream license specification: BSD-3-Clause
License: BSD
URL: https://crates.io/crates/bindgen
Source: %{crates_source}
# Initial patched metadata
# * Update hashbrown to 0.3, upstream is switching away from hashbrown
Patch0: bindgen-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: (crate(bitflags/default) >= 1.0.3 with crate(bitflags/default) < 2.0.0)
BuildRequires: (crate(cexpr/default) >= 0.3.3 with crate(cexpr/default) < 0.4.0)
BuildRequires: (crate(cfg-if/default) >= 0.1.0 with crate(cfg-if/default) < 0.2.0)
BuildRequires: (crate(clang-sys/clang_6_0) >= 0.28.0 with crate(clang-sys/clang_6_0) < 0.29.0)
BuildRequires: (crate(clang-sys/default) >= 0.28.0 with crate(clang-sys/default) < 0.29.0)
BuildRequires: (crate(clang-sys/runtime) >= 0.28.0 with crate(clang-sys/runtime) < 0.29.0)
BuildRequires: (crate(clap/default) >= 2.0.0 with crate(clap/default) < 3.0.0)
BuildRequires: (crate(env_logger/default) >= 0.6.0 with crate(env_logger/default) < 0.7.0)
BuildRequires: (crate(hashbrown/default) >= 0.3.0 with crate(hashbrown/default) < 0.4.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(peeking_take_while/default) >= 0.1.2 with crate(peeking_take_while/default) < 0.2.0)
BuildRequires: (crate(proc-macro2) >= 0.4.0 with crate(proc-macro2) < 0.5.0)
BuildRequires: (crate(quote) >= 0.6.0 with crate(quote) < 0.7.0)
BuildRequires: (crate(regex/default) >= 1.0.0 with crate(regex/default) < 2.0.0)
BuildRequires: (crate(shlex/default) >= 0.1.0 with crate(shlex/default) < 0.2.0)
BuildRequires: (crate(which/default) >= 1.0.0 with crate(which/default) < 3.0.0)
%if %{with check}
BuildRequires: (crate(clap/default) >= 2.0.0 with crate(clap/default) < 3.0.0)
BuildRequires: (crate(diff/default) >= 0.1.0 with crate(diff/default) < 0.2.0)
BuildRequires: (crate(shlex/default) >= 0.1.0 with crate(shlex/default) < 0.2.0)
%endif
%global _description %{expand:
Automatically generates Rust FFI bindings to C and C++ libraries.}
%description %{_description}
%if ! %{__cargo_skip_build}
%package -n %{crate}
Summary: %{summary}
@ -56,6 +35,7 @@ Summary: %{summary}
%license LICENSE
%doc README.md
%{_bindir}/bindgen
%endif
%package devel
Summary: %{summary}
@ -82,6 +62,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+clap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+clap-devel %{_description}
This package contains library source intended for building other packages
which use "clap" feature of "%{crate}" crate.
%files -n %{name}+clap-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+env_logger-devel
Summary: %{summary}
BuildArch: noarch
@ -206,6 +198,9 @@ which use "testing_only_libclang_5" feature of "%{crate}" crate.
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -218,6 +213,9 @@ which use "testing_only_libclang_5" feature of "%{crate}" crate.
%endif
%changelog
* Wed Jul 31 18:31:15 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.51.0-1
- Release 0.51.0
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.49.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (bindgen-0.49.0.crate) = 3b5213b30629e38e1bd4dd5a94aed1591db2519fe976e7d57f7e18c8846da343883540794a0b8c35fd68bdf35904257d022c8acedf50cf93b28c423270b2bd14
SHA512 (bindgen-0.51.0.crate) = ca68c2ce356b2cf542249442301e35dc941c92882d44150bf672d504c57bd595e6e1a7214c913ca4bcf406eeb670bd5d3a34735816e3ab85b6a9443fbc38c4e8

Loading…
Cancel
Save