Update to 0.46.0

epel9
Josh Stone 6 years ago
parent 1fb115d9e6
commit 2a47207730

1
.gitignore vendored

@ -3,3 +3,4 @@
/bindgen-0.42.2.crate
/bindgen-0.43.0.crate
/bindgen-0.43.1.crate
/bindgen-0.46.0.crate

@ -1,16 +0,0 @@
--- bindgen-0.43.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ bindgen-0.43.0/Cargo.toml 2018-11-04T08:28:26.571463+01:00
@@ -63,11 +63,11 @@
version = "0.1.2"
[dependencies.proc-macro2]
-version = "0.3.2, < 0.3.6"
+version = "0.4"
default-features = false
[dependencies.quote]
-version = "0.5"
+version = "0.6"
default-features = false
[dependencies.regex]

@ -4,7 +4,7 @@
%global crate bindgen
Name: rust-%{crate}
Version: 0.43.1
Version: 0.46.0
Release: 1%{?dist}
Summary: Automatically generates Rust FFI bindings to C and C++ libraries
@ -12,11 +12,6 @@ Summary: Automatically generates Rust FFI bindings to C and C++ libraries
License: BSD
URL: https://crates.io/crates/bindgen
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Update quote and proc-macro2
Patch0: bindgen-fix-metadata.diff
# https://github.com/rust-lang-nursery/rust-bindgen/pull/1409
Patch0001: 0001-Update-quote-and-proc-macro.patch
ExclusiveArch: %{rust_arches}
@ -28,14 +23,15 @@ BuildRequires: (crate(clang-sys/clang_6_0) >= 0.26.0 with crate(clang-sys/clang
BuildRequires: (crate(clang-sys/default) >= 0.26.0 with crate(clang-sys/default) < 0.27.0)
BuildRequires: (crate(clang-sys/runtime) >= 0.26.0 with crate(clang-sys/runtime) < 0.27.0)
BuildRequires: (crate(clap/default) >= 2.0.0 with crate(clap/default) < 3.0.0)
BuildRequires: (crate(env_logger/default) >= 0.5.0 with crate(env_logger/default) < 0.6.0)
BuildRequires: (crate(env_logger/default) >= 0.6.0 with crate(env_logger/default) < 0.7.0)
BuildRequires: (crate(hashbrown/default) >= 0.1.0 with crate(hashbrown/default) < 0.2.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(peeking_take_while/default) >= 0.1.2 with crate(peeking_take_while/default) < 0.2.0)
BuildRequires: (crate(proc-macro2) >= 0.4.0 with crate(proc-macro2) < 0.5.0)
BuildRequires: (crate(quote) >= 0.6.0 with crate(quote) < 0.7.0)
BuildRequires: (crate(regex/default) >= 1.0.0 with crate(regex/default) < 2.0.0)
BuildRequires: (crate(which/default) >= 1.0.2 with crate(which/default) < 2.0.0)
BuildRequires: (crate(which/default) >= 2.0.0 with crate(which/default) < 3.0.0)
%if %{with check}
BuildRequires: (crate(clap/default) >= 2.0.0 with crate(clap/default) < 3.0.0)
BuildRequires: (crate(diff/default) >= 0.1.0 with crate(diff/default) < 0.2.0)
@ -136,6 +132,9 @@ which use "logging" feature of "%{crate}" crate.
%endif
%changelog
* Mon Jan 14 2019 Josh Stone <jistone@redhat.com> - 0.46.0-1
- Update to 0.46.0
* Sat Nov 10 2018 Josh Stone <jistone@redhat.com> - 0.43.1-1
- Update to 0.43.1

@ -1 +1 @@
SHA512 (bindgen-0.43.1.crate) = b5d4f3f7c49952a64b8fdb045885e0ab1872f0d70253ee1c1749ae873fbdf0687b0289605b1e69726a8591faef26ccde91cc13ebbbd5e4b55ef62f28df7e3aab
SHA512 (bindgen-0.46.0.crate) = 1303b20d837d67891449495a3a0ec024c9ba8697e2ba82e891cad83d840f2c3d005eee6c147ae1ef2485ac49398a18e3dcb5c4ecf858f741424e68e077256bbd

Loading…
Cancel
Save