Update hashbrown to 0.3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent abd5aee3b8
commit 2a2f3cb23f
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,11 +1,11 @@
--- bindgen-0.49.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ bindgen-0.49.0/Cargo.toml 2019-04-14T20:45:44.491409+02:00
--- bindgen-0.49.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ bindgen-0.49.0/Cargo.toml 2019-05-15T06:38:03.373873+00:00
@@ -53,7 +53,7 @@
optional = true
[dependencies.hashbrown]
-version = "0.1"
+version = "0.2"
+version = "0.3"
[dependencies.lazy_static]
version = "1"

@ -1,19 +1,19 @@
# Generated by rust2rpm
# Generated by rust2rpm 9
%bcond_without check
%global crate bindgen
Name: rust-%{crate}
Version: 0.49.0
Release: 2%{?dist}
Summary: Automatically generates Rust FFI bindings to C and C++ libraries.
Release: 3%{?dist}
Summary: Automatically generates Rust FFI bindings to C and C++ libraries
# Upstream license specification: BSD-3-Clause
License: BSD
URL: https://crates.io/crates/bindgen
Source: %{crates_source}
# Initial patched metadata
# - Bump hashbrown to 0.2.0 https://github.com/rust-lang/rust-bindgen/pull/1551
# * Update hashbrown to 0.3, upstream is switching away from hashbrown
Patch0: bindgen-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -27,7 +27,7 @@ BuildRequires: (crate(clang-sys/default) >= 0.28.0 with crate(clang-sys/default
BuildRequires: (crate(clang-sys/runtime) >= 0.28.0 with crate(clang-sys/runtime) < 0.29.0)
BuildRequires: (crate(clap/default) >= 2.0.0 with crate(clap/default) < 3.0.0)
BuildRequires: (crate(env_logger/default) >= 0.6.0 with crate(env_logger/default) < 0.7.0)
BuildRequires: (crate(hashbrown/default) >= 0.2.0 with crate(hashbrown/default) < 0.3.0)
BuildRequires: (crate(hashbrown/default) >= 0.3.0 with crate(hashbrown/default) < 0.4.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(peeking_take_while/default) >= 0.1.2 with crate(peeking_take_while/default) < 0.2.0)
@ -42,8 +42,8 @@ BuildRequires: (crate(diff/default) >= 0.1.0 with crate(diff/default) < 0.2.0)
BuildRequires: (crate(shlex/default) >= 0.1.0 with crate(shlex/default) < 0.2.0)
%endif
%global _description \
Automatically generates Rust FFI bindings to C and C++ libraries.
%global _description %{expand:
Automatically generates Rust FFI bindings to C and C++ libraries.}
%description %{_description}
@ -130,6 +130,78 @@ which use "static" feature of "%{crate}" crate.
%files -n %{name}+static-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+testing_only_docs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_docs-devel %{_description}
This package contains library source intended for building other packages
which use "testing_only_docs" feature of "%{crate}" crate.
%files -n %{name}+testing_only_docs-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+testing_only_extra_assertions-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_extra_assertions-devel %{_description}
This package contains library source intended for building other packages
which use "testing_only_extra_assertions" feature of "%{crate}" crate.
%files -n %{name}+testing_only_extra_assertions-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+testing_only_libclang_3_8-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_3_8-devel %{_description}
This package contains library source intended for building other packages
which use "testing_only_libclang_3_8" feature of "%{crate}" crate.
%files -n %{name}+testing_only_libclang_3_8-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+testing_only_libclang_3_9-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_3_9-devel %{_description}
This package contains library source intended for building other packages
which use "testing_only_libclang_3_9" feature of "%{crate}" crate.
%files -n %{name}+testing_only_libclang_3_9-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+testing_only_libclang_4-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_4-devel %{_description}
This package contains library source intended for building other packages
which use "testing_only_libclang_4" feature of "%{crate}" crate.
%files -n %{name}+testing_only_libclang_4-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+testing_only_libclang_5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_5-devel %{_description}
This package contains library source intended for building other packages
which use "testing_only_libclang_5" feature of "%{crate}" crate.
%files -n %{name}+testing_only_libclang_5-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -146,6 +218,9 @@ which use "static" feature of "%{crate}" crate.
%endif
%changelog
* Wed May 15 08:38:03 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.49.0-3
- Update hashbrown to 0.3
* Sun Apr 14 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.49.0-2
- Rebuilt for hashbrown 0.2.0

Loading…
Cancel
Save