Update to version 0.59.2; Fixes RHBZ#2026817

epel9
Fabio Valentini 3 years ago
parent 06d88e02a0
commit 1b4fe4b742
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -15,3 +15,4 @@
/bindgen-0.56.0.crate /bindgen-0.56.0.crate
/bindgen-0.57.0.crate /bindgen-0.57.0.crate
/bindgen-0.59.1.crate /bindgen-0.59.1.crate
/bindgen-0.59.2.crate

@ -1,24 +1,6 @@
--- bindgen-0.59.1/Cargo.toml 1970-01-01T00:00:00+00:00 --- bindgen-0.59.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bindgen-0.59.1/Cargo.toml 2021-11-11T21:30:32.795129+00:00 +++ bindgen-0.59.2/Cargo.toml 2021-12-15T14:13:11.648974+00:00
@@ -38,7 +38,7 @@ @@ -100,7 +100,7 @@
version = "1.0.3"
[dependencies.cexpr]
-version = "0.5"
+version = "0.6"
[dependencies.clang-sys]
version = "1"
@@ -85,7 +85,7 @@
version = "1"
[dependencies.which]
-version = "3.0"
+version = "4.0"
optional = true
default-features = false
[dev-dependencies.clap]
@@ -101,7 +101,7 @@
version = "3" version = "3"
[features] [features]

@ -1,10 +1,10 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 20
%bcond_without check %bcond_without check
%global crate bindgen %global crate bindgen
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.59.1 Version: 0.59.2
Release: %autorelease Release: %autorelease
Summary: Automatically generates Rust FFI bindings to C and C++ libraries Summary: Automatically generates Rust FFI bindings to C and C++ libraries
@ -16,13 +16,9 @@ Source: %{crates_source}
# * No "runtime" feature by default. We can afford linking directly to libclang # * No "runtime" feature by default. We can afford linking directly to libclang
# and rebuild it for each SONAME change. This just makes it better integrated # and rebuild it for each SONAME change. This just makes it better integrated
# in distribution context. # in distribution context.
# * Bump which from 3.0 to 4.0
Patch0: bindgen-fix-metadata.diff Patch0: bindgen-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
@ -31,17 +27,51 @@ Automatically generates Rust FFI bindings to C and C++ libraries.}
%description %{_description} %description %{_description}
%if ! %{__cargo_skip_build}
%package -n %{crate} %package -n %{crate}
Summary: %{summary} Summary: %{summary}
# ASL 2.0 or MIT: rust-cexpr 0.6.0
# ASL 2.0 or MIT: rust-peeking_take_while 0.1.2
# ASL 2.0 or MIT: rust-rustc-hash 1.1.0
# ASL 2.0: rust-clang-sys 1.3.0
# BSD: rust-bindgen 0.59.2
# MIT or ASL 2.0: rust-bitflags 1.3.2
# MIT or ASL 2.0: rust-cfg-if 1.0.0
# MIT or ASL 2.0: rust-either 1.6.1
# MIT or ASL 2.0: rust-env_logger 0.9.0
# MIT or ASL 2.0: rust-glob 0.3.0
# MIT or ASL 2.0: rust-humantime 2.1.0
# MIT or ASL 2.0: rust-lazy_static 1.4.0
# MIT or ASL 2.0: rust-lazycell 1.3.0
# MIT or ASL 2.0: rust-libc 0.2.109
# MIT or ASL 2.0: rust-log 0.4.14
# MIT or ASL 2.0: rust-minimal-lexical 0.2.1
# MIT or ASL 2.0: rust-proc-macro2 1.0.33
# MIT or ASL 2.0: rust-quote 1.0.10
# MIT or ASL 2.0: rust-regex 1.5.4
# MIT or ASL 2.0: rust-regex-syntax 0.6.25
# MIT or ASL 2.0: rust-shlex 1.1.0
# MIT or ASL 2.0: rust-unicode-width 0.1.9
# MIT or ASL 2.0: rust-unicode-xid 0.2.2
# MIT or ASL 2.0: rust-vec_map 0.8.2
# MIT or ASL 2.0: rust-version_check 0.9.3
# MIT: rust-ansi_term0.11 0.11.0
# MIT: rust-atty 0.2.14
# MIT: rust-clap2 2.33.3
# MIT: rust-nom 7.1.0
# MIT: rust-strsim 0.10.0
# MIT: rust-textwrap0.11 0.11.0
# MIT: rust-which 4.2.2
# Unlicense or MIT: rust-aho-corasick 0.7.18
# Unlicense or MIT: rust-memchr 2.4.1
# Unlicense or MIT: rust-termcolor 1.1.2
License: BSD and ASL 2.0 and MIT
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
%files -n %{crate} %files -n %{crate}
%license LICENSE %license LICENSE
%doc README.md csmith-fuzzing/README.md %doc README.md
%{_bindir}/bindgen %{_bindir}/bindgen
%endif
%package devel %package devel
Summary: %{summary} Summary: %{summary}
@ -49,12 +79,12 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE
%doc README.md csmith-fuzzing/README.md %doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -63,8 +93,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -75,8 +105,8 @@ BuildArch: noarch
%description -n %{name}+clap-devel %{_description} %description -n %{name}+clap-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clap" feature of "%{crate}" crate. use the "clap" feature of the "%{crate}" crate.
%files -n %{name}+clap-devel %files -n %{name}+clap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -87,8 +117,8 @@ BuildArch: noarch
%description -n %{name}+env_logger-devel %{_description} %description -n %{name}+env_logger-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "env_logger" feature of "%{crate}" crate. use the "env_logger" feature of the "%{crate}" crate.
%files -n %{name}+env_logger-devel %files -n %{name}+env_logger-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -99,8 +129,8 @@ BuildArch: noarch
%description -n %{name}+log-devel %{_description} %description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "log" feature of "%{crate}" crate. use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel %files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -111,8 +141,8 @@ BuildArch: noarch
%description -n %{name}+logging-devel %{_description} %description -n %{name}+logging-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "logging" feature of "%{crate}" crate. use the "logging" feature of the "%{crate}" crate.
%files -n %{name}+logging-devel %files -n %{name}+logging-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -123,8 +153,8 @@ BuildArch: noarch
%description -n %{name}+runtime-devel %{_description} %description -n %{name}+runtime-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "runtime" feature of "%{crate}" crate. use the "runtime" feature of the "%{crate}" crate.
%files -n %{name}+runtime-devel %files -n %{name}+runtime-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -135,8 +165,8 @@ BuildArch: noarch
%description -n %{name}+static-devel %{_description} %description -n %{name}+static-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "static" feature of "%{crate}" crate. use the "static" feature of the "%{crate}" crate.
%files -n %{name}+static-devel %files -n %{name}+static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -147,8 +177,8 @@ BuildArch: noarch
%description -n %{name}+testing_only_docs-devel %{_description} %description -n %{name}+testing_only_docs-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "testing_only_docs" feature of "%{crate}" crate. use the "testing_only_docs" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_docs-devel %files -n %{name}+testing_only_docs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -159,8 +189,8 @@ BuildArch: noarch
%description -n %{name}+testing_only_extra_assertions-devel %{_description} %description -n %{name}+testing_only_extra_assertions-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "testing_only_extra_assertions" feature of "%{crate}" crate. use the "testing_only_extra_assertions" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_extra_assertions-devel %files -n %{name}+testing_only_extra_assertions-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -171,8 +201,8 @@ BuildArch: noarch
%description -n %{name}+testing_only_libclang_3_9-devel %{_description} %description -n %{name}+testing_only_libclang_3_9-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "testing_only_libclang_3_9" feature of "%{crate}" crate. use the "testing_only_libclang_3_9" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_3_9-devel %files -n %{name}+testing_only_libclang_3_9-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -183,8 +213,8 @@ BuildArch: noarch
%description -n %{name}+testing_only_libclang_4-devel %{_description} %description -n %{name}+testing_only_libclang_4-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "testing_only_libclang_4" feature of "%{crate}" crate. use the "testing_only_libclang_4" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_4-devel %files -n %{name}+testing_only_libclang_4-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -195,8 +225,8 @@ BuildArch: noarch
%description -n %{name}+testing_only_libclang_5-devel %{_description} %description -n %{name}+testing_only_libclang_5-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "testing_only_libclang_5" feature of "%{crate}" crate. use the "testing_only_libclang_5" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_5-devel %files -n %{name}+testing_only_libclang_5-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -207,8 +237,8 @@ BuildArch: noarch
%description -n %{name}+testing_only_libclang_9-devel %{_description} %description -n %{name}+testing_only_libclang_9-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "testing_only_libclang_9" feature of "%{crate}" crate. use the "testing_only_libclang_9" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_9-devel %files -n %{name}+testing_only_libclang_9-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -219,8 +249,8 @@ BuildArch: noarch
%description -n %{name}+which-devel %{_description} %description -n %{name}+which-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "which" feature of "%{crate}" crate. use the "which" feature of the "%{crate}" crate.
%files -n %{name}+which-devel %files -n %{name}+which-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -231,8 +261,8 @@ BuildArch: noarch
%description -n %{name}+which-rustfmt-devel %{_description} %description -n %{name}+which-rustfmt-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "which-rustfmt" feature of "%{crate}" crate. use the "which-rustfmt" feature of the "%{crate}" crate.
%files -n %{name}+which-rustfmt-devel %files -n %{name}+which-rustfmt-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (bindgen-0.59.1.crate) = 6e81999b8a07dfdaf3872a8fa86daae36508f1180c83da125d8494424fc64a947a486b0552c452e8797ce1448dd079e667713a310c98d19d5ac690f286dda11f SHA512 (bindgen-0.59.2.crate) = 14c49879c7443191b877957a4fd405c7f10a1e8b70016d91bf5fe33861fc5d71982a1c685c190e4f7922cedb6c8aefadac3b0b68cbe5578da791a8da6bfedf44

Loading…
Cancel
Save