Link with libclang instead of runtime detection

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent a59b0e6ce8
commit 0667b01dc0
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E

@ -0,0 +1,11 @@
--- bindgen-0.53.2/Cargo.toml 2020-03-09T23:18:21+00:00
+++ bindgen-0.53.2/Cargo.toml 2020-05-14T06:11:52.686170+00:00
@@ -100,7 +100,7 @@
version = "0.1"
[features]
-default = ["logging", "clap", "runtime", "which-rustfmt"]
+default = ["logging", "clap", "which-rustfmt"]
logging = ["env_logger", "log"]
runtime = ["clang-sys/runtime"]
static = ["clang-sys/static"]

@ -5,13 +5,18 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.53.2 Version: 0.53.2
Release: 1%{?dist} Release: 2%{?dist}
Summary: Automatically generates Rust FFI bindings to C and C++ libraries Summary: Automatically generates Rust FFI bindings to C and C++ libraries
# Upstream license specification: BSD-3-Clause # Upstream license specification: BSD-3-Clause
License: BSD License: BSD
URL: https://crates.io/crates/bindgen URL: https://crates.io/crates/bindgen
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * No "runtime" feature by default. We can afford linking directly to libclang
# and rebuild it for each SONAME change. This just makes it better integrated
# in distribution context.
Patch0: bindgen-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -262,6 +267,9 @@ which use "which-rustfmt" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Thu May 14 08:11:52 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.53.2-2
- Link with libclang instead of runtime detection
* Tue Mar 10 2020 Josh Stone <jistone@redhat.com> - 0.53.2-1 * Tue Mar 10 2020 Josh Stone <jistone@redhat.com> - 0.53.2-1
- Update to 0.53.2 - Update to 0.53.2

Loading…
Cancel
Save