Update to version 0.68.1; Fixes RHBZ#2168598

epel9
Fabio Valentini 1 year ago
parent bb66831929
commit de6440eba2
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,2 +1,3 @@
/bindgen-cli-0.62.0.crate
/bindgen-cli-0.63.0.crate
/bindgen-cli-0.68.1.crate

@ -1,16 +1,19 @@
--- bindgen-cli-0.63.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bindgen-cli-0.63.0/Cargo.toml 2023-01-30T17:45:54.622156+00:00
@@ -37,6 +37,8 @@
[dependencies.bindgen]
version = "=0.63.0"
+features = ["logging", "which-rustfmt"]
--- bindgen-cli-0.68.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bindgen-cli-0.68.1/Cargo.toml 2023-09-17T13:49:25.158864+00:00
@@ -46,7 +46,11 @@
features = [
"__cli",
"experimental",
+ "logging",
+ "prettyplease",
+ "which-rustfmt",
]
+default-features = false
[dependencies.clap]
version = "3"
@@ -55,7 +57,6 @@
[features]
version = "4"
@@ -72,7 +76,6 @@
__testing_only_libclang_9 = ["bindgen/__testing_only_libclang_9"]
default = [
"logging",
- "runtime",

@ -1,10 +1,10 @@
# Generated by rust2rpm 23
# Generated by rust2rpm 24
%bcond_without check
%global crate bindgen-cli
Name: rust-bindgen-cli
Version: 0.63.0
Version: 0.68.1
Release: %autorelease
Summary: Automatically generates Rust FFI bindings to C and C++ libraries
@ -15,7 +15,7 @@ Source: %{crates_source}
# * default to linking with libclang instead of using dlopen
Patch: bindgen-cli-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Automatically generates Rust FFI bindings to C and C++ libraries.}
@ -24,22 +24,26 @@ Automatically generates Rust FFI bindings to C and C++ libraries.}
%package -n %{crate}
Summary: %{summary}
# /usr/bin/bindgen was moved from bindgen to bindgen-cli with v0.61
Provides: bindgen = %{version}-%{release}
Obsoletes: bindgen < 0.61
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
# Apache-2.0
# Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# BSD-3-Clause
# MIT
# MIT OR Apache-2.0
# Unlicense OR MIT
License: BSD-3-Clause AND Apache-2.0 AND MIT AND Unicode-DFS-2016
License: BSD-3-Clause AND Apache-2.0 AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown
# /usr/bin/bindgen was moved from bindgen to bindgen-cli with v0.61
Provides: bindgen = %{version}-%{release}
Obsoletes: bindgen < 0.61
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc README.md
%{_bindir}/bindgen
@ -48,10 +52,12 @@ License: BSD-3-Clause AND Apache-2.0 AND MIT AND Unicode-DFS-2016
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build
%{cargo_license_summary}
%{cargo_license} > LICENSE.dependencies
%install
%cargo_install

@ -1 +1 @@
SHA512 (bindgen-cli-0.63.0.crate) = 5144e4b73c039a2c90a9568d43138c590e6691c98bf76d8e37e2adb47e9926c30592dd9944664b3d7c014f154a5c942d9331c7ef784266a36016877cf0ecf4e9
SHA512 (bindgen-cli-0.68.1.crate) = 0202022a31ab7b943ca7bedcae61b74d97018f1a8f203ff4c386862f776d2bbd66c45a4d34272e88951fd9f5273176b39f3afea3ef5560192667309546101164

Loading…
Cancel
Save