Update to 0.4.0; Fixes: RHBZ#2022244

epel9
Davide Cavalca 3 years ago
parent 105ebad6c2
commit cf9695d976

2
.gitignore vendored

@ -4,3 +4,5 @@
/below-0.3.0-vendor.tar.gz /below-0.3.0-vendor.tar.gz
/below-0.4.0.crate /below-0.4.0.crate
/below-0.4.0-vendor.tar.gz /below-0.4.0-vendor.tar.gz
/below-0.4.1.crate
/below-0.4.1-vendor.tar.gz

@ -1,6 +1,6 @@
diff -Naur a/patched-crates/below-common/Cargo.toml b/patched-crates/below-common/Cargo.toml diff -Naur a/patched-crates/below-common/Cargo.toml b/patched-crates/below-common/Cargo.toml
--- a/patched-crates/below-common/Cargo.toml 2021-10-27 13:13:54.321402732 -0700 --- a/patched-crates/below-common/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-common/Cargo.toml 2021-10-27 13:14:01.866441582 -0700 +++ b/patched-crates/below-common/Cargo.toml 2021-11-11 10:55:02.722814393 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -8,11 +8,11 @@ diff -Naur a/patched-crates/below-common/Cargo.toml b/patched-crates/below-commo
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below-common" name = "below-common"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-common/src/dateutil.rs b/patched-crates/below-common/src/dateutil.rs diff -Naur a/patched-crates/below-common/src/dateutil.rs b/patched-crates/below-common/src/dateutil.rs
--- a/patched-crates/below-common/src/dateutil.rs 2021-10-27 12:58:23.000000000 -0700 --- a/patched-crates/below-common/src/dateutil.rs 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-common/src/dateutil.rs 2021-10-27 13:14:26.157566663 -0700 +++ b/patched-crates/below-common/src/dateutil.rs 2021-11-11 10:55:02.723814398 -0800
@@ -302,7 +302,7 @@ @@ -302,7 +302,7 @@
let mut default_format = String::new(); let mut default_format = String::new();
let mut date_with_defaults = date.clone(); let mut date_with_defaults = date.clone();
@ -23,8 +23,8 @@ diff -Naur a/patched-crates/below-common/src/dateutil.rs b/patched-crates/below-
.chars() .chars()
.any(|ch| naive_format.contains(&format!("%{}", ch))) .any(|ch| naive_format.contains(&format!("%{}", ch)))
diff -Naur a/patched-crates/below-config/Cargo.toml b/patched-crates/below-config/Cargo.toml diff -Naur a/patched-crates/below-config/Cargo.toml b/patched-crates/below-config/Cargo.toml
--- a/patched-crates/below-config/Cargo.toml 2021-10-27 13:13:54.322402737 -0700 --- a/patched-crates/below-config/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-config/Cargo.toml 2021-10-27 13:14:01.867441588 -0700 +++ b/patched-crates/below-config/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -32,11 +32,11 @@ diff -Naur a/patched-crates/below-config/Cargo.toml b/patched-crates/below-confi
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below-config" name = "below-config"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below_derive/Cargo.toml b/patched-crates/below_derive/Cargo.toml diff -Naur a/patched-crates/below_derive/Cargo.toml b/patched-crates/below_derive/Cargo.toml
--- a/patched-crates/below_derive/Cargo.toml 2021-10-27 13:13:54.322402737 -0700 --- a/patched-crates/below_derive/Cargo.toml 2021-11-11 10:54:23.802601209 -0800
+++ b/patched-crates/below_derive/Cargo.toml 2021-10-27 13:14:01.868441593 -0700 +++ b/patched-crates/below_derive/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -44,11 +44,11 @@ diff -Naur a/patched-crates/below_derive/Cargo.toml b/patched-crates/below_deriv
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below_derive" name = "below_derive"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-dump/Cargo.toml b/patched-crates/below-dump/Cargo.toml diff -Naur a/patched-crates/below-dump/Cargo.toml b/patched-crates/below-dump/Cargo.toml
--- a/patched-crates/below-dump/Cargo.toml 2021-10-27 13:13:54.323402742 -0700 --- a/patched-crates/below-dump/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-dump/Cargo.toml 2021-10-27 13:14:01.869441598 -0700 +++ b/patched-crates/below-dump/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -56,11 +56,11 @@ diff -Naur a/patched-crates/below-dump/Cargo.toml b/patched-crates/below-dump/Ca
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below-dump" name = "below-dump"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-model/Cargo.toml b/patched-crates/below-model/Cargo.toml diff -Naur a/patched-crates/below-model/Cargo.toml b/patched-crates/below-model/Cargo.toml
--- a/patched-crates/below-model/Cargo.toml 2021-10-27 13:13:54.324402747 -0700 --- a/patched-crates/below-model/Cargo.toml 2021-11-11 10:54:23.799601192 -0800
+++ b/patched-crates/below-model/Cargo.toml 2021-10-27 13:14:01.869441598 -0700 +++ b/patched-crates/below-model/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -68,11 +68,11 @@ diff -Naur a/patched-crates/below-model/Cargo.toml b/patched-crates/below-model/
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below-model" name = "below-model"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-render/Cargo.toml b/patched-crates/below-render/Cargo.toml diff -Naur a/patched-crates/below-render/Cargo.toml b/patched-crates/below-render/Cargo.toml
--- a/patched-crates/below-render/Cargo.toml 2021-10-27 13:13:54.324402747 -0700 --- a/patched-crates/below-render/Cargo.toml 2021-11-11 10:54:23.800601198 -0800
+++ b/patched-crates/below-render/Cargo.toml 2021-10-27 13:14:01.869441598 -0700 +++ b/patched-crates/below-render/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -80,11 +80,11 @@ diff -Naur a/patched-crates/below-render/Cargo.toml b/patched-crates/below-rende
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below-render" name = "below-render"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-store/Cargo.toml b/patched-crates/below-store/Cargo.toml diff -Naur a/patched-crates/below-store/Cargo.toml b/patched-crates/below-store/Cargo.toml
--- a/patched-crates/below-store/Cargo.toml 2021-10-27 13:13:54.324402747 -0700 --- a/patched-crates/below-store/Cargo.toml 2021-11-11 10:54:23.800601198 -0800
+++ b/patched-crates/below-store/Cargo.toml 2021-10-27 13:14:01.869441598 -0700 +++ b/patched-crates/below-store/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -92,11 +92,11 @@ diff -Naur a/patched-crates/below-store/Cargo.toml b/patched-crates/below-store/
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below-store" name = "below-store"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-view/Cargo.toml b/patched-crates/below-view/Cargo.toml diff -Naur a/patched-crates/below-view/Cargo.toml b/patched-crates/below-view/Cargo.toml
--- a/patched-crates/below-view/Cargo.toml 2021-10-27 13:13:54.324402747 -0700 --- a/patched-crates/below-view/Cargo.toml 2021-11-11 10:54:23.801601203 -0800
+++ b/patched-crates/below-view/Cargo.toml 2021-10-27 13:14:01.870441603 -0700 +++ b/patched-crates/below-view/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -104,11 +104,11 @@ diff -Naur a/patched-crates/below-view/Cargo.toml b/patched-crates/below-view/Ca
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "below-view" name = "below-view"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/cgroupfs/Cargo.toml b/patched-crates/cgroupfs/Cargo.toml diff -Naur a/patched-crates/cgroupfs/Cargo.toml b/patched-crates/cgroupfs/Cargo.toml
--- a/patched-crates/cgroupfs/Cargo.toml 2021-10-27 13:13:54.324402747 -0700 --- a/patched-crates/cgroupfs/Cargo.toml 2021-11-11 10:54:23.807601236 -0800
+++ b/patched-crates/cgroupfs/Cargo.toml 2021-10-27 13:14:01.870441603 -0700 +++ b/patched-crates/cgroupfs/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -116,11 +116,11 @@ diff -Naur a/patched-crates/cgroupfs/Cargo.toml b/patched-crates/cgroupfs/Cargo.
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "cgroupfs" name = "cgroupfs"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/fb_procfs/Cargo.toml b/patched-crates/fb_procfs/Cargo.toml diff -Naur a/patched-crates/fb_procfs/Cargo.toml b/patched-crates/fb_procfs/Cargo.toml
--- a/patched-crates/fb_procfs/Cargo.toml 2021-10-27 13:13:54.325402752 -0700 --- a/patched-crates/fb_procfs/Cargo.toml 2021-11-11 10:54:23.838601406 -0800
+++ b/patched-crates/fb_procfs/Cargo.toml 2021-10-27 13:14:01.870441603 -0700 +++ b/patched-crates/fb_procfs/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents. # See Cargo.toml.orig for the original contents.
@ -128,40 +128,42 @@ diff -Naur a/patched-crates/fb_procfs/Cargo.toml b/patched-crates/fb_procfs/Carg
-edition = "2021" -edition = "2021"
+edition = "2018" +edition = "2018"
name = "fb_procfs" name = "fb_procfs"
version = "0.4.0" version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"] authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/libbpf-cargo/Cargo.toml b/patched-crates/libbpf-cargo/Cargo.toml diff -Naur a/patched-crates/libbpf-cargo/Cargo.toml b/patched-crates/libbpf-cargo/Cargo.toml
--- a/patched-crates/libbpf-cargo/Cargo.toml 2021-10-27 13:13:54.325402752 -0700 --- a/patched-crates/libbpf-cargo/Cargo.toml 2021-11-11 10:54:23.848601461 -0800
+++ b/patched-crates/libbpf-cargo/Cargo.toml 2021-10-27 13:14:01.870441603 -0700 +++ b/patched-crates/libbpf-cargo/Cargo.toml 2021-11-11 10:55:28.898957781 -0800
@@ -35,7 +35,7 @@ @@ -35,7 +35,7 @@
version = "0.12" version = "0.12"
[dependencies.libbpf-sys] [dependencies.libbpf-sys]
-version = "0.5.0-1" -version = "0.5.0-2"
+version = "0.4.0-2" +version = "0.4.0-2"
[dependencies.memmap2] [dependencies.memmap2]
version = "0.3" version = "0.3"
diff -Naur a/patched-crates/libbpf-rs/Cargo.toml b/patched-crates/libbpf-rs/Cargo.toml diff -Naur a/patched-crates/libbpf-rs/Cargo.toml b/patched-crates/libbpf-rs/Cargo.toml
--- a/patched-crates/libbpf-rs/Cargo.toml 2021-10-27 13:13:54.325402752 -0700 --- a/patched-crates/libbpf-rs/Cargo.toml 2021-11-11 10:54:23.856601505 -0800
+++ b/patched-crates/libbpf-rs/Cargo.toml 2021-10-27 13:14:01.870441603 -0700 +++ b/patched-crates/libbpf-rs/Cargo.toml 2021-11-11 10:55:48.192063468 -0800
@@ -24,7 +24,7 @@ @@ -24,7 +24,7 @@
version = "1.3" version = "1.3"
[dependencies.libbpf-sys] [dependencies.libbpf-sys]
-version = "0.5.0-1" -version = "0.5.0-2"
+version = "0.4.0-2" +version = "0.4.0-2"
[dependencies.nix] [dependencies.nix]
version = "0.22" version = "0.22"
diff -Naur a/patched-crates/libbpf-rs/src/object.rs b/patched-crates/libbpf-rs/src/object.rs diff -Naur a/patched-crates/libbpf-rs/src/object.rs b/patched-crates/libbpf-rs/src/object.rs
--- a/patched-crates/libbpf-rs/src/object.rs 2021-10-27 12:58:23.000000000 -0700 --- a/patched-crates/libbpf-rs/src/object.rs 2021-11-11 10:54:23.857601510 -0800
+++ b/patched-crates/libbpf-rs/src/object.rs 2021-10-27 13:19:44.254204545 -0700 +++ b/patched-crates/libbpf-rs/src/object.rs 2021-11-11 10:56:05.745159628 -0800
@@ -67,7 +67,6 @@ @@ -67,9 +67,6 @@
pin_root_path: ptr::null(), pin_root_path: ptr::null(),
attach_prog_fd: 0, attach_prog_fd: 0,
kconfig: ptr::null(), kconfig: ptr::null(),
- btf_custom_path: ptr::null(), - btf_custom_path: ptr::null(),
- __bindgen_padding_0: <[u8; 6]>::default(),
- __bindgen_padding_1: <[u8; 4]>::default(),
} }
} }

@ -16,7 +16,7 @@
%global forgeurl https://github.com/facebookincubator/below %global forgeurl https://github.com/facebookincubator/below
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.4.0 Version: 0.4.1
Release: %autorelease Release: %autorelease
Summary: Interactive tool to view and record historical system data Summary: Interactive tool to view and record historical system data

@ -1,2 +1,2 @@
SHA512 (below-0.4.0.crate) = ce536583048c4866b890f1298e3ca45071594f10c84b313f566725b747ccccd4ec39ad2d1560a63cebcc4c574989c57d73e64ec9e619ba93bea3b399271ed540 SHA512 (below-0.4.1.crate) = 1e67ad09248c8ae457932857fbee21375d1ea71020ba8254e08f1d43473ef400ac31189771e4ae02b6e199cec1a12fed6d4cde0320224ff844a39c12668e0375
SHA512 (below-0.4.0-vendor.tar.gz) = 841822049b8d3a42135b108a77c9c90e09ce55a8c26390e0e1ea05bab3581be6b05e954ffc49a2e3ca7db3c98048466f51807403847a8e40e222f279a714435f SHA512 (below-0.4.1-vendor.tar.gz) = 7d93a19ec33feae4ae7649bfc8125a958a4b4cb0899d047f132f48e503bff6b9daac3ef298926d3e690431ef6a482d8d2c0bf2fa45904fbc18234a376e5043ce

@ -1,5 +1,9 @@
#!/bin/sh #!/bin/sh
if [ "$1" == --prepare ]; then
PREPARE=1
fi
name='below' name='below'
specfile="rust-${name}.spec" specfile="rust-${name}.spec"
version=$(rpm -q --qf '%{VERSION}\n' --specfile "$specfile" | head -1) version=$(rpm -q --qf '%{VERSION}\n' --specfile "$specfile" | head -1)
@ -15,7 +19,9 @@ fi
[ -f "$crate" ] || spectool -g "$specfile" [ -f "$crate" ] || spectool -g "$specfile"
tardir="$PWD" tardir="$PWD"
workdir=$(mktemp -d) workdir=$(mktemp -d)
trap 'rm -rf "$workdir"' EXIT if [ ! -n "$PREPARE" ]; then
trap 'rm -rf "$workdir"' EXIT
fi
# All the below crates use edition 2021, which isn't supported by rust in el8; # All the below crates use edition 2021, which isn't supported by rust in el8;
# moreover, libbpf-rs and libbpf-cargo transitively depend on libbpf 0.5.0, and # moreover, libbpf-rs and libbpf-cargo transitively depend on libbpf 0.5.0, and
@ -42,10 +48,15 @@ for c in below_derive below-common below-config below-dump below-model below-ren
mv "${workdir}/${nv}/vendor/${c}" "${workdir}/${nv}/patched-crates/" mv "${workdir}/${nv}/vendor/${c}" "${workdir}/${nv}/patched-crates/"
done done
rm -r "${workdir}/${nv}/vendor" rm -r "${workdir}/${nv}/vendor"
(cd "${workdir}/${nv}" && \ (cd "${workdir}/${nv}" && patch -p1 < ${tardir}/below-fix-metadata.diff)
patch -p1 < ${tardir}/below-fix-metadata.diff && \ if [ -n "$PREPARE" ]; then
patch -p1 < ${tardir}/below-patched-crates.patch && \ echo "Go to ${workdir} and update the patch"
cargo vendor && \ exit 1
tar cvzf "${tardir}/${vendor_tarball}" patched-crates/ vendor/) else
(cd "${workdir}/${nv}" && \
patch -p1 < ${tardir}/below-patched-crates.patch && \
cargo vendor && \
tar cvzf "${tardir}/${vendor_tarball}" patched-crates/ vendor/)
fi
exit 0 exit 0

Loading…
Cancel
Save