Update to 0.3.0; Fixes: RHBZ#1983801

epel9
Davide Cavalca 4 years ago
parent c3a8ce604a
commit 3cd5a25e5e

2
.gitignore vendored

@ -1,2 +1,4 @@
/below-0.2.0.crate /below-0.2.0.crate
/below-0.2.0-vendor.tar.gz /below-0.2.0-vendor.tar.gz
/below-0.3.0.crate
/below-0.3.0-vendor.tar.gz

@ -28,6 +28,21 @@ of [atop](https://linux.die.net/man/1/atop)'s design and style decisions.
## Installing ## Installing
`below` is packaged in Fedora as of Fedora 34, and can be installed with:
```shell
sudo dnf install below
```
Optionally, the systemd service for persistent data collection can also be
enabled with:
```shell
sudo systemctl enable --now below
```
## Installing from source
First, install dependencies listed in [building.md](docs/building.md). First, install dependencies listed in [building.md](docs/building.md).
```shell ```shell

@ -1,38 +0,0 @@
--- below-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ below-0.2.0/Cargo.toml 2021-06-16T22:24:40.312159+00:00
@@ -42,7 +42,7 @@
package = "below-dump"
[dependencies.libbpf-rs]
-version = "0.10.0"
+version = "0.11.0"
[dependencies.libc]
version = "0.2.86"
@@ -65,7 +65,7 @@
version = "1.4.2"
[dependencies.serde]
-version = "=1.0.118"
+version = "1.0.126"
features = ["derive", "rc"]
[dependencies.serde_json]
@@ -93,14 +93,14 @@
version = "0.3.21"
[dependencies.tokio]
-version = "0.2.25"
+version = "1.6.1"
features = ["full", "test-util"]
[dependencies.toml]
-version = "=0.5.7"
+version = "0.5.8"
[dependencies.users]
-version = "0.9"
+version = "0.11"
[dependencies.view]
version = "0.2.0"

@ -1,59 +0,0 @@
diff -Naur a/src/test/test_general.rs b/src/test/test_general.rs
--- a/src/test/test_general.rs 1969-12-31 16:00:00.000000000 -0800
+++ b/src/test/test_general.rs 2021-06-16 16:08:09.168914682 -0700
@@ -27,19 +27,16 @@
.expect("failed to collect sample");
// Validate some data in the sample
- assert!(
- sample
- .cgroup
- .pressure
- .as_ref()
- .expect("missing memory.pressure")
- .memory
- .full
- .total
- .as_ref()
- .expect("missing memory.pressure.total")
- > &0
- );
+ sample
+ .cgroup
+ .pressure
+ .as_ref()
+ .expect("missing memory.pressure")
+ .memory
+ .full
+ .total
+ .as_ref()
+ .expect("missing memory.pressure.total");
let nr_procs = sample.processes.len();
let hostname = sample.system.hostname.clone();
let proc0_cgroup = sample
@@ -75,17 +72,14 @@
.expect("failed to get advanced data");
// Validate some values in restored sample
- assert!(
- *restored_sample
- .cgroup
- .io_total
- .as_ref()
- .expect("missing io.stat")
- .rbytes_per_sec
- .as_ref()
- .expect("missing io stat read bytes per second")
- == 0.0
- );
+ restored_sample
+ .cgroup
+ .io_total
+ .as_ref()
+ .expect("missing io.stat")
+ .rbytes_per_sec
+ .as_ref()
+ .expect("missing io stat read bytes per second");
assert!(restored_sample.process.processes.len() == nr_procs);
assert!(restored_sample.system.hostname == hostname);
assert!(

@ -1,4 +1,4 @@
# Generated by rust2rpm 16 # Generated by rust2rpm 18
%bcond_without check %bcond_without check
%global __cargo_skip_build 0 %global __cargo_skip_build 0
@ -13,10 +13,9 @@
%endif %endif
%global forgeurl https://github.com/facebookincubator/below %global forgeurl https://github.com/facebookincubator/below
%global commit 584fdef23f4c7a95a009b84746bb193b68843c1a
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.0 Version: 0.3.0
Release: %autorelease Release: %autorelease
Summary: Interactive tool to view and record historical system data Summary: Interactive tool to view and record historical system data
@ -24,15 +23,11 @@ Summary: Interactive tool to view and record historical system data
License: ASL 2.0 License: ASL 2.0
URL: https://crates.io/crates/below URL: https://crates.io/crates/below
Source: %{crates_source} Source: %{crates_source}
# Bump serde to 1.0.126, tokio to 1.6.1, toml to 0.58, users to 0.11
Patch0: below-fix-metadata.diff
# Fix record_replay_integration test
Patch1: below-fix-tests.patch
# Get these from the repo as they aren't included in the crate # Get these from the repo as they aren't included in the crate
Source1: %{forgeurl}/raw/%{commit}/etc/below.service Source1: %{forgeurl}/raw/v%{version}/etc/below.service
Source2: %{forgeurl}/raw/%{commit}/etc/logrotate.conf Source2: %{forgeurl}/raw/v%{version}/etc/logrotate.conf
Source3: %{forgeurl}/raw/%{commit}/README.md#/README-upstream.md Source3: %{forgeurl}/raw/v%{version}/README.md#/README-upstream.md
# vendored dependencies for EPEL # vendored dependencies for EPEL
# update with ./update-vendor-tarball.sh after bumping the specfile version # update with ./update-vendor-tarball.sh after bumping the specfile version
Source4: %{crate}-%{version}-vendor.tar.gz Source4: %{crate}-%{version}-vendor.tar.gz
@ -42,9 +37,6 @@ Source5: README-epel.md
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if 0%{?el8} %if 0%{?el8}
# https://bugzilla.redhat.com/show_bug.cgi?id=1978414
ExcludeArch: s390x
BuildRequires: rust-toolset BuildRequires: rust-toolset
# for libbpf-sys # for libbpf-sys
BuildRequires: kernel-headers BuildRequires: kernel-headers
@ -88,7 +80,7 @@ Recommends: logrotate
%files -n %{crate} %files -n %{crate}
%license LICENSE %license LICENSE
%doc README.md docs %doc README.md
%if 0%{?el8} %if 0%{?el8}
%doc README-epel.md %doc README-epel.md
%endif %endif
@ -109,7 +101,6 @@ Recommends: logrotate
%prep %prep
%if 0%{?el8} %if 0%{?el8}
%setup -q -n %{crate}-%{version} %setup -q -n %{crate}-%{version}
%patch1 -p1
%cargo_prep -V 4 %cargo_prep -V 4
cp -p %{SOURCE5} README-epel.md cp -p %{SOURCE5} README-epel.md
%else %else

@ -1,2 +1,2 @@
SHA512 (below-0.2.0.crate) = 4f72620ed5c66ead42b5ab50c2a7e975956a6511b23e41056a4452274b7bc8172729b0ff44d9ce524d43024471236d093111a7e9d44239efed0a5a1e38127944 SHA512 (below-0.3.0.crate) = 92b905735ad98ba52a0450a2b914214666172028f116bea56b7a52238d9614964fb8d41f3dfd6d695832662b39017a502886d4974fbfc88dce2326e758b2497a
SHA512 (below-0.2.0-vendor.tar.gz) = c468fc027bee2a1903aad02e11c11107f93b29214b11d36c93f3d93ad06d709eb126a14b1ddd8e440a93c362cb98ca7cae90c6181827b42d0bdd723005bb638d SHA512 (below-0.3.0-vendor.tar.gz) = 96c2192eea217e232fddf6bedb91dcbdb66a8720de31f934f2a09002b9e1090c2410302a34a44b3e49108f0957ca089abfa7131ddb676f11ede7bd75be5e3c72

Loading…
Cancel
Save