Update to 0.3.0; Files: RHBZ#1983808

epel9
Davide Cavalca 4 years ago
parent 61968fbe63
commit a0d0019ea5

1
.gitignore vendored

@ -1 +1,2 @@
/below-view-0.2.0.crate /below-view-0.2.0.crate
/below-view-0.3.0.crate

@ -1,21 +0,0 @@
diff -Naur a/src/lib.rs b/src/lib.rs
--- a/src/lib.rs 1969-12-31 16:00:00.000000000 -0800
+++ b/src/lib.rs 2021-06-16 15:12:14.380997374 -0700
@@ -15,7 +15,7 @@
/// View Module defines how to render below inside terminal.
///
/// ## High level architecture
-/// ```
+/// ```text
/// ------------------------------------------------------------
/// | Status Bar |
/// ------------------------------------------------------------
@@ -31,7 +31,7 @@
/// * Stats View: Display the detailed stats. Please check the stats view section for more details.
///
/// ### Stats View
-/// ```
+/// ```text
/// ------------------------------------------------------------
/// | Tabs |
/// | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~|

@ -1,17 +1,19 @@
--- below-view-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00 --- below-view-0.3.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ below-view-0.2.0/Cargo.toml 2021-06-16T21:13:17.615123+00:00 +++ below-view-0.3.0/Cargo.toml 2021-07-30T20:59:47.625361+00:00
@@ -60,7 +60,7 @@ @@ -31,7 +31,7 @@
package = "below-render" package = "below-common"
[dependencies.serde] [dependencies.crossterm]
-version = "=1.0.118" -version = "0.20.0"
+version = "1.0.126" +version = "0.19.0"
features = ["derive", "rc"] features = ["event-stream"]
[dependencies.slog] [dependencies.cursive]
@@ -72,4 +72,4 @@ @@ -72,6 +72,6 @@
package = "below-store" package = "below-store"
[dependencies.toml] [dependencies.toml]
-version = "=0.5.7" -version = "=0.5.7"
+version = "0.5.8" +version = "0.5.8"
[dev-dependencies.tempdir]
version = "0.3"

@ -1,11 +1,11 @@
# Generated by rust2rpm 17 # Generated by rust2rpm 18
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate below-view %global crate below-view
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.0 Version: 0.3.0
Release: %autorelease Release: %autorelease
Summary: View crate for below Summary: View crate for below
@ -13,10 +13,8 @@ Summary: View crate for below
License: ASL 2.0 License: ASL 2.0
URL: https://crates.io/crates/below-view URL: https://crates.io/crates/below-view
Source: %{crates_source} Source: %{crates_source}
# Bump serde to 1.0.126 and toml to 0.58 # Bump toml to 0.58 and downgrade crossterm to 0.19
Patch0: below-view-fix-metadata.diff Patch0: below-view-fix-metadata.diff
# Mark rustdoc text as text
Patch1: below-view-fix-build.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}

@ -1 +1 @@
SHA512 (below-view-0.2.0.crate) = 4cfde9ccd0f0dfa64fb9ec75c5219e37a3032e6941de77465403c68503463d5bcbc0a3217364d3847fb55f3cbf6c2c103951af4cceb69cf09a26867ee66475a1 SHA512 (below-view-0.3.0.crate) = 4834133b235c6092e93782d26f4b5618f7028d0ac2deb185eec1b4dd83d798d1484e7ae6fa7d9429e219ab17327281613b00c3f71718749a2ba6e293a3f007b1

Loading…
Cancel
Save