import #1972931
parent
454163187b
commit
6cb35a9b9f
@ -0,0 +1 @@
|
||||
/below-view-0.2.0.crate
|
@ -0,0 +1,21 @@
|
||||
diff -Naur a/src/lib.rs b/src/lib.rs
|
||||
--- a/src/lib.rs 1969-12-31 16:00:00.000000000 -0800
|
||||
+++ b/src/lib.rs 2021-06-16 15:12:14.380997374 -0700
|
||||
@@ -15,7 +15,7 @@
|
||||
/// View Module defines how to render below inside terminal.
|
||||
///
|
||||
/// ## High level architecture
|
||||
-/// ```
|
||||
+/// ```text
|
||||
/// ------------------------------------------------------------
|
||||
/// | Status Bar |
|
||||
/// ------------------------------------------------------------
|
||||
@@ -31,7 +31,7 @@
|
||||
/// * Stats View: Display the detailed stats. Please check the stats view section for more details.
|
||||
///
|
||||
/// ### Stats View
|
||||
-/// ```
|
||||
+/// ```text
|
||||
/// ------------------------------------------------------------
|
||||
/// | Tabs |
|
||||
/// | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~|
|
@ -0,0 +1,17 @@
|
||||
--- below-view-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ below-view-0.2.0/Cargo.toml 2021-06-16T21:13:17.615123+00:00
|
||||
@@ -60,7 +60,7 @@
|
||||
package = "below-render"
|
||||
|
||||
[dependencies.serde]
|
||||
-version = "=1.0.118"
|
||||
+version = "1.0.126"
|
||||
features = ["derive", "rc"]
|
||||
|
||||
[dependencies.slog]
|
||||
@@ -72,4 +72,4 @@
|
||||
package = "below-store"
|
||||
|
||||
[dependencies.toml]
|
||||
-version = "=0.5.7"
|
||||
+version = "0.5.8"
|
@ -0,0 +1,78 @@
|
||||
# Generated by rust2rpm 17
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate below-view
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: View crate for below
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/below-view
|
||||
Source: %{crates_source}
|
||||
# Bump serde to 1.0.126 and toml to 0.58
|
||||
Patch0: below-view-fix-metadata.diff
|
||||
# Mark rustdoc text as text
|
||||
Patch1: below-view-fix-build.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
View crate for below.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jun 16 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.2.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue