Drop unused lessopen feature and its dependencies

epel10
Fabio Valentini 4 months ago
parent e20a76760b
commit 0f2beed71e
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,5 +1,5 @@
--- bat-0.24.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- bat-0.24.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bat-0.24.0/Cargo.toml 2024-06-02T20:59:58.535240+00:00 +++ bat-0.24.0/Cargo.toml 2024-10-23T21:47:41.348860+00:00
@@ -199,13 +199,8 @@ @@ -199,13 +199,8 @@
regex-fancy = ["syntect/regex-fancy"] regex-fancy = ["syntect/regex-fancy"]
regex-onig = ["syntect/regex-onig"] regex-onig = ["syntect/regex-onig"]

@ -1,5 +1,5 @@
--- bat-0.24.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- bat-0.24.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bat-0.24.0/Cargo.toml 2024-06-02T21:00:30.381361+00:00 +++ bat-0.24.0/Cargo.toml 2024-10-23T21:49:08.185292+00:00
@@ -24,7 +24,7 @@ @@ -24,7 +24,7 @@
homepage = "https://github.com/sharkdp/bat" homepage = "https://github.com/sharkdp/bat"
readme = "README.md" readme = "README.md"
@ -9,7 +9,7 @@
repository = "https://github.com/sharkdp/bat" repository = "https://github.com/sharkdp/bat"
[profile.release] [profile.release]
@@ -85,18 +85,17 @@ @@ -85,25 +85,16 @@
optional = true optional = true
[dependencies.nu-ansi-term] [dependencies.nu-ansi-term]
@ -19,18 +19,33 @@
[dependencies.once_cell] [dependencies.once_cell]
version = "1.18" version = "1.18"
[dependencies.os_str_bytes] -[dependencies.os_str_bytes]
-version = "~6.4" -version = "~6.4"
-optional = true -optional = true
- -
-[dependencies.path_abs] -[dependencies.path_abs]
-version = "0.5" -version = "0.5"
-default-features = false -default-features = false
+version = "6.4"
+optional = true
+
+[dependencies.path-absolutize] +[dependencies.path-absolutize]
+version = "3" +version = "3"
[dependencies.regex] [dependencies.regex]
version = "1.8.3" version = "1.8.3"
-optional = true
-
-[dependencies.run_script]
-version = "^0.10.0"
optional = true
[dependencies.semver]
@@ -181,10 +172,6 @@
]
default = ["application"]
git = ["git2"]
-lessopen = [
- "run_script",
- "os_str_bytes",
-]
minimal-application = [
"clap",
"etcetera",

@ -19,8 +19,8 @@ Patch: bat-fix-metadata-auto.diff
# * port from path_abs to path-absolutize: # * port from path_abs to path-absolutize:
# https://github.com/sharkdp/bat/pull/1025 # https://github.com/sharkdp/bat/pull/1025
# * bump nu-ansi-term from 0.49.0 to 0.50.0 # * bump nu-ansi-term from 0.49.0 to 0.50.0
# * relax os_str_bytes dependency from ~6.4 to ^6.4
# * adapt license tag to reflect bundled content # * adapt license tag to reflect bundled content
# * drop unused lessopen feature and its dependencies
Patch: bat-fix-metadata.diff Patch: bat-fix-metadata.diff
Patch: 0001-port-from-path_abs-to-path-absolutize.patch Patch: 0001-port-from-path_abs-to-path-absolutize.patch
@ -359,18 +359,6 @@ use the "grep-cli" feature of the "%{crate}" crate.
%files -n %{name}+grep-cli-devel %files -n %{name}+grep-cli-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lessopen-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lessopen-devel %{_description}
This package contains library source intended for building other packages which
use the "lessopen" feature of the "%{crate}" crate.
%files -n %{name}+lessopen-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+minimal-application-devel %package -n %{name}+minimal-application-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -383,18 +371,6 @@ use the "minimal-application" feature of the "%{crate}" crate.
%files -n %{name}+minimal-application-devel %files -n %{name}+minimal-application-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+os_str_bytes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os_str_bytes-devel %{_description}
This package contains library source intended for building other packages which
use the "os_str_bytes" feature of the "%{crate}" crate.
%files -n %{name}+os_str_bytes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+paging-devel %package -n %{name}+paging-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -443,18 +419,6 @@ use the "regex-onig" feature of the "%{crate}" crate.
%files -n %{name}+regex-onig-devel %files -n %{name}+regex-onig-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+run_script-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+run_script-devel %{_description}
This package contains library source intended for building other packages which
use the "run_script" feature of the "%{crate}" crate.
%files -n %{name}+run_script-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+shell-words-devel %package -n %{name}+shell-words-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -2,8 +2,8 @@
cargo-toml-patch-comments = [ cargo-toml-patch-comments = [
"port from path_abs to path-absolutize: https://github.com/sharkdp/bat/pull/1025", "port from path_abs to path-absolutize: https://github.com/sharkdp/bat/pull/1025",
"bump nu-ansi-term from 0.49.0 to 0.50.0", "bump nu-ansi-term from 0.49.0 to 0.50.0",
"relax os_str_bytes dependency from ~6.4 to ^6.4",
"adapt license tag to reflect bundled content", "adapt license tag to reflect bundled content",
"drop unused lessopen feature and its dependencies",
] ]
extra-files = [ extra-files = [
"%{_mandir}/man1/bat.1*", "%{_mandir}/man1/bat.1*",

Loading…
Cancel
Save