Update to 0.11.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent 1359c315e7
commit b4fe18bc02
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -5,3 +5,4 @@
/base64-0.9.2.crate
/base64-0.9.3.crate
/base64-0.10.1.crate
/base64-0.11.0.crate

@ -1,22 +0,0 @@
From afac000c8b89059e3ea1d22477a22ec31d6f6856 Mon Sep 17 00:00:00 2001
From: Marshall Pierce <marshall@mpierce.org>
Date: Fri, 12 Jul 2019 11:54:33 -0600
Subject: [PATCH] Fix compat issue with beta rust
---
src/decode.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/decode.rs b/src/decode.rs
index ae34230..9c9916c 100644
--- a/src/decode.rs
+++ b/src/decode.rs
@@ -55,7 +55,7 @@ impl error::Error for DecodeError {
}
}
- fn cause(&self) -> Option<&error::Error> {
+ fn cause(&self) -> Option<&dyn error::Error> {
None
}
}

@ -1,39 +0,0 @@
From e923d5f45668e4dd8b8bc3109f4e1b664a386053 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?=
<30413512+eclipseo@users.noreply.github.com>
Date: Fri, 13 Sep 2019 18:13:37 +0200
Subject: [PATCH] Bump criterion to 0.3
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
---
benches/benchmarks.rs | 4 ++--
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/benches/benchmarks.rs b/benches/benchmarks.rs
index e6ae3d2..475dfdb 100644
--- a/benches/benchmarks.rs
+++ b/benches/benchmarks.rs
@@ -124,7 +124,7 @@ fn encode_benchmarks(byte_sizes: &[usize]) -> ParameterizedBenchmark<usize> {
ParameterizedBenchmark::new("encode", do_encode_bench, byte_sizes.iter().cloned())
.warm_up_time(std::time::Duration::from_millis(500))
.measurement_time(std::time::Duration::from_secs(3))
- .throughput(|s| Throughput::Bytes(*s as u32))
+ .throughput(|s| Throughput::Bytes(*s as u64))
.with_function("encode_display", do_encode_bench_display)
.with_function("encode_reuse_buf", do_encode_bench_reuse_buf)
.with_function("encode_slice", do_encode_bench_slice)
@@ -135,7 +135,7 @@ fn decode_benchmarks(byte_sizes: &[usize]) -> ParameterizedBenchmark<usize> {
ParameterizedBenchmark::new("decode", do_decode_bench, byte_sizes.iter().cloned())
.warm_up_time(std::time::Duration::from_millis(500))
.measurement_time(std::time::Duration::from_secs(3))
- .throughput(|s| Throughput::Bytes(*s as u32))
+ .throughput(|s| Throughput::Bytes(*s as u64))
.with_function("decode_reuse_buf", do_decode_bench_reuse_buf)
.with_function("decode_slice", do_decode_bench_slice)
}
--
2.21.0

@ -1,27 +1,18 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 11
%bcond_without check
%global debug_package %{nil}
%global crate base64
Name: rust-%{crate}
Version: 0.10.1
Release: 6%{?dist}
Version: 0.11.0
Release: 1%{?dist}
Summary: Encodes and decodes base64 as bytes or utf8
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/base64
Source: %{crates_source}
# Initial patched metadata
# - Bump criterion to 0.3 https://github.com/marshallpierce/rust-base64/pull/117
Patch0: base64-fix-metadata.diff
# Fix compat issue with beta rust
# https://github.com/marshallpierce/rust-base64/commit/afac000c8b89059e3ea1d22477a22ec31d6f6856
Patch1: https://github.com/marshallpierce/rust-base64/commit/afac000c8b89059e3ea1d22477a22ec31d6f6856.patch#/0001-Fix-compat-issue-with-beta-rust.patch
# criterion 0.3: Throughput has been expanded from u32 to u64 to accommodate very large input sizes.
Patch2: 0001-Throughput-has-been-expanded-from-u32-to-u64.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -61,6 +52,30 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -80,6 +95,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Thu Dec 05 15:34:06 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.0-1
- Update to 0.11.0
* Fri Sep 13 18:10:48 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.10.1-6
- Bump criterion to 0.3

@ -1 +1 @@
SHA512 (base64-0.10.1.crate) = 674a8cbee95a41f755499a4e3bb93ebd3f80140c3e8e2d44a0b73890ee423754e7ba8abcd92132683cd54501ff5d14438d023a202eaf12776aecbe36df9e5535
SHA512 (base64-0.11.0.crate) = 31b5f56d4907a5e4ae40e92ef1629a446126525186f5236afc2475829bf2e5e067554db200a18f7b3ab741d0cc9c01e20612e77cc0cbc1bc2a4a8d11c0fdbf33

Loading…
Cancel
Save