parent
2c3b0f8278
commit
3393ae50c9
@ -0,0 +1,22 @@
|
|||||||
|
From afac000c8b89059e3ea1d22477a22ec31d6f6856 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Marshall Pierce <marshall@mpierce.org>
|
||||||
|
Date: Fri, 12 Jul 2019 11:54:33 -0600
|
||||||
|
Subject: [PATCH] Fix compat issue with beta rust
|
||||||
|
|
||||||
|
---
|
||||||
|
src/decode.rs | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/decode.rs b/src/decode.rs
|
||||||
|
index ae34230..9c9916c 100644
|
||||||
|
--- a/src/decode.rs
|
||||||
|
+++ b/src/decode.rs
|
||||||
|
@@ -55,7 +55,7 @@ impl error::Error for DecodeError {
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- fn cause(&self) -> Option<&error::Error> {
|
||||||
|
+ fn cause(&self) -> Option<&dyn error::Error> {
|
||||||
|
None
|
||||||
|
}
|
||||||
|
}
|
@ -0,0 +1,53 @@
|
|||||||
|
From e923d5f45668e4dd8b8bc3109f4e1b664a386053 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?=
|
||||||
|
<30413512+eclipseo@users.noreply.github.com>
|
||||||
|
Date: Fri, 13 Sep 2019 18:13:37 +0200
|
||||||
|
Subject: [PATCH] Bump criterion to 0.3
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
|
||||||
|
---
|
||||||
|
Cargo.toml | 2 +-
|
||||||
|
benches/benchmarks.rs | 4 ++--
|
||||||
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Cargo.toml b/Cargo.toml
|
||||||
|
index 107537a..736b0c9 100644
|
||||||
|
--- a/Cargo.toml
|
||||||
|
+++ b/Cargo.toml
|
||||||
|
@@ -16,7 +16,7 @@ name = "benchmarks"
|
||||||
|
harness = false
|
||||||
|
|
||||||
|
[dev-dependencies]
|
||||||
|
-criterion = "0.2"
|
||||||
|
+criterion = "0.3"
|
||||||
|
rand = "0.6.1"
|
||||||
|
doc-comment = "0.3"
|
||||||
|
|
||||||
|
diff --git a/benches/benchmarks.rs b/benches/benchmarks.rs
|
||||||
|
index e6ae3d2..475dfdb 100644
|
||||||
|
--- a/benches/benchmarks.rs
|
||||||
|
+++ b/benches/benchmarks.rs
|
||||||
|
@@ -124,7 +124,7 @@ fn encode_benchmarks(byte_sizes: &[usize]) -> ParameterizedBenchmark<usize> {
|
||||||
|
ParameterizedBenchmark::new("encode", do_encode_bench, byte_sizes.iter().cloned())
|
||||||
|
.warm_up_time(std::time::Duration::from_millis(500))
|
||||||
|
.measurement_time(std::time::Duration::from_secs(3))
|
||||||
|
- .throughput(|s| Throughput::Bytes(*s as u32))
|
||||||
|
+ .throughput(|s| Throughput::Bytes(*s as u64))
|
||||||
|
.with_function("encode_display", do_encode_bench_display)
|
||||||
|
.with_function("encode_reuse_buf", do_encode_bench_reuse_buf)
|
||||||
|
.with_function("encode_slice", do_encode_bench_slice)
|
||||||
|
@@ -135,7 +135,7 @@ fn decode_benchmarks(byte_sizes: &[usize]) -> ParameterizedBenchmark<usize> {
|
||||||
|
ParameterizedBenchmark::new("decode", do_decode_bench, byte_sizes.iter().cloned())
|
||||||
|
.warm_up_time(std::time::Duration::from_millis(500))
|
||||||
|
.measurement_time(std::time::Duration::from_secs(3))
|
||||||
|
- .throughput(|s| Throughput::Bytes(*s as u32))
|
||||||
|
+ .throughput(|s| Throughput::Bytes(*s as u64))
|
||||||
|
.with_function("decode_reuse_buf", do_decode_bench_reuse_buf)
|
||||||
|
.with_function("decode_slice", do_decode_bench_slice)
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- base64-0.10.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ base64-0.10.1/Cargo.toml 2019-09-13T16:10:47.978838+00:00
|
||||||
|
@@ -30,7 +30,7 @@
|
||||||
|
[dependencies.byteorder]
|
||||||
|
version = "1.2.6"
|
||||||
|
[dev-dependencies.criterion]
|
||||||
|
-version = "0.2"
|
||||||
|
+version = "0.3"
|
||||||
|
|
||||||
|
[dev-dependencies.rand]
|
||||||
|
version = "0.6.1"
|
Loading…
Reference in new issue