Update to version 0.3.74; Fixes RHBZ#2310767

epel10 imports/epel10/rust-backtrace-0.3.74-1.el10
Fabio Valentini 5 months ago
parent 8625b09dde
commit e0edd9d304
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -28,3 +28,4 @@
/backtrace-0.3.67.crate /backtrace-0.3.67.crate
/backtrace-0.3.69.crate /backtrace-0.3.69.crate
/backtrace-0.3.73.crate /backtrace-0.3.73.crate
/backtrace-0.3.74.crate

@ -1,31 +1,11 @@
--- backtrace-0.3.73/Cargo.toml 1970-01-01T00:00:01+00:00 --- backtrace-0.3.74/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.73/Cargo.toml 2024-07-24T18:48:04.168995+00:00 +++ backtrace-0.3.74/Cargo.toml 2024-09-16T21:48:56.255999+00:00
@@ -121,18 +121,6 @@ @@ -143,8 +143,6 @@
std = []
unix-backtrace = []
verify-winapi = [
- "winapi/dbghelp",
- "winapi/handleapi",
- "winapi/libloaderapi",
- "winapi/memoryapi",
- "winapi/minwindef",
- "winapi/processthreadsapi",
- "winapi/synchapi",
- "winapi/tlhelp32",
- "winapi/winbase",
- "winapi/winnt",
- "winapi/winnls",
- "winapi/stringapiset",
]
[target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.addr2line]
@@ -160,9 +148,6 @@
] ]
default-features = false default-features = false
-[target."cfg(windows)".dependencies.winapi] -[target."cfg(windows)".dependencies.windows-targets]
-version = "0.3.9" -version = "0.52.6"
-optional = true
- -
[lints.rust] [lints.rust]
unexpected_cfgs = "allow" unexpected_cfgs = "allow"

@ -1,7 +1,7 @@
--- backtrace-0.3.73/Cargo.toml 1970-01-01T00:00:01+00:00 --- backtrace-0.3.74/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.73/Cargo.toml 2024-07-24T18:48:25.715217+00:00 +++ backtrace-0.3.74/Cargo.toml 2024-09-16T21:49:07.938082+00:00
@@ -61,20 +61,8 @@ @@ -45,20 +45,8 @@
edition = "2021" required-features = ["std"]
[[test]] [[test]]
-name = "accuracy" -name = "accuracy"
@ -21,12 +21,3 @@
harness = false harness = false
required-features = ["std"] required-features = ["std"]
@@ -124,7 +112,7 @@
]
[target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.addr2line]
-version = "0.22.0"
+version = "0.24.0"
default-features = false
[target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.libc]

@ -5,7 +5,7 @@
%global crate backtrace %global crate backtrace
Name: rust-backtrace Name: rust-backtrace
Version: 0.3.73 Version: 0.3.74
Release: %autorelease Release: %autorelease
Summary: Library to acquire a stack trace (backtrace) at runtime in a Rust program Summary: Library to acquire a stack trace (backtrace) at runtime in a Rust program

@ -9,7 +9,6 @@ hide = [
"kernel32", "kernel32",
"libunwind", "libunwind",
"unix-backtrace", "unix-backtrace",
"verify-winapi",
] ]
[scripts] [scripts]

@ -1 +1 @@
SHA512 (backtrace-0.3.73.crate) = dacedfd32cb91fe408e4f395441baf09c0a4b3bc4ba8f79d088359455cc903c93d24969567c7c5b2feb806433ffbb63a526d73f53caa4bee9c51961b61f831d9 SHA512 (backtrace-0.3.74.crate) = 00cb2be0626f0bf6ec8b8f525bb129d3ac74c386c5e46ee0f343edb78c863222521f8132876057a5a1facacf40792dea51f2f20e986b35f3a85bca3dcf5c1520

Loading…
Cancel
Save