Update to version 0.3.66; Fixes RHBZ#2076300

epel9
Fabio Valentini 3 years ago
parent bce065ef87
commit 68934b7e90
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -24,3 +24,4 @@
/backtrace-0.3.59.crate /backtrace-0.3.59.crate
/backtrace-0.3.61.crate /backtrace-0.3.61.crate
/backtrace-0.3.64.crate /backtrace-0.3.64.crate
/backtrace-0.3.66.crate

@ -0,0 +1,21 @@
--- backtrace-0.3.66/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.66/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -121,18 +121,5 @@
std = []
unix-backtrace = []
verify-winapi = [
- "winapi/dbghelp",
- "winapi/handleapi",
- "winapi/libloaderapi",
- "winapi/memoryapi",
- "winapi/minwindef",
- "winapi/processthreadsapi",
- "winapi/synchapi",
- "winapi/tlhelp32",
- "winapi/winbase",
- "winapi/winnt",
]
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-optional = true

@ -1,6 +1,14 @@
--- backtrace-0.3.64/Cargo.toml 1970-01-01T00:00:01+00:00 --- backtrace-0.3.66/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.64/Cargo.toml 2022-02-03T14:55:24.935091+00:00 +++ backtrace-0.3.66/Cargo.toml 2022-08-09T09:33:39.983784+00:00
@@ -42,11 +42,6 @@ @@ -25,6 +25,7 @@
readme = "README.md"
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-lang/backtrace-rs"
+exclude = ["/ci/"]
[[example]]
name = "backtrace"
@@ -44,11 +45,6 @@
[[test]] [[test]]
name = "smoke" name = "smoke"
@ -12,23 +20,3 @@
required-features = ["std"] required-features = ["std"]
edition = "2018" edition = "2018"
@@ -96,19 +91,9 @@
version = "1.0.67"
[features]
-coresymbolication = []
-dbghelp = []
default = ["std"]
-dladdr = []
gimli-symbolize = []
-kernel32 = []
libbacktrace = []
-libunwind = []
serialize-rustc = ["rustc-serialize"]
serialize-serde = ["serde"]
std = []
-unix-backtrace = []
-verify-winapi = ["winapi/dbghelp", "winapi/handleapi", "winapi/libloaderapi", "winapi/memoryapi", "winapi/minwindef", "winapi/processthreadsapi", "winapi/synchapi", "winapi/tlhelp32", "winapi/winbase", "winapi/winnt"]
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-optional = true

@ -1,26 +1,28 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 22
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate backtrace %global crate backtrace
Name: rust-%{crate} Name: rust-backtrace
Version: 0.3.64 Version: 0.3.66
Release: %autorelease Release: %autorelease
Summary: Library to acquire a stack trace (backtrace) at runtime in a Rust program Summary: Library to acquire a stack trace (backtrace) at runtime in a Rust program
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/backtrace URL: https://crates.io/crates/backtrace
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Automatically generated patch to strip foreign dependencies
# * Drop windows-specific dependencies and features Patch: backtrace-fix-metadata-auto.diff
# * Drop deprecated/internal features # Manually created patch for downstream crate metadata changes
Patch0: backtrace-fix-metadata.diff # * drop accuracy test (requires crates to be built in dylib mode)
# * exclude files for upstream CI
Patch: backtrace-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Library to acquire a stack trace (backtrace) at runtime in a Rust program.} Library to acquire a stack trace (backtrace) at runtime in a Rust program.}
@ -37,10 +39,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%exclude %{cargo_registry}/%{crate}-%{version_no_tilde}/ci/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -52,7 +54,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cpp_demangle-devel %package -n %{name}+cpp_demangle-devel
Summary: %{summary} Summary: %{summary}
@ -64,7 +66,7 @@ This package contains library source intended for building other packages which
use the "cpp_demangle" feature of the "%{crate}" crate. use the "cpp_demangle" feature of the "%{crate}" crate.
%files -n %{name}+cpp_demangle-devel %files -n %{name}+cpp_demangle-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+gimli-symbolize-devel %package -n %{name}+gimli-symbolize-devel
Summary: %{summary} Summary: %{summary}
@ -76,7 +78,7 @@ This package contains library source intended for building other packages which
use the "gimli-symbolize" feature of the "%{crate}" crate. use the "gimli-symbolize" feature of the "%{crate}" crate.
%files -n %{name}+gimli-symbolize-devel %files -n %{name}+gimli-symbolize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libbacktrace-devel %package -n %{name}+libbacktrace-devel
Summary: %{summary} Summary: %{summary}
@ -88,7 +90,7 @@ This package contains library source intended for building other packages which
use the "libbacktrace" feature of the "%{crate}" crate. use the "libbacktrace" feature of the "%{crate}" crate.
%files -n %{name}+libbacktrace-devel %files -n %{name}+libbacktrace-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc-serialize-devel %package -n %{name}+rustc-serialize-devel
Summary: %{summary} Summary: %{summary}
@ -100,7 +102,7 @@ This package contains library source intended for building other packages which
use the "rustc-serialize" feature of the "%{crate}" crate. use the "rustc-serialize" feature of the "%{crate}" crate.
%files -n %{name}+rustc-serialize-devel %files -n %{name}+rustc-serialize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -112,7 +114,7 @@ This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-rustc-devel %package -n %{name}+serialize-rustc-devel
Summary: %{summary} Summary: %{summary}
@ -124,7 +126,7 @@ This package contains library source intended for building other packages which
use the "serialize-rustc" feature of the "%{crate}" crate. use the "serialize-rustc" feature of the "%{crate}" crate.
%files -n %{name}+serialize-rustc-devel %files -n %{name}+serialize-rustc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-serde-devel %package -n %{name}+serialize-serde-devel
Summary: %{summary} Summary: %{summary}
@ -136,7 +138,7 @@ This package contains library source intended for building other packages which
use the "serialize-serde" feature of the "%{crate}" crate. use the "serialize-serde" feature of the "%{crate}" crate.
%files -n %{name}+serialize-serde-devel %files -n %{name}+serialize-serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -148,7 +150,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -168,12 +170,9 @@ rm -r tests/accuracy/
%if %{with check} %if %{with check}
%check %check
# https://github.com/rust-lang/backtrace-rs/issues/204 # https://github.com/rust-lang/backtrace-rs/issues/204
%ifarch %{ix86} ppc64le aarch64 s390x # * smoke_test_frames: fails on all architectures
%cargo_test || : # * backtrace_new_unresolved_should_start_with_call_site_trace: fails on aarch64, ppc64le, s390x
%else %cargo_test -- -- --skip smoke_test_frames --skip backtrace_new_unresolved_should_start_with_call_site_trace
# some tests can't find symbols in release mode
%cargo_test -- -- --skip smoke_test_frames
%endif
%endif %endif
%changelog %changelog

@ -0,0 +1,9 @@
[DEFAULT]
unwanted-features =
coresymbolication
dbghelp
dladdr
kernel32
libunwind
unix-backtrace
verify-winapi

@ -1 +1 @@
SHA512 (backtrace-0.3.64.crate) = 37435cca0587c1c7b511536478ff448914d423c9cf6152ec8bb884c19d1c2466c377b270ebce2028960b4a380f3152fbfeb940de943ef4071ed271c7cd576f2e SHA512 (backtrace-0.3.66.crate) = 7370ce52d0b949a6faa05f91225f60928e42e52c00ed2ba4054ef7efd41cd65c77b0e67c8afb9d5bf834eb4b1451b642720521e17d1954be810e3c5fc70bf646

Loading…
Cancel
Save