commit
48e27aa65c
@ -0,0 +1,24 @@
|
|||||||
|
From 4613c06f3db9818ed7165c18fc6e89c13ab3e526 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Sun, 23 Jul 2023 22:15:00 +0200
|
||||||
|
Subject: [PATCH] deny(warnings) considered harmful
|
||||||
|
|
||||||
|
---
|
||||||
|
src/lib.rs | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib.rs b/src/lib.rs
|
||||||
|
index be8a2cc..be34c6f 100644
|
||||||
|
--- a/src/lib.rs
|
||||||
|
+++ b/src/lib.rs
|
||||||
|
@@ -120,7 +120,6 @@ additional terms or conditions.
|
||||||
|
#![no_std]
|
||||||
|
#![warn(missing_docs)]
|
||||||
|
#![doc(html_root_url = "https://docs.rs/az/~1.2")]
|
||||||
|
-#![doc(test(attr(deny(warnings))))]
|
||||||
|
#![cfg_attr(feature = "fail-on-warnings", deny(warnings))]
|
||||||
|
|
||||||
|
#[cfg(test)]
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
Binary file not shown.
@ -0,0 +1,126 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 4;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate az
|
||||||
|
|
||||||
|
Name: rust-az
|
||||||
|
Version: 1.2.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Casts and checked casts
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/az
|
||||||
|
Source: %{crates_source}
|
||||||
|
Patch: 0001-deny-warnings-considered-harmful.patch
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Casts and checked casts.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/RELEASES.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+fail-on-warnings-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+fail-on-warnings-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "fail-on-warnings" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+fail-on-warnings-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.2.1-4
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Sun Jul 23 2023 Fabio Valentini <decathorpe@gmail.com> - 1.2.1-4
|
||||||
|
- Remove deny(warnings) lint from doctests
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 26 2022 Fabio Valentini <decathorpe@gmail.com> - 1.2.1-1
|
||||||
|
- Update to version 1.2.1; Fixes RHBZ#2110618
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Dec 10 2021 Rémi Lauzier <remilauzier@protonmail.com> - 1.2.0-1
|
||||||
|
- Update to version 1.2.0; Fixes RHBZ#2026315
|
||||||
|
|
||||||
|
* Wed Aug 25 2021 Rémi Lauzier <remilauzier@protonmail.com> - 1.1.2-1
|
||||||
|
- Update to version 1.1.2; Fixes RHBZ#1996843
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 19 2021 Rémi Lauzier <remilauzier@protonmail.com> - 1.1.1-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue