Update to 1.0.0

epel9
Josh Stone 5 years ago
parent 874fd5390b
commit 047daa08c8

1
.gitignore vendored

@ -4,3 +4,4 @@
/autocfg-0.1.5.crate /autocfg-0.1.5.crate
/autocfg-0.1.6.crate /autocfg-0.1.6.crate
/autocfg-0.1.7.crate /autocfg-0.1.7.crate
/autocfg-1.0.0.crate

@ -1,39 +0,0 @@
From 1915a0ac72e22fef906351858478eebadf81c4cf Mon Sep 17 00:00:00 2001
From: Josh Stone <cuviper@gmail.com>
Date: Tue, 19 Nov 2019 14:06:44 -0800
Subject: [PATCH] Use the test's current_exe() to find the target dir
---
tests/rustflags.rs | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)
diff --git a/tests/rustflags.rs b/tests/rustflags.rs
index bfa0f03ee0ef..119376c409a8 100644
--- a/tests/rustflags.rs
+++ b/tests/rustflags.rs
@@ -1,13 +1,19 @@
extern crate autocfg;
+use std::env;
+
/// Tests that autocfg uses the RUSTFLAGS environment variable when running
/// rustc.
#[test]
fn test_with_sysroot() {
- std::env::set_var("RUSTFLAGS", "-L target/debug/deps -L target/debug");
- std::env::set_var("OUT_DIR", "target");
+ // Use the same path as this test binary.
+ let dir = env::current_exe().unwrap().parent().unwrap().to_path_buf();
+ env::set_var("RUSTFLAGS", &format!("-L {}", dir.display()));
+ env::set_var("OUT_DIR", &format!("{}", dir.display()));
+
// Ensure HOST != TARGET.
- std::env::set_var("HOST", "lol");
+ env::set_var("HOST", "lol");
+
let ac = autocfg::AutoCfg::new().unwrap();
assert!(ac.probe_sysroot_crate("autocfg"));
}
--
2.23.0

@ -1,22 +1,19 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 13
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate autocfg %global crate autocfg
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.1.7 Version: 1.0.0
Release: 1%{?dist} Release: 1%{?dist}
Summary: Automatic cfg for Rust compiler features Summary: Automatic cfg for Rust compiler features
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: Apache-2.0 OR MIT
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/autocfg URL: https://crates.io/crates/autocfg
Source: %{crates_source} Source: %{crates_source}
# https://github.com/cuviper/autocfg/pull/18
Patch1: 0001-Use-the-test-s-current_exe-to-find-the-target-dir.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
BuildArch: noarch BuildArch: noarch
@ -41,7 +38,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license LICENSE-APACHE LICENSE-MIT
%doc README.md %doc README.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -53,7 +50,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -74,6 +71,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Wed Jan 15 2020 Josh Stone <jistone@redhat.com> - 1.0.0-1
- Update to 1.0.0
* Tue Nov 19 2019 Josh Stone <jistone@redhat.com> - 0.1.7-1 * Tue Nov 19 2019 Josh Stone <jistone@redhat.com> - 0.1.7-1
- Update to 0.1.7 - Update to 0.1.7

@ -1 +1 @@
SHA512 (autocfg-0.1.7.crate) = 667ca520f2b46140d2f3519b43e5155426a6e7a2130879860eb10b974f84465600077f53abed4c0e6bf2612471f01786bfb3531ea8773d0f50f29d48e05f7925 SHA512 (autocfg-1.0.0.crate) = 451fc63148792ba1952b884170e3481359b01bacca5ec0456f43ca58f8e092b8f81c9764f8b00d4104059ff608089be5858220ee868127c064cc890c767ec3a3

Loading…
Cancel
Save