Update to version 0.12.0; Fixes RHBZ#2175662

epel9
Fabio Valentini 1 year ago
parent 21a67506ac
commit 75b2715da4
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/askama-0.10.5.crate /askama-0.10.5.crate
/askama-0.11.0.crate /askama-0.11.0.crate
/askama-0.11.1.crate /askama-0.11.1.crate
/askama-0.12.0.crate

@ -1,10 +1,25 @@
--- askama-0.11.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- askama-0.12.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ askama-0.11.1/Cargo.toml 2023-04-20T17:56:39.523486+00:00 +++ askama-0.12.0/Cargo.toml 2023-08-06T12:50:32.836608+00:00
@@ -37,7 +37,6 @@ @@ -44,11 +44,6 @@
config = ["askama_derive/config", "askama_shared/config"] [dependencies.askama_escape]
default = ["config", "humansize", "num-traits", "urlencode"] version = "0.10.3"
humansize = ["askama_shared/humansize"]
-markdown = ["askama_shared/markdown"] -[dependencies.comrak]
-version = "0.16"
-optional = true
-default-features = false
-
[dependencies.dep_humansize]
version = "2"
optional = true
@@ -88,10 +83,6 @@
"askama_derive/humansize",
"dep_humansize",
]
-markdown = [
- "askama_derive/markdown",
- "comrak",
-]
mime = [] mime = []
mime_guess = [] mime_guess = []
num-traits = ["askama_shared/num-traits"] num-traits = [

@ -5,7 +5,7 @@
%global crate askama %global crate askama
Name: rust-askama Name: rust-askama
Version: 0.11.1 Version: 0.12.0
Release: %autorelease Release: %autorelease
Summary: Type-safe, compiled Jinja-like templates for Rust Summary: Type-safe, compiled Jinja-like templates for Rust
@ -35,6 +35,7 @@ use the "%{crate}" crate.
%files devel %files devel
%license %{crate_instdir}/LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT %license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -61,6 +62,30 @@ use the "config" feature of the "%{crate}" crate.
%files -n %{name}+config-devel %files -n %{name}+config-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dep_humansize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dep_humansize-devel %{_description}
This package contains library source intended for building other packages which
use the "dep_humansize" feature of the "%{crate}" crate.
%files -n %{name}+dep_humansize-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dep_num_traits-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dep_num_traits-devel %{_description}
This package contains library source intended for building other packages which
use the "dep_num_traits" feature of the "%{crate}" crate.
%files -n %{name}+dep_num_traits-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+humansize-devel %package -n %{name}+humansize-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -109,6 +134,30 @@ use the "num-traits" feature of the "%{crate}" crate.
%files -n %{name}+num-traits-devel %files -n %{name}+num-traits-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+percent-encoding-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+percent-encoding-devel %{_description}
This package contains library source intended for building other packages which
use the "percent-encoding" feature of the "%{crate}" crate.
%files -n %{name}+percent-encoding-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-json-devel %package -n %{name}+serde-json-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -133,6 +182,30 @@ use the "serde-yaml" feature of the "%{crate}" crate.
%files -n %{name}+serde-yaml-devel %files -n %{name}+serde-yaml-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_yaml-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_yaml-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_yaml" feature of the "%{crate}" crate.
%files -n %{name}+serde_yaml-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+urlencode-devel %package -n %{name}+urlencode-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -181,6 +254,18 @@ use the "with-gotham" feature of the "%{crate}" crate.
%files -n %{name}+with-gotham-devel %files -n %{name}+with-gotham-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-hyper-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+with-hyper-devel %{_description}
This package contains library source intended for building other packages which
use the "with-hyper" feature of the "%{crate}" crate.
%files -n %{name}+with-hyper-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-mendes-devel %package -n %{name}+with-mendes-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -1 +1 @@
SHA512 (askama-0.11.1.crate) = d75507a43d2ab12b046854e33308eeabbac6825282588554a678742a71f2521a33637b89d3b24088643d18e84cefa538031264c587896e6e1eb16cc15c93afb7 SHA512 (askama-0.12.0.crate) = 8703a9091bd0145c12b724b116452be45ea8730fb05eba375af321345105105fb1486511e3cec82c494fae8771b12632caf5a01e3722a730cda6f81033c470e5

Loading…
Cancel
Save