parent
34e9e42c2d
commit
80accd90dc
@ -0,0 +1,25 @@
|
|||||||
|
From e0641952e15e81afd101652240828d30d7ee6726 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Tue, 2 Jul 2024 14:24:40 +0200
|
||||||
|
Subject: [PATCH] drop is_terminal_polyfill and replace with
|
||||||
|
std::io::IsTerminal
|
||||||
|
|
||||||
|
---
|
||||||
|
src/stream.rs | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/stream.rs b/src/stream.rs
|
||||||
|
index b30d232..e8472c1 100644
|
||||||
|
--- a/src/stream.rs
|
||||||
|
+++ b/src/stream.rs
|
||||||
|
@@ -1,5 +1,7 @@
|
||||||
|
//! Higher-level traits to describe writeable streams
|
||||||
|
|
||||||
|
+use std::io as is_terminal_polyfill;
|
||||||
|
+
|
||||||
|
/// Required functionality for underlying [`std::io::Write`] for adaptation
|
||||||
|
#[cfg(not(all(windows, feature = "wincon")))]
|
||||||
|
pub trait RawStream: std::io::Write + IsTerminal + private::Sealed {}
|
||||||
|
--
|
||||||
|
2.45.2
|
||||||
|
|
@ -1,12 +1,20 @@
|
|||||||
--- anstream-0.6.13/Cargo.toml 1970-01-01T00:00:01+00:00
|
--- anstream-0.6.14/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
+++ anstream-0.6.13/Cargo.toml 2024-02-29T10:44:04.583536+00:00
|
+++ anstream-0.6.14/Cargo.toml 2024-07-02T12:18:12.596325+00:00
|
||||||
@@ -133,8 +133,5 @@
|
@@ -141,11 +141,7 @@
|
||||||
"wincon",
|
"wincon",
|
||||||
]
|
]
|
||||||
test = []
|
test = []
|
||||||
-wincon = ["dep:anstyle-wincon"]
|
-wincon = ["dep:anstyle-wincon"]
|
||||||
+wincon = []
|
-
|
||||||
|
|
||||||
-[target."cfg(windows)".dependencies.anstyle-wincon]
|
-[target."cfg(windows)".dependencies.anstyle-wincon]
|
||||||
-version = "3.0.1"
|
-version = "3.0.1"
|
||||||
-optional = true
|
-optional = true
|
||||||
|
+wincon = []
|
||||||
|
|
||||||
|
[lints.clippy]
|
||||||
|
bool_assert_comparison = "allow"
|
||||||
|
@@ -216,3 +212,4 @@
|
||||||
|
unused_lifetimes = "warn"
|
||||||
|
unused_macro_rules = "warn"
|
||||||
|
unused_qualifications = "warn"
|
||||||
|
+
|
||||||
|
@ -0,0 +1,6 @@
|
|||||||
|
[package]
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused, benchmark-only divan dev-dependency",
|
||||||
|
"drop unnecessary is-terminal polyfill (MSRV 1.65 -> 1.70 is OK downstream)",
|
||||||
|
]
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (anstream-0.6.13.crate) = 4f9ccfd135de9be22a01230f39d571c8d8ccf7c3eba837fbf0868c9660693b60ee0c1c2f9490a587d5307e892ed45cb946da7a0690a9f972619c94fb050bde09
|
SHA512 (anstream-0.6.14.crate) = 65ece20958e3fb1ed4a5ff1d45f5bfdcb942c64994a3d14eefb0dfd5b04f433f6e1b06ebff240c67ed8ff7cc01d93ca0acf8c8ea29cb41309c6c882e7c192b34
|
||||||
|
Loading…
Reference in new issue