parent
836f408259
commit
4f5ec85c00
@ -0,0 +1 @@
|
|||||||
|
/ansiterm-0.12.2.crate
|
@ -0,0 +1,15 @@
|
|||||||
|
--- ansiterm-0.12.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ ansiterm-0.12.2/Cargo.toml 2023-09-12T13:02:37.868190+00:00
|
||||||
|
@@ -52,12 +52,3 @@
|
||||||
|
[features]
|
||||||
|
derive_serde_style = ["serde"]
|
||||||
|
|
||||||
|
-[target."cfg(target_os=\"windows\")".dependencies.winapi]
|
||||||
|
-version = "0.3.4"
|
||||||
|
-features = [
|
||||||
|
- "consoleapi",
|
||||||
|
- "errhandlingapi",
|
||||||
|
- "fileapi",
|
||||||
|
- "handleapi",
|
||||||
|
- "processenv",
|
||||||
|
-]
|
@ -0,0 +1,106 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate ansiterm
|
||||||
|
|
||||||
|
Name: rust-ansiterm
|
||||||
|
Version: 0.12.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Library for ANSI terminal colours and styles (bold, underline)
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/ansiterm
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: ansiterm-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Library for ANSI terminal colours and styles (bold, underline).}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENCE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+ansi_colours-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+ansi_colours-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "ansi_colours" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+ansi_colours-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+derive_serde_style-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+derive_serde_style-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "derive_serde_style" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+derive_serde_style-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue