Regenerate with rust2rpm 24; Fixes: RHBZ#2224956

epel10
Davide Cavalca 2 years ago
parent f2200892f4
commit 317b902bc8

@ -0,0 +1,8 @@
--- alsa-sys-0.3.1/Cargo.toml 2020-12-22T20:30:47+00:00
+++ alsa-sys-0.3.1/Cargo.toml 2023-07-25T05:54:41.960681+00:00
@@ -27,3 +27,5 @@
version = "0.2.65"
[build-dependencies.pkg-config]
version = "0.3"
+[lib]
+doctest = false

@ -1,24 +1,22 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 24
# Deactivate tests because of missing function %bcond_without check
# https://github.com/diwic/alsa-sys/issues/8
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate alsa-sys %global crate alsa-sys
Name: rust-%{crate} Name: rust-alsa-sys
Version: 0.3.1 Version: 0.3.1
Release: %autorelease Release: %autorelease
Summary: FFI bindings for the ALSA project (Advanced Linux Sound Architecture) Summary: FFI bindings for the ALSA project (Advanced Linux Sound Architecture)
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/alsa-sys URL: https://crates.io/crates/alsa-sys
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * skip doctests: https://github.com/diwic/alsa-sys/commit/3a6d3b26bdc21ac74a0ba6e4a637decf20da0a39
Patch: alsa-sys-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
FFI bindings for the ALSA project (Advanced Linux Sound Architecture).} FFI bindings for the ALSA project (Advanced Linux Sound Architecture).}
@ -28,7 +26,7 @@ FFI bindings for the ALSA project (Advanced Linux Sound Architecture).}
%package devel %package devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
Requires: alsa-lib-devel Requires: pkgconfig(alsa)
%description devel %{_description} %description devel %{_description}
@ -36,9 +34,9 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc README.md %doc %{crate_instdir}/README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,7 +48,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -58,7 +56,7 @@ use the "default" feature of the "%{crate}" crate.
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires
echo "alsa-lib-devel" echo 'pkgconfig(alsa)'
%build %build
%cargo_build %cargo_build

@ -0,0 +1,5 @@
[DEFAULT]
buildrequires =
pkgconfig(alsa)
lib.requires =
pkgconfig(alsa)
Loading…
Cancel
Save