Update to 0.9.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent db694f48ba
commit 693b5bc2ea
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -2,3 +2,4 @@
/addr2line-0.6.0.crate /addr2line-0.6.0.crate
/addr2line-0.7.0.crate /addr2line-0.7.0.crate
/addr2line-0.8.0.crate /addr2line-0.8.0.crate
/addr2line-0.9.0.crate

@ -1,10 +0,0 @@
--- addr2line-0.8.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ addr2line-0.8.0/Cargo.toml 2019-02-10T15:33:51.349701+01:00
@@ -82,7 +82,6 @@
version = "0.3"
[features]
-alloc = ["gimli/alloc"]
default = ["rustc-demangle", "cpp_demangle", "object", "std"]
std = ["gimli/std", "intervaltree/std", "object/std", "smallvec/std"]
[badges.travis-ci]

@ -1,13 +1,11 @@
# Generated by rust2rpm # Generated by rust2rpm-9-1.fc31
# addr2line(dev) -> backtrace(opt) -> addr2line
# findshlibs depends on bindgen which is not packaged
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate addr2line %global crate addr2line
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.8.0 Version: 0.9.0
Release: 1%{?dist} Release: 1%{?dist}
Summary: Cross-platform symbolication library written in Rust, using `gimli` Summary: Cross-platform symbolication library written in Rust, using `gimli`
@ -15,22 +13,19 @@ Summary: Cross-platform symbolication library written in Rust, using `gim
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/addr2line URL: https://crates.io/crates/addr2line
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * Drop "alloc" feature, it is nightly-only
Patch0: addr2line-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(cpp_demangle) >= 0.2.0 with crate(cpp_demangle) < 0.3.0) BuildRequires: (crate(cpp_demangle) >= 0.2.0 with crate(cpp_demangle) < 0.3.0)
BuildRequires: (crate(fallible-iterator) >= 0.1.0 with crate(fallible-iterator) < 0.2.0) BuildRequires: (crate(fallible-iterator) >= 0.2.0 with crate(fallible-iterator) < 0.3.0)
BuildRequires: (crate(gimli) >= 0.16.1 with crate(gimli) < 0.17.0) BuildRequires: (crate(gimli/read) >= 0.18.0 with crate(gimli/read) < 0.19.0)
BuildRequires: (crate(gimli/std) >= 0.16.1 with crate(gimli/std) < 0.17.0) BuildRequires: (crate(gimli/std) >= 0.18.0 with crate(gimli/std) < 0.19.0)
BuildRequires: (crate(intervaltree) >= 0.2.0 with crate(intervaltree) < 0.3.0) BuildRequires: (crate(intervaltree) >= 0.2.0 with crate(intervaltree) < 0.3.0)
BuildRequires: (crate(intervaltree/std) >= 0.2.0 with crate(intervaltree/std) < 0.3.0) BuildRequires: (crate(intervaltree/std) >= 0.2.0 with crate(intervaltree/std) < 0.3.0)
BuildRequires: (crate(lazycell/default) >= 1.0.0 with crate(lazycell/default) < 2.0.0) BuildRequires: (crate(lazycell/default) >= 1.0.0 with crate(lazycell/default) < 2.0.0)
BuildRequires: (crate(object) >= 0.11.0 with crate(object) < 0.12.0) BuildRequires: (crate(object) >= 0.12.0 with crate(object) < 0.13.0)
BuildRequires: (crate(object/std) >= 0.11.0 with crate(object/std) < 0.12.0) BuildRequires: (crate(object/std) >= 0.12.0 with crate(object/std) < 0.13.0)
BuildRequires: (crate(rustc-demangle/default) >= 0.1.0 with crate(rustc-demangle/default) < 0.2.0) BuildRequires: (crate(rustc-demangle/default) >= 0.1.0 with crate(rustc-demangle/default) < 0.2.0)
BuildRequires: (crate(smallvec) >= 0.6.0 with crate(smallvec) < 0.7.0) BuildRequires: (crate(smallvec) >= 0.6.0 with crate(smallvec) < 0.7.0)
BuildRequires: (crate(smallvec/std) >= 0.6.0 with crate(smallvec/std) < 0.7.0) BuildRequires: (crate(smallvec/std) >= 0.6.0 with crate(smallvec/std) < 0.7.0)
@ -74,6 +69,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+cpp_demangle-devel %package -n %{name}+cpp_demangle-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -122,6 +129,18 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-object-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-object-devel %{_description}
This package contains library source intended for building other packages
which use "std-object" feature of "%{crate}" crate.
%files -n %{name}+std-object-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
@ -138,6 +157,9 @@ which use "std" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Tue May 07 15:32:08 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.0-1
- Update to 0.9.0
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-1 * Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-1
- Update to 0.8.0 - Update to 0.8.0

@ -1 +1 @@
SHA512 (addr2line-0.8.0.crate) = 63857ab38cc2106b6d9f8a80d59202a40a7352ffa49b60ed8dd2d7abe427bea66dd8d123b105a7a45b41dd80ac9ec913b2d913db9e72f7b60453e80e4fee5b80 SHA512 (addr2line-0.9.0.crate) = e6bd415af39334aeeeaac77b634d5ac2522a1b0d76ee9576f42a2fbea56e9dc6aa4712511d72e8212d58cfd814b3530f7037e4e4793979be764a6408de7e5045

Loading…
Cancel
Save