commit
685a0ce966
@ -0,0 +1 @@
|
|||||||
|
/rubberband-1.8.2.tar.bz2
|
@ -1,21 +0,0 @@
|
|||||||
# Makefile for source rpm: rubberband
|
|
||||||
# $Id$
|
|
||||||
NAME := rubberband
|
|
||||||
SPECFILE = $(firstword $(wildcard *.spec))
|
|
||||||
|
|
||||||
define find-makefile-common
|
|
||||||
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
|
|
||||||
endef
|
|
||||||
|
|
||||||
MAKEFILE_COMMON := $(shell $(find-makefile-common))
|
|
||||||
|
|
||||||
ifeq ($(MAKEFILE_COMMON),)
|
|
||||||
# attept a checkout
|
|
||||||
define checkout-makefile-common
|
|
||||||
test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
|
|
||||||
endef
|
|
||||||
|
|
||||||
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
|
|
||||||
endif
|
|
||||||
|
|
||||||
include $(MAKEFILE_COMMON)
|
|
@ -0,0 +1,44 @@
|
|||||||
|
--- rubberband-1.8.2/Makefile.in.mk 2018-05-15 10:43:39.000000000 -0700
|
||||||
|
+++ rubberband-1.8.2/Makefile.in 2018-10-17 20:42:02.869414480 -0700
|
||||||
|
@@ -20,11 +20,11 @@
|
||||||
|
|
||||||
|
INSTALL_BINDIR := $(PREFIX)/bin
|
||||||
|
INSTALL_INCDIR := $(PREFIX)/include/rubberband
|
||||||
|
-INSTALL_LIBDIR := $(PREFIX)/lib
|
||||||
|
-INSTALL_VAMPDIR := $(PREFIX)/lib/vamp
|
||||||
|
-INSTALL_LADSPADIR := $(PREFIX)/lib/ladspa
|
||||||
|
+INSTALL_LIBDIR := @libdir@
|
||||||
|
+INSTALL_VAMPDIR := $(INSTALL_LIBDIR)/vamp
|
||||||
|
+INSTALL_LADSPADIR := $(INSTALL_LIBDIR)/ladspa
|
||||||
|
INSTALL_LRDFDIR := $(PREFIX)/share/ladspa/rdf
|
||||||
|
-INSTALL_PKGDIR := $(PREFIX)/lib/pkgconfig
|
||||||
|
+INSTALL_PKGDIR := $(INSTALL_LIBDIR)/pkgconfig
|
||||||
|
|
||||||
|
LIBNAME := librubberband
|
||||||
|
JNINAME := librubberband-jni
|
||||||
|
@@ -174,19 +174,17 @@
|
||||||
|
$(MKDIR) -p $(DESTDIR)$(INSTALL_LADSPADIR)
|
||||||
|
$(MKDIR) -p $(DESTDIR)$(INSTALL_LRDFDIR)
|
||||||
|
$(MKDIR) -p $(DESTDIR)$(INSTALL_PKGDIR)
|
||||||
|
- cp $(PROGRAM_TARGET) $(DESTDIR)$(INSTALL_BINDIR)
|
||||||
|
- cp $(PUBLIC_INCLUDES) $(DESTDIR)$(INSTALL_INCDIR)
|
||||||
|
- cp $(STATIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)
|
||||||
|
+ cp -p $(PROGRAM_TARGET) $(DESTDIR)$(INSTALL_BINDIR)
|
||||||
|
+ cp -p $(PUBLIC_INCLUDES) $(DESTDIR)$(INSTALL_INCDIR)
|
||||||
|
+ cp -p $(STATIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)
|
||||||
|
rm -f $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_ABI_VERSION)
|
||||||
|
rm -f $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION)
|
||||||
|
- rm -f $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION)
|
||||||
|
- cp $(DYNAMIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION)
|
||||||
|
+ cp -p $(DYNAMIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION)
|
||||||
|
ln -s $(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_ABI_VERSION)
|
||||||
|
ln -s $(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION)
|
||||||
|
- cp -f $(JNI_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION)
|
||||||
|
- cp $(VAMP_TARGET) $(DESTDIR)$(INSTALL_VAMPDIR)
|
||||||
|
+ cp -p $(VAMP_TARGET) $(DESTDIR)$(INSTALL_VAMPDIR)
|
||||||
|
cp vamp/vamp-rubberband.cat $(DESTDIR)$(INSTALL_VAMPDIR)
|
||||||
|
- cp $(LADSPA_TARGET) $(DESTDIR)$(INSTALL_LADSPADIR)
|
||||||
|
+ cp -p $(LADSPA_TARGET) $(DESTDIR)$(INSTALL_LADSPADIR)
|
||||||
|
cp ladspa/ladspa-rubberband.cat $(DESTDIR)$(INSTALL_LADSPADIR)
|
||||||
|
cp ladspa/ladspa-rubberband.rdf $(DESTDIR)$(INSTALL_LRDFDIR)
|
||||||
|
sed "s,%PREFIX%,$(PREFIX)," rubberband.pc.in \
|
@ -0,0 +1,161 @@
|
|||||||
|
Name: rubberband
|
||||||
|
Version: 1.8.2
|
||||||
|
Release: 3%{?dist}
|
||||||
|
Summary: Audio time-stretching and pitch-shifting library
|
||||||
|
|
||||||
|
License: GPLv2+
|
||||||
|
URL: http://www.breakfastquay.com/rubberband/
|
||||||
|
Source0: https://breakfastquay.com/files/releases/%{name}-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-1.8.2-mk.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: ladspa-devel
|
||||||
|
BuildRequires: pkgconfig(fftw3)
|
||||||
|
BuildRequires: pkgconfig(samplerate)
|
||||||
|
BuildRequires: pkgconfig(sndfile)
|
||||||
|
BuildRequires: vamp-plugin-sdk-devel
|
||||||
|
|
||||||
|
Requires: ladspa
|
||||||
|
|
||||||
|
%description
|
||||||
|
Rubber Band is a library and utility program that permits you to change the
|
||||||
|
tempo and pitch of an audio recording independently of one another.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1
|
||||||
|
sed -i 's|{exec_prefix}/lib|{exec_prefix}/%{_lib}|' rubberband.pc.in
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
rm -rf $RPM_BUILD_ROOT%{_libdir}/*.a
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license COPYING
|
||||||
|
%doc README.txt
|
||||||
|
%{_bindir}/rubberband
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
%{_libdir}/ladspa/ladspa-rubberband.*
|
||||||
|
%{_datadir}/ladspa/rdf/ladspa-rubberband.rdf
|
||||||
|
%{_libdir}/vamp/vamp-rubberband.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc CHANGELOG
|
||||||
|
%{_includedir}/*
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/rubberband.pc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Oct 17 2018 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.8.2-1
|
||||||
|
- Update to 1.8.2
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.8.1-6
|
||||||
|
- Rebuilt for GCC 5 C++11 ABI change
|
||||||
|
|
||||||
|
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Oct 28 2012 Michel Salim <salimma@fedoraproject.org> - 1.8.1-1
|
||||||
|
- Update to 1.8.1
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
|
||||||
|
- Rebuilt for c++ ABI breakage
|
||||||
|
|
||||||
|
* Tue Jan 31 2012 Michel Salim <salimma@fedoraproject.org> - 1.7.0-1
|
||||||
|
- Update to 1.7.0
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 14 2011 Michel Salim <salimma@fedoraproject.org> - 1.6.0-1
|
||||||
|
- Update to 1.6.0
|
||||||
|
|
||||||
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 3 2010 Michel Salim <salimma@fedoraproject.org> - 1.5.0-2
|
||||||
|
- Fixed pkg-config version declaration
|
||||||
|
|
||||||
|
* Wed Jun 2 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5.0-1
|
||||||
|
- update to 1.5.0
|
||||||
|
- disable static libs
|
||||||
|
|
||||||
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Feb 8 2009 Michel Salim <salimma@fedoraproject.org> - 1.2-3
|
||||||
|
- Fix compilation problem with GCC 4.4
|
||||||
|
|
||||||
|
* Sun Dec 14 2008 Michel Salim <salimma@fedoraproject.org> - 1.2-2
|
||||||
|
- Rebuild for vamp-plugins-sdk-2.0
|
||||||
|
|
||||||
|
* Thu Jul 17 2008 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.2-1
|
||||||
|
- Update to 1.2
|
||||||
|
|
||||||
|
* Sun Mar 30 2008 Michel Salim <michel.sylvan@gmail.com> - 1.0.1-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue