parent
c5c095d84f
commit
42002cc6ae
@ -0,0 +1 @@
|
|||||||
|
rubberband-1.0.1.tar.bz2
|
@ -0,0 +1,74 @@
|
|||||||
|
--- rubberband-1.0.1/Makefile.in.destdir 2007-12-13 17:15:03.000000000 -0500
|
||||||
|
+++ rubberband-1.0.1/Makefile.in 2008-03-30 23:31:44.000000000 -0400
|
||||||
|
@@ -16,16 +16,16 @@
|
||||||
|
|
||||||
|
PROGRAM_TARGET := bin/rubberband
|
||||||
|
STATIC_TARGET := lib/librubberband.a
|
||||||
|
-DYNAMIC_TARGET := lib/librubberband$(DYNAMIC_EXTENSION)
|
||||||
|
+DYNAMIC_TARGET := lib/librubberband$(DYNAMIC_EXTENSION).1
|
||||||
|
VAMP_TARGET := lib/vamp-rubberband$(DYNAMIC_EXTENSION)
|
||||||
|
LADSPA_TARGET := lib/ladspa-rubberband$(DYNAMIC_EXTENSION)
|
||||||
|
|
||||||
|
INSTALL_BINDIR := @prefix@/bin
|
||||||
|
INSTALL_INCDIR := @prefix@/include/rubberband
|
||||||
|
-INSTALL_LIBDIR := @prefix@/lib
|
||||||
|
-INSTALL_VAMPDIR := @prefix@/lib/vamp
|
||||||
|
-INSTALL_LADSPADIR := @prefix@/lib/ladspa
|
||||||
|
-INSTALL_PKGDIR := @prefix@/lib/pkgconfig
|
||||||
|
+INSTALL_LIBDIR := @libdir@
|
||||||
|
+INSTALL_VAMPDIR := @libdir@/vamp
|
||||||
|
+INSTALL_LADSPADIR := @libdir@/ladspa
|
||||||
|
+INSTALL_PKGDIR := @libdir@/pkgconfig
|
||||||
|
|
||||||
|
all: bin lib $(PROGRAM_TARGET) $(STATIC_TARGET) $(DYNAMIC_TARGET) $(VAMP_TARGET) $(LADSPA_TARGET)
|
||||||
|
|
||||||
|
@@ -95,7 +95,8 @@
|
||||||
|
$(AR) rsc $@ $^
|
||||||
|
|
||||||
|
$(DYNAMIC_TARGET): $(LIBRARY_OBJECTS)
|
||||||
|
- $(CXX) $(DYNAMIC_LDFLAGS) $^ -o $@ $(LIBRARY_LIBS) $(LDFLAGS)
|
||||||
|
+ $(CXX) -shared -Wl,-soname,librubberband.so.1 $^ \
|
||||||
|
+ -o $@ $(LIBRARY_LIBS) $(LDFLAGS)
|
||||||
|
|
||||||
|
$(VAMP_TARGET): $(LIBRARY_OBJECTS) $(VAMP_OBJECTS)
|
||||||
|
$(CXX) $(DYNAMIC_LDFLAGS) -o $@ $^ $(VAMP_PLUGIN_LIBS) $(LDFLAGS)
|
||||||
|
@@ -109,22 +110,24 @@
|
||||||
|
$(MKDIR) $@
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- $(MKDIR) -p $(INSTALL_BINDIR)
|
||||||
|
- $(MKDIR) -p $(INSTALL_INCDIR)
|
||||||
|
- $(MKDIR) -p $(INSTALL_LIBDIR)
|
||||||
|
- $(MKDIR) -p $(INSTALL_VAMPDIR)
|
||||||
|
- $(MKDIR) -p $(INSTALL_LADSPADIR)
|
||||||
|
- $(MKDIR) -p $(INSTALL_PKGDIR)
|
||||||
|
- cp $(PROGRAM_TARGET) $(INSTALL_BINDIR)
|
||||||
|
- cp $(PUBLIC_INCLUDES) $(INSTALL_INCDIR)
|
||||||
|
- cp $(STATIC_TARGET) $(INSTALL_LIBDIR)
|
||||||
|
- cp $(DYNAMIC_TARGET) $(INSTALL_LIBDIR)
|
||||||
|
- cp $(VAMP_TARGET) $(INSTALL_VAMPDIR)
|
||||||
|
- cp src/vamp/vamp-rubberband.cat $(INSTALL_VAMPDIR)
|
||||||
|
- cp $(LADSPA_TARGET) $(INSTALL_LADSPADIR)
|
||||||
|
- cp src/ladspa/ladspa-rubberband.cat $(INSTALL_LADSPADIR)
|
||||||
|
+ $(MKDIR) -p $(DESTDIR)$(INSTALL_BINDIR)
|
||||||
|
+ $(MKDIR) -p $(DESTDIR)$(INSTALL_INCDIR)
|
||||||
|
+ $(MKDIR) -p $(DESTDIR)$(INSTALL_LIBDIR)
|
||||||
|
+ $(MKDIR) -p $(DESTDIR)$(INSTALL_VAMPDIR)
|
||||||
|
+ $(MKDIR) -p $(DESTDIR)$(INSTALL_LADSPADIR)
|
||||||
|
+ $(MKDIR) -p $(DESTDIR)$(INSTALL_PKGDIR)
|
||||||
|
+ cp -p $(PROGRAM_TARGET) $(DESTDIR)$(INSTALL_BINDIR)
|
||||||
|
+ cp -p $(PUBLIC_INCLUDES) $(DESTDIR)$(INSTALL_INCDIR)
|
||||||
|
+ cp -p $(STATIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)
|
||||||
|
+ cp -p $(DYNAMIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)
|
||||||
|
+ ( cd $(DESTDIR)$(INSTALL_LIBDIR) && \
|
||||||
|
+ ln -s librubberband.so.1 librubberband.so )
|
||||||
|
+ cp -p $(VAMP_TARGET) $(DESTDIR)$(INSTALL_VAMPDIR)
|
||||||
|
+ cp -p src/vamp/vamp-rubberband.cat $(DESTDIR)$(INSTALL_VAMPDIR)
|
||||||
|
+ cp -p $(LADSPA_TARGET) $(DESTDIR)$(INSTALL_LADSPADIR)
|
||||||
|
+ cp -p src/ladspa/ladspa-rubberband.cat $(DESTDIR)$(INSTALL_LADSPADIR)
|
||||||
|
sed "s,%PREFIX%,@prefix@," rubberband.pc.in \
|
||||||
|
- > $(INSTALL_PKGDIR)/rubberband.pc
|
||||||
|
+ > $(DESTDIR)$(INSTALL_PKGDIR)/rubberband.pc
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f $(LIBRARY_OBJECTS) $(PROGRAM_OBJECTS) $(LADSPA_OBJECTS) $(VAMP_OBJECTS)
|
@ -0,0 +1,61 @@
|
|||||||
|
--- rubberband-1.0.1/src/Window.h.gcc43 2007-12-13 17:15:03.000000000 -0500
|
||||||
|
+++ rubberband-1.0.1/src/Window.h 2008-03-30 22:20:04.000000000 -0400
|
||||||
|
@@ -16,6 +16,7 @@
|
||||||
|
#define _RUBBERBAND_WINDOW_H_
|
||||||
|
|
||||||
|
#include <cmath>
|
||||||
|
+#include <cstdlib>
|
||||||
|
#include <iostream>
|
||||||
|
#include <map>
|
||||||
|
|
||||||
|
--- rubberband-1.0.1/src/Thread.cpp.gcc43 2007-12-13 17:15:03.000000000 -0500
|
||||||
|
+++ rubberband-1.0.1/src/Thread.cpp 2008-03-30 22:26:25.000000000 -0400
|
||||||
|
@@ -14,6 +14,7 @@
|
||||||
|
|
||||||
|
#include "Thread.h"
|
||||||
|
|
||||||
|
+#include <cstdlib>
|
||||||
|
#include <iostream>
|
||||||
|
|
||||||
|
#include <sys/time.h>
|
||||||
|
--- rubberband-1.0.1/src/FFT.cpp.gcc43 2007-12-13 17:15:03.000000000 -0500
|
||||||
|
+++ rubberband-1.0.1/src/FFT.cpp 2008-03-30 22:25:59.000000000 -0400
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
#include <iostream>
|
||||||
|
#include <map>
|
||||||
|
#include <cstdio>
|
||||||
|
+#include <cstdlib>
|
||||||
|
#include <vector>
|
||||||
|
|
||||||
|
namespace RubberBand {
|
||||||
|
--- rubberband-1.0.1/src/RingBuffer.h.gcc43 2007-12-13 17:15:03.000000000 -0500
|
||||||
|
+++ rubberband-1.0.1/src/RingBuffer.h 2008-03-30 22:25:17.000000000 -0400
|
||||||
|
@@ -15,6 +15,7 @@
|
||||||
|
#ifndef _RUBBERBAND_RINGBUFFER_H_
|
||||||
|
#define _RUBBERBAND_RINGBUFFER_H_
|
||||||
|
|
||||||
|
+#include <cstring>
|
||||||
|
#include <sys/types.h>
|
||||||
|
|
||||||
|
#ifndef _WIN32
|
||||||
|
--- rubberband-1.0.1/src/StretchCalculator.cpp.gcc43 2007-12-13 17:15:03.000000000 -0500
|
||||||
|
+++ rubberband-1.0.1/src/StretchCalculator.cpp 2008-03-30 22:21:44.000000000 -0400
|
||||||
|
@@ -14,6 +14,7 @@
|
||||||
|
|
||||||
|
#include "StretchCalculator.h"
|
||||||
|
|
||||||
|
+#include <algorithm>
|
||||||
|
#include <math.h>
|
||||||
|
#include <iostream>
|
||||||
|
#include <deque>
|
||||||
|
--- rubberband-1.0.1/src/main.cpp.gcc43 2007-12-13 17:15:03.000000000 -0500
|
||||||
|
+++ rubberband-1.0.1/src/main.cpp 2008-03-30 22:26:57.000000000 -0400
|
||||||
|
@@ -17,6 +17,8 @@
|
||||||
|
#include <iostream>
|
||||||
|
#include <sndfile.h>
|
||||||
|
#include <cmath>
|
||||||
|
+#include <cstdlib>
|
||||||
|
+#include <cstring>
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <time.h>
|
||||||
|
#include "sysutils.h"
|
@ -0,0 +1,80 @@
|
|||||||
|
Name: rubberband
|
||||||
|
Version: 1.0.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Audio time-stretching and pitch-shifting library
|
||||||
|
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
License: GPLv2+
|
||||||
|
URL: http://www.breakfastquay.com/rubberband/
|
||||||
|
Source0: http://www.breakfastquay.com/rubberband/files/rubberband-%{version}.tar.bz2
|
||||||
|
Patch0: rubberband-1.0.1-gcc43.patch
|
||||||
|
Patch1: rubberband-1.0.1-destdir.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
BuildRequires: fftw-devel libsamplerate-devel libsndfile-devel
|
||||||
|
BuildRequires: ladspa-devel vamp-plugin-sdk-devel
|
||||||
|
#Requires:
|
||||||
|
|
||||||
|
%description
|
||||||
|
Rubber Band is a library and utility program that permits you to change the
|
||||||
|
tempo and pitch of an audio recording independently of one another.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .gcc43
|
||||||
|
%patch1 -p1 -b .destdir
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc COPYING README
|
||||||
|
%{_bindir}/rubberband
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
%{_libdir}/ladspa/ladspa-rubberband.*
|
||||||
|
%{_libdir}/vamp/vamp-rubberband.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc
|
||||||
|
%{_includedir}/*
|
||||||
|
%{_libdir}/*.a
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/rubberband.pc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Mar 30 2008 Michel Salim <michel.sylvan@gmail.com> - 1.0.1-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue