Update to latest 1.2.0 snapshot (rcgit.25)

epel8
Simone Caronni 7 years ago
parent 0b4af866d4
commit bfa7094b60

1
.gitignore vendored

@ -32,3 +32,4 @@ remmina-0.7.5.tar.gz
/Remmina-89009c8.tar.gz
/Remmina-0387ee0.tar.gz
/Remmina-205df66.tar.gz
/Remmina-08f5b4b.tar.gz

@ -0,0 +1,12 @@
diff -Naur Remmina-08f5b4be5e31a44765d651009be2ac7797fc44ac.old/remmina-plugins/exec/exec_plugin.c Remmina-08f5b4be5e31a44765d651009be2ac7797fc44ac/remmina-plugins/exec/exec_plugin.c
--- Remmina-08f5b4be5e31a44765d651009be2ac7797fc44ac.old/remmina-plugins/exec/exec_plugin.c 2017-12-20 14:08:42.167227579 +0100
+++ Remmina-08f5b4be5e31a44765d651009be2ac7797fc44ac/remmina-plugins/exec/exec_plugin.c 2017-12-20 14:17:09.688627742 +0100
@@ -201,7 +201,7 @@
_("WARNING! Executing a command synchronously, may hung Remmina.\r"
"Do you really want to continue?");
dialog = GTK_DIALOG(gtk_message_dialog_new(NULL, GTK_DIALOG_MODAL,
- GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO, sync_warning));
+ GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO, "%s", sync_warning));
gint result = gtk_dialog_run (GTK_DIALOG (dialog));
switch (result)

@ -1,14 +1,14 @@
# Main branch is the "next" branch, not master
%global commit0 205df66325b566d2ae5f87f8a68f9d829765d4d5
%global date 20170908
%global commit0 08f5b4be5e31a44765d651009be2ac7797fc44ac
%global date 20171220
%global shortcommit0 %%(c=%%{commit0}; echo ${c:0:7})
# RC releases
#%%global snapshot rcgit.19
#%%global snapshot rcgit.25
Name: remmina
Version: 1.2.0
Release: 0.42%{?snapshot:.%{snapshot}}%{?shortcommit0:.%{date}git%{shortcommit0}}%{?dist}
Release: 0.43%{?snapshot:.%{snapshot}}%{?shortcommit0:.%{date}git%{shortcommit0}}%{?dist}
Summary: Remote Desktop Client
License: GPLv2+ and MIT
URL: http://remmina.sourceforge.net
@ -24,6 +24,8 @@ Source0: https://github.com/FreeRDP/Remmina/archive/%{commit0}/Remmina-%{c
# So we can't use it directly only as instructions.
Source1: pluginBuild-CMakeLists.txt
Patch0: %{name}-format-security.patch
BuildRequires: cmake >= 2.8
BuildRequires: desktop-file-utils
BuildRequires: gettext
@ -43,11 +45,14 @@ BuildRequires: pkgconfig(vte-2.91)
BuildRequires: pkgconfig(xkbfile)
# We don't ship the remmina-plugins-telepathy package any longer
Provides: remmina-plugins-telepathy = %{version}
Obsoletes: remmina-plugins-telepathy < %{version}-%{release}
Obsoletes: %{name}-plugins-telepathy < %{version}-%{release}
Recommends: remmina-plugins-nx remmina-plugins-rdp
Recommends: remmina-plugins-gnome remmina-plugins-vnc remmina-plugins-xdmcp
Recommends: %{name}-plugins-exec
Recommends: %{name}-plugins-nx
Recommends: %{name}-plugins-rdp
Recommends: %{name}-plugins-secret
Recommends: %{name}-plugins-vnc
Recommends: %{name}-plugins-xdmcp
%description
Remmina is a remote desktop client written in GTK+, aiming to be useful for
@ -70,17 +75,32 @@ The %{name}-devel package contains header files for developing plugins for
%{name}.
%package plugins-gnome
Summary: GNOME keyring integration for Remmina Remote Desktop Client
%package plugins-exec
Summary: External execution plugin for Remmina Remote Desktop Client
Requires: %{name}%{?_isa} = %{version}-%{release}
%description plugins-gnome
%description plugins-exec
Remmina is a remote desktop client written in GTK+, aiming to be useful for
system administrators and travelers, who need to work with lots of remote
computers in front of either large monitors or tiny net-books.
This package contains the plugin with GNOME keyring support for the Remmina
remote desktop client.
This package contains the plugin to execute external processes (commands or
applications) from the Remmina window.
%package plugins-secret
Summary: Keyring integration for Remmina Remote Desktop Client
Requires: %{name}%{?_isa} = %{version}-%{release}
Obsoletes: %{name}-plugins-gnome < %{version}-%{release}
Provides: %{name}-plugins-gnome%{?_isa} = %{version}-%{release}
%description plugins-secret
Remmina is a remote desktop client written in GTK+, aiming to be useful for
system administrators and travelers, who need to work with lots of remote
computers in front of either large monitors or tiny net-books.
This package contains the plugin with keyring support for the Remmina remote
desktop client.
%package plugins-nx
@ -151,6 +171,7 @@ client.
%prep
%setup -qn Remmina-%{?snapshot:%{version}-%{snapshot}}%{?commit0}
%patch0 -p1
%build
mkdir -p build
@ -158,7 +179,6 @@ mkdir -p build
%cmake --build=build \
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
-DCMAKE_INSTALL_COMPONENT=1 \
-DWITH_APPINDICATOR=ON \
-DWITH_AVAHI=ON \
-DWITH_FREERDP=ON \
@ -166,20 +186,17 @@ mkdir -p build
-DWITH_GETTEXT=ON \
-DWITH_LIBSSH=ON \
-DWITH_SPICE=ON \
-DWITH_SURVEY=OFF \
-DWITH_TELEPATHY=OFF \
-DWITH_VTE=ON \
-DWITH_ZLIB=ON \
-DGIT_REVISION=%{commit0} \
.
make %{?_smp_mflags}
%make_build
%install
%make_install
desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/appdata/%{name}.appdata.xml
desktop-file-validate %{buildroot}/%{_datadir}/applications/*.desktop
appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/metainfo/*.appdata.xml
mkdir -p %{buildroot}/%{_libdir}/cmake/%{name}/
cp -pr cmake/*.cmake %{buildroot}/%{_libdir}/cmake/%{name}/
@ -262,15 +279,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files -f %{name}.lang
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc AUTHORS ChangeLog README.md
%{_bindir}/%{name}
%{_datadir}/appdata/*.appdata.xml
%{_datadir}/metainfo/*.appdata.xml
%{_datadir}/applications/*.desktop
%{_datadir}/icons/hicolor/*/actions/*.*
%{_datadir}/icons/hicolor/*/apps/*.*
%{_datadir}/icons/hicolor/*/emblems/remmina-sftp.png
%{_datadir}/icons/hicolor/*/emblems/remmina-*.png
%{_datadir}/mime/packages/*.xml
%{_datadir}/%{name}/
%dir %{_libdir}/remmina/
%dir %{_libdir}/remmina/plugins/
@ -281,8 +298,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_libdir}/pkgconfig/%{name}.pc
%{_libdir}/cmake/%{name}/*.cmake
%files plugins-gnome
%{_libdir}/remmina/plugins/remmina-plugins-gnome.so
%files plugins-exec
%{_libdir}/remmina/plugins/remmina-plugin-exec.so
%files plugins-secret
%{_libdir}/remmina/plugins/remmina-plugin-secret.so
%files plugins-nx
%{_libdir}/remmina/plugins/remmina-plugin-nx.so
@ -309,6 +329,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog
* Wed Dec 20 2017 Simone Caronni <negativo17@gmail.com> - 1.2.0-0.43.20171220git08f5b4b
- Update to latest 1.2.0 snapshot (rcgit.25).
- Gnome plugin renamed to secret.
- Add new executor plugin.
* Mon Sep 11 2017 Simone Caronni <negativo17@gmail.com> - 1.2.0-0.42.20170908git205df66
- Update to latest snapshot.
- Trim changelog.

@ -1 +1 @@
SHA512 (Remmina-205df66.tar.gz) = e9b2daac5edf6d73bd0b6b9186032cab97f13efd3d82036d5c301a7d8af4ff724731871f14072eaff202cd1998c1ea3b480717d5b00c806204fc2fee23d160a1
SHA512 (Remmina-08f5b4b.tar.gz) = 3ea1191dccd2b84526c17f99c3fb14894e6b020fa9aa7d78c989a348640ed75e94c52cdc746ac58f650b30ca61006c0723948ba1448f067aec1cdbe91f5be853

Loading…
Cancel
Save