Merge branch 'rawhide' into epel9

epel9
Phil Wyett 2 years ago
commit a4bdcc581b

@ -1,25 +0,0 @@
From c6adb35b854dcc71895413b120fafaa071645549 Mon Sep 17 00:00:00 2001
From: John Chadwick <johnwchadwick@gmail.com>
Date: Fri, 14 Apr 2023 04:01:41 +0000
Subject: [PATCH] Fix segfault in VNC when using domain socket
---
plugins/vnc/vnc_plugin.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/plugins/vnc/vnc_plugin.c b/plugins/vnc/vnc_plugin.c
index 4fa7b627b..adecffff4 100644
--- a/plugins/vnc/vnc_plugin.c
+++ b/plugins/vnc/vnc_plugin.c
@@ -1716,7 +1716,7 @@ static gboolean remmina_plugin_vnc_open_connection(RemminaProtocolWidget *gp)
raw_server = remmina_plugin_service->file_get_string(remminafile, "server");
if (raw_server && strstr(raw_server, "unix://") == raw_server) {
- REMMINA_PLUGIN_AUDIT(_("Connected to %s via VNC"), server);
+ REMMINA_PLUGIN_AUDIT(_("Connected to %s via VNC"), raw_server);
} else {
remmina_plugin_service->get_server_port(raw_server,
VNC_DEFAULT_PORT,
--
GitLab

@ -1,11 +1,8 @@
%global release_commit_hash 61ea9b6681104cadf0a3f8c25bd3e5685ee6691a
# Use old cmake macro behaviour.
%define __cmake_in_source_build 1
%global release_commit_hash 7407cc3a27eb25ba4ddddeab565f67fd688324ed
Name: remmina
Version: 1.4.30
Release: 2%{?dist}
Version: 1.4.31
Release: 1%{?dist}
Summary: Remote Desktop Client
License: GPL-2.0-or-later and MIT
URL: https://remmina.org
@ -18,10 +15,7 @@ Source0: https://gitlab.com/Remmina/Remmina/-/archive/v%{version}/Remmina-%{vers
# So we can't use it directly only as instructions.
Source1: pluginBuild-CMakeLists.txt
# Patches.
Patch00: 0001_remmina_fix_vnc_crash_domain_socket.patch
BuildRequires: cmake
BuildRequires: cmake >= 3.2
BuildRequires: cups-devel
BuildRequires: desktop-file-utils
BuildRequires: gcc-c++
@ -223,12 +217,7 @@ that shows up under the display manager session menu.
%autosetup -p1 -n Remmina-v%{version}-%{release_commit_hash}
%build
%if 0%{?fedora}
# Workaround for Pango on Fedora 31+.
export CFLAGS="%{optflags} -I%{_includedir}/harfbuzz"
%endif
%cmake . \
%cmake \
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
-DHAVE_LIBAPPINDICATOR=ON \
@ -256,7 +245,6 @@ export CFLAGS="%{optflags} -I%{_includedir}/harfbuzz"
%else
-DWITH_X2GO=OFF
%endif
%cmake_build
%install
@ -345,6 +333,13 @@ appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/metainfo/*.appdat
%{_mandir}/man1/remmina-gnome.1*
%changelog
* Wed Jun 07 2023 Phil Wyett <philip.wyett@kathenas.org> - 1.4.31-1
- New upstream version 1.4.31.
- Remove no longer needed patches.
* Tue Jun 06 2023 Phil Wyett <philip.wyett@kathenas.org> - 1.4.30-3
- Remove some old workarounds from spec file.
* Thu Apr 20 2023 Phil Wyett <philip.wyett@kathenas.org> - 1.4.30-2
- Add patch: 0001_remmina_fix_vnc_crash_domain_socket.patch

@ -1 +1 @@
SHA512 (remmina-1.4.30.tar.gz) = 99156e4ce54383d9a047ac8d0b1aaaaba9c8847393ef0fcb087704d3da231276d46b8212c3c5637cd1b949c304589c5f7e0844deedbc5b6e9e50f7f0cacf9673
SHA512 (remmina-1.4.31.tar.gz) = bc71864918f504a44767dafa967458803a9c154436d6673130c16c1594e15e9f7cca12504465cb11f7d0481e08252de1ac790a954cf9e99af7bb20ad28639f80

Loading…
Cancel
Save