Merge branch 'rawhide' into epel9

epel9
Phil Wyett 2 years ago
commit c432488fab

@ -0,0 +1,25 @@
From c6adb35b854dcc71895413b120fafaa071645549 Mon Sep 17 00:00:00 2001
From: John Chadwick <johnwchadwick@gmail.com>
Date: Fri, 14 Apr 2023 04:01:41 +0000
Subject: [PATCH] Fix segfault in VNC when using domain socket
---
plugins/vnc/vnc_plugin.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/plugins/vnc/vnc_plugin.c b/plugins/vnc/vnc_plugin.c
index 4fa7b627b..adecffff4 100644
--- a/plugins/vnc/vnc_plugin.c
+++ b/plugins/vnc/vnc_plugin.c
@@ -1716,7 +1716,7 @@ static gboolean remmina_plugin_vnc_open_connection(RemminaProtocolWidget *gp)
raw_server = remmina_plugin_service->file_get_string(remminafile, "server");
if (raw_server && strstr(raw_server, "unix://") == raw_server) {
- REMMINA_PLUGIN_AUDIT(_("Connected to %s via VNC"), server);
+ REMMINA_PLUGIN_AUDIT(_("Connected to %s via VNC"), raw_server);
} else {
remmina_plugin_service->get_server_port(raw_server,
VNC_DEFAULT_PORT,
--
GitLab

@ -5,7 +5,7 @@
Name: remmina
Version: 1.4.30
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Remote Desktop Client
License: GPL-2.0-or-later and MIT
URL: https://remmina.org
@ -18,6 +18,9 @@ Source0: https://gitlab.com/Remmina/Remmina/-/archive/v%{version}/Remmina-%{vers
# So we can't use it directly only as instructions.
Source1: pluginBuild-CMakeLists.txt
# Patches.
Patch00: 0001_remmina_fix_vnc_crash_domain_socket.patch
BuildRequires: cmake
BuildRequires: cups-devel
BuildRequires: desktop-file-utils
@ -342,6 +345,9 @@ appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/metainfo/*.appdat
%{_mandir}/man1/remmina-gnome.1*
%changelog
* Thu Apr 20 2023 Phil Wyett <philip.wyett@kathenas.org> - 1.4.30-2
- Add patch: 0001_remmina_fix_vnc_crash_domain_socket.patch
* Mon Apr 10 2023 Phil Wyett <philip.wyett@kathenas.org> - 1.4.30-1
- New upstream version 1.4.30.
- Use SPDX license identifiers.

Loading…
Cancel
Save