Fix DSO linking against gnutls (#819976)

epel8
Christoph Wickert 13 years ago
parent 75c2aae559
commit 48973fa57e

@ -0,0 +1,11 @@
--- remmina-plugins/vnc/CMakeLists.txt 2012-06-04 13:03:46.542093149 -0600
+++ remmina-plugins/vnc/CMakeLists.txt 2012-06-04 13:03:34.112332497 -0600
@@ -28,7 +28,7 @@
set_target_properties(remmina-plugin-vnc PROPERTIES PREFIX "")
include_directories(${REMMINA_COMMON_INCLUDE_DIRS} ${LIBVNCSERVER_INCLUDE_DIRS})
-target_link_libraries(remmina-plugin-vnc ${REMMINA_COMMON_LIBRARIES} ${LIBVNCSERVER_LIBRARIES})
+target_link_libraries(remmina-plugin-vnc ${REMMINA_COMMON_LIBRARIES} ${LIBVNCSERVER_LIBRARIES} gnutls )
install(TARGETS remmina-plugin-vnc DESTINATION ${REMMINA_PLUGINDIR})

@ -2,7 +2,7 @@
Name: remmina
Version: 1.0.0
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Remote Desktop Client
Group: Applications/Internet
@ -32,6 +32,9 @@ Patch10: remmina-1.0.0-fix-crashes-in-some-cases.patch
# https://github.com/FreeRDP/Remmina/commit/b2277827
Patch11: remmina-1.0.0-fix-memory-leak.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=819976
Patch20: remmina-1.0.0-dsofix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gtk3-devel
@ -200,8 +203,10 @@ client.
%patch4 -p1 -b .some-more-clipboard-fixes
%patch5 -p1 -b .disconnect-signal-handler
%patch10 -p1 -b .fix-crashes-in-some-cases
%patch11 -p1 -b .fix-memory-leak
%patch10 -p1 -b .fix-crashes-in-some-cases
%patch11 -p1 -b .fix-memory-leak
%patch20 -p1 -b .dsofix
# Don't hardcode libdir
sed -i "s,/lib/remmina/plugins,/%{_lib}/remmina/plugins,g" CMakeLists.txt
@ -333,6 +338,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog
* Sat Jun 09 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.0-4
- Fix DSO linking against gnutls (#819976)
* Sun Jun 03 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.0-3
- Fix crash introduced by clipboard support (#827756)

Loading…
Cancel
Save