i9c-stream-7
changed/i9c-stream-7/redis-7.2.6-1.module+el9.5.0+22422+63e067d8
parent
c52478c709
commit
fcefa9b050
@ -1,2 +1,2 @@
|
|||||||
SOURCES/redis-7.0.12.tar.gz
|
SOURCES/redis-7.2.6.tar.gz
|
||||||
SOURCES/redis-doc-c7880ba.tar.gz
|
SOURCES/redis-doc-c7880ba.tar.gz
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
cd8190d9289d46be2b3a30dda14ffba8a92abbc8 SOURCES/redis-7.0.12.tar.gz
|
0d9d539a8cb4239843d97835465c733035950c85 SOURCES/redis-7.2.6.tar.gz
|
||||||
b2c7f2bee8e40fc6bd5385c25429fa537e2751c5 SOURCES/redis-doc-c7880ba.tar.gz
|
b2c7f2bee8e40fc6bd5385c25429fa537e2751c5 SOURCES/redis-doc-c7880ba.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From bbace21828d7e82f1c481f0e1caece31b661cbd9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Florian Weimer <fweimer@redhat.com>
|
|
||||||
Date: Mon, 5 Dec 2022 11:10:37 +0100
|
|
||||||
Subject: [PATCH 2/2] deps/jemalloc: Do not force building in gnu99 mode
|
|
||||||
Content-type: text/plain
|
|
||||||
|
|
||||||
The jemalloc configure logic switches to gnu11 mode if available,
|
|
||||||
and this explicit flags injection prevents that. The main difference
|
|
||||||
seems to be that in gnu99 mode, <stdatomic.h> is presumed to be
|
|
||||||
unavailable and is not used.
|
|
||||||
|
|
||||||
Submitted upstream: <https://github.com/redis/redis/pull/11583>
|
|
||||||
|
|
||||||
---
|
|
||||||
deps/Makefile | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/deps/Makefile b/deps/Makefile
|
|
||||||
index 8592e17..d6cb06e 100644
|
|
||||||
--- a/deps/Makefile
|
|
||||||
+++ b/deps/Makefile
|
|
||||||
@@ -90,7 +90,7 @@ lua: .make-prerequisites
|
|
||||||
|
|
||||||
.PHONY: lua
|
|
||||||
|
|
||||||
-JEMALLOC_CFLAGS= -std=gnu99 -Wall -pipe -g3 -O3 -funroll-loops $(CFLAGS)
|
|
||||||
+JEMALLOC_CFLAGS= -Wall -pipe -g3 -O3 -funroll-loops $(CFLAGS)
|
|
||||||
JEMALLOC_LDFLAGS= $(LDFLAGS)
|
|
||||||
|
|
||||||
ifneq ($(DEB_HOST_GNU_TYPE),)
|
|
||||||
--
|
|
||||||
2.38.1
|
|
||||||
|
|
@ -1,54 +0,0 @@
|
|||||||
From e351099e1119fb89496be578f5232c61ce300224 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Oran Agra <oran@redislabs.com>
|
|
||||||
Date: Sun, 7 Jan 2024 12:32:44 +0200
|
|
||||||
Subject: [PATCH] Fix possible corruption in sdsResize (CVE-2023-41056)
|
|
||||||
|
|
||||||
#11766 introduced a bug in sdsResize where it could forget to update
|
|
||||||
the sds type in the sds header and then cause an overflow in sdsalloc.
|
|
||||||
it looks like the only implication of that is a possible assertion in HLL,
|
|
||||||
but it's hard to rule out possible heap corruption issues with clientsCronResizeQueryBuffer
|
|
||||||
---
|
|
||||||
src/sds.c | 30 ++++++++++++++++--------------
|
|
||||||
1 file changed, 16 insertions(+), 14 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/sds.c b/src/sds.c
|
|
||||||
index 8e5863a3ab8e..71490d5b2522 100644
|
|
||||||
--- a/src/sds.c
|
|
||||||
+++ b/src/sds.c
|
|
||||||
@@ -348,20 +348,22 @@ sds sdsResize(sds s, size_t size, int would_regrow) {
|
|
||||||
* type. */
|
|
||||||
int use_realloc = (oldtype==type || (type < oldtype && type > SDS_TYPE_8));
|
|
||||||
size_t newlen = use_realloc ? oldhdrlen+size+1 : hdrlen+size+1;
|
|
||||||
- int alloc_already_optimal = 0;
|
|
||||||
- #if defined(USE_JEMALLOC)
|
|
||||||
- /* je_nallocx returns the expected allocation size for the newlen.
|
|
||||||
- * We aim to avoid calling realloc() when using Jemalloc if there is no
|
|
||||||
- * change in the allocation size, as it incurs a cost even if the
|
|
||||||
- * allocation size stays the same. */
|
|
||||||
- alloc_already_optimal = (je_nallocx(newlen, 0) == zmalloc_size(sh));
|
|
||||||
- #endif
|
|
||||||
-
|
|
||||||
- if (use_realloc && !alloc_already_optimal) {
|
|
||||||
- newsh = s_realloc(sh, newlen);
|
|
||||||
- if (newsh == NULL) return NULL;
|
|
||||||
- s = (char*)newsh+oldhdrlen;
|
|
||||||
- } else if (!alloc_already_optimal) {
|
|
||||||
+
|
|
||||||
+ if (use_realloc) {
|
|
||||||
+ int alloc_already_optimal = 0;
|
|
||||||
+ #if defined(USE_JEMALLOC)
|
|
||||||
+ /* je_nallocx returns the expected allocation size for the newlen.
|
|
||||||
+ * We aim to avoid calling realloc() when using Jemalloc if there is no
|
|
||||||
+ * change in the allocation size, as it incurs a cost even if the
|
|
||||||
+ * allocation size stays the same. */
|
|
||||||
+ alloc_already_optimal = (je_nallocx(newlen, 0) == zmalloc_size(sh));
|
|
||||||
+ #endif
|
|
||||||
+ if (!alloc_already_optimal) {
|
|
||||||
+ newsh = s_realloc(sh, newlen);
|
|
||||||
+ if (newsh == NULL) return NULL;
|
|
||||||
+ s = (char*)newsh+oldhdrlen;
|
|
||||||
+ }
|
|
||||||
+ } else {
|
|
||||||
newsh = s_malloc(newlen);
|
|
||||||
if (newsh == NULL) return NULL;
|
|
||||||
memcpy((char*)newsh+hdrlen, s, len);
|
|
Loading…
Reference in new issue