import recode-3.7.11-1.el9

i9ce changed/i9ce/recode-3.7.11-1.el9
Arkady L. Shane 1 year ago
parent da4ba78a88
commit a753f78121
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

2
.gitignore vendored

@ -1 +1 @@
SOURCES/recode-3.6.tar.gz SOURCES/recode-3.7.11.tar.gz

@ -1 +1 @@
2de90cd2ba553bc07d75a29913ea4424dd9e616b SOURCES/recode-3.6.tar.gz 697cbd7ae376d92758da3b9074abe7d643513365 SOURCES/recode-3.7.11.tar.gz

@ -0,0 +1,40 @@
From 170857800f2a84b4cdb8fefe9a698efe5509837a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Fri, 16 Aug 2019 09:29:54 +0200
Subject: [PATCH] Rename coliding hash functions
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Ported from Fedora recode patch:
commit 5cd1d43a39e4679ed265efcdf4bdc3da517e3de5 (tag: recode-3_6-16)
Author: Bill Nottingham <notting@fedoraproject.org>
Date: Fri May 27 02:52:25 2005 +0000
auto-import recode-3.6-16 on branch devel from recode-3.6-16.src.rpm
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
lib/hash.h | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/lib/hash.h b/lib/hash.h
index 562f5e6..65d967e 100644
--- a/lib/hash.h
+++ b/lib/hash.h
@@ -24,6 +24,11 @@
#ifndef HASH_H_
# define HASH_H_
+#define hash_lookup recode_hash_lookup
+#define hash_delete recode_hash_delete
+#define hash_free recode_hash_free
+#define hash_insert recode_hash_insert
+
# include <stdio.h>
# include <stdbool.h>
--
2.21.0

@ -1,103 +1,202 @@
Summary: Conversion between character sets and surfaces Name: recode
Name: recode Version: 3.7.11
Version: 3.6 Release: 1%{?dist}
Release: 47%{?dist} Summary: Conversion between character sets and surfaces
License: GPLv2+ # COPYING: GPLv3 text
Group: Applications/File # COPYING-LIB: LGPLv3 text
Url: http://recode.progiciels-bpi.ca/ # doc/recode.info: OFSFDL
Source: http://recode.progiciels-bpi.ca/archives/recode-%{version}.tar.gz # doc/recode.texi: OFSFDL
Patch0: recode.patch # lib/error.h: GPLv3+
Patch1: recode-3.6-getcwd.patch # lib/strerror-override.c: GPLv3+
Patch2: recode-bool-bitfield.patch # lib/vasnprintf.c: GPLv3+
Patch3: recode-flex-m4.patch # src/ansellat1.l: BSD
Patch4: recode-automake.patch # src/lat1asci.c: GPLv3+
Patch5: recode-format-security.patch # src/merged.c: BSD
Patch6: recode-longfilename.patch # src/recode.h: LGPLv3+
# src/ucs.c: LGPLv3+
Requires(post): /sbin/install-info ## Not in any binary package
Requires(post): /sbin/ldconfig # aclocal.m4: FSFULLR
Requires(preun): /sbin/install-info # build-aux/bootstrap.in: MIT or GPLv3+ (bundled gnulib-modules/bootstrap)
Requires(postun): /sbin/ldconfig # build-aux/compile: GPLv2+ with exceptions
# build-aux/config.guess: GPLv3+ with exceptions
BuildRequires: libtool # build-aux/config.rpath: FSFULLR
BuildRequires: texinfo # build-aux/config.sub: GPLv3+ with exceptions
# build-aux/depcomp: GPLv2+ with exceptions
# build-aux/extract-trace: MIT or GPLv3+ (bundled gnulib-modules/bootstrap)
# build-aux/funclib.sh: MIT or GPLv3+ (bundled gnulib-modules/bootstrap)
# build-aux/inline-source: MIT or GPLv3+ (bundled gnulib-modules/bootstrap)
# build-aux/install-sh: MIT
# build-aux/ltmain.sh: GPLv2+ with exceptions and GPLv3+ with exceptions
# and GPLv3+
# build-aux/mdate-sh: GPLv2+ with exceptions
# build-aux/missing: GPLv2+ with exceptions
# build-aux/options-parser: MIT or GPLv3+ (bundled gnulib-modules/bootstrap)
# build-aux/texinfo.tex: GPLv3+ with exceptions
# config.rpath: FSFULLR
# configure: FSFUL and GPLv2+ with exceptions
# doc/Makefile.am: GPLv3+
# doc/Makefile.in: FSFULLR and GPLv3+
# doc/texinfo.tex: GPLv2+ with exceptions
# INSTALL: FSFAP
# Makefile.am: GPLv3+
# m4/gettext.m4: FSFULLR
# m4/gnulib-cache.m4: GPLv3+ with exceptions
# m4/libtool.m4: GPLv2+ with exceptions and FSFUL
# m4/mbstate_t.m4: FSFULLR
# m4/minmax.m4: FSFULLR
# m4/ssize_t.m4: FSFULLR
# m4/sys_stat_h.m4: FSFULLR
# tables.py: GPLv3+
# tests/Makefile.am: GPLv3+
# tests/Makefile.in: FSFULLR and GPLv3+
# tests/Recode.pyx: GPLv3+
License: GPLv3+ and LGPLv3+ and BSD and OFSFDL
URL: https://github.com/rrthomas/recode
Source: %{url}/releases/download/v%{version}/recode-%{version}.tar.gz
# Make internal hash function identifiers unique
Patch0: recode-3.7.1-Rename-coliding-hash-functions.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: coreutils
BuildRequires: gcc
BuildRequires: gettext-devel
# help2man is executed from ./src/Makefile if main.c or configure.ac is newer
# than recode.1.
BuildRequires: make
BuildRequires: libtool
BuildRequires: texinfo
# Tests:
BuildRequires: python3-Cython
BuildRequires: python3-devel >= 3.7.5
%description %description
The `recode' converts files between character sets and usages. The recode tool and library convert files between character sets and surfaces.
It recognizes or produces nearly 150 different character sets It recognizes or produces over 200 different character sets (or about 300 if
and is able to transliterate files between almost any pair. When exact combined with an iconv library) and transliterates files between almost any
transliteration are not possible, it may get rid of the offending pair. When exact transliteration is not possible, it gets rid of the offending
characters or fall back on approximations. Most RFC 1345 character sets character or falls back on an approximations.
are supported.
%package devel %package devel
Summary: Header files for development using recode Summary: Header files for development using recode library
Group: Development/Libraries # Header files are LGPLv3+
Requires: %{name}%{?_isa} = %{version}-%{release} License: LGPLv3+
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel %description devel
The `recode' library converts files between character sets and usages. This package provides the header files for a recode library.
The library recognizes or produces nearly 150 different character sets
and is able to transliterate files between almost any pair. When exact
transliteration are not possible, it may get rid of the offending
characters or fall back on approximations. Most RFC 1345 character sets
are supported.
%prep %prep
%setup -q %setup -q
%patch0 -p1 %patch0 -p1
%patch1 -p1 -b .getcwd autoreconf -fi
%patch2 -p0
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
rm m4/libtool.m4
rm acinclude.m4
%build %build
autoreconf -fiv export PYTHON=%{__python3}
%configure --disable-static %configure \
make %{?_smp_mflags} --without-dmalloc \
--disable-gcc-warnings \
--enable-largefile \
--enable-nls \
--disable-rpath \
--enable-shared \
--disable-static
%{make_build}
%check %check
make check make check
%install %install
%makeinstall %{make_install}
%find_lang %{name} %find_lang %{name}
# remove unpackaged file from the buildroot # remove unpackaged file from the buildroot
rm -f $RPM_BUILD_ROOT%{_infodir}/dir rm -r $RPM_BUILD_ROOT%{_infodir}/dir
# remove libtool archives # remove libtool archives
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la rm $RPM_BUILD_ROOT%{_libdir}/*.la
%post
/sbin/ldconfig
/sbin/install-info %{_infodir}/recode.info.gz %{_infodir}/dir --entry="* recode: (recode). Conversion between character sets and surfaces." || :
%preun
if [ $1 = 0 ]; then
/sbin/install-info --delete %{_infodir}/recode.info.gz %{_infodir}/dir --entry="* recode: (recode). Conversion between character sets and surfaces." || :
fi
%postun -p /sbin/ldconfig
%files -f %{name}.lang %files -f %{name}.lang
%doc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO %license COPYING COPYING-LIB
# Changelog is not helpful
%doc AUTHORS NEWS README THANKS TODO
%{_mandir}/*/* %{_mandir}/*/*
%{_infodir}/recode.info* %{_infodir}/recode.info*
%{_bindir}/* %{_bindir}/*
%{_libdir}/*.so.0* %{_libdir}/librecode.so.3
%{_libdir}/librecode.so.3.*
%files devel %files devel
%{_libdir}/*.so %{_libdir}/*.so
%{_includedir}/* %{_includedir}/*
%changelog %changelog
* Tue Jan 16 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 3.7.11-1
- Rebuilt for MSVSphere 9.3
* Tue Feb 08 2022 Ondrej Pohorelsky <opohorel@redhat.com> - 3.7.11-1
- 3.7.11 bump
- Resolves: rhbz#2043834
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Tue Jun 08 2021 Ondrej Pohorelsky <opohorel@redhat.com> - 3.7.9-1
- 3.7.9 bump
- Resolves: rhbz#1967383
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Nov 12 2020 Ondrej Pohorelsky <opohorel@redhat.com> - 3.7.8-1
- 3.7.8 bump
* Thu Jul 30 2020 Petr Pisar <ppisar@redhat.com> - 3.7.7-1
- 3.7.7 bump
* Wed Jul 29 2020 Petr Pisar <ppisar@redhat.com> - 3.7.6-4
- Correct a description
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Fri Sep 13 2019 Petr Pisar <ppisar@redhat.com> - 3.7.6-1
- 3.7.6
* Thu Sep 12 2019 Petr Pisar <ppisar@redhat.com> - 3.7.5-1
- 3.7.5 bump
- Fix a possible buffer overflow in transform_utf16_java()
- Fix a type mismatch in tests
* Mon Sep 02 2019 Petr Pisar <ppisar@redhat.com> - 3.7.4-1
- 3.7.4 bump
* Mon Sep 02 2019 Petr Pisar <ppisar@redhat.com> - 3.7.3-1
- 3.7.3 bump
* Tue Aug 20 2019 Petr Pisar <ppisar@redhat.com> - 3.7.2-1
- 3.7.2 bump
- Change a soname because recode-3.7 changed an ABI
(https://github.com/rrthomas/recode/issues/22)
* Fri Aug 16 2019 Petr Pisar <ppisar@redhat.com> - 3.7.1-1
- 3.7.1 bump (bug #1379055)
- License changed to GPLv3+ and LGPLv3+ and BSD and OFSFDL
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.6-50
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.6-49
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.6-48
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.6-47 * Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.6-47
- Escape macros in %%changelog - Escape macros in %%changelog

Loading…
Cancel
Save