parent
14edfa55ee
commit
6df3d476eb
@ -1 +1 @@
|
|||||||
281c2e0a352c53ef1656bfe778c380226d61726f SOURCES/rasqal-0.9.33.tar.gz
|
281c2e0a352c53ef1656bfe778c380226d61726f SOURCES/rasqal-0.9.33.tar.gz
|
||||||
|
@ -0,0 +1,23 @@
|
|||||||
|
diff -ruN rasqal-0.9.33.orig/configure rasqal-0.9.33/configure
|
||||||
|
--- rasqal-0.9.33.orig/configure 2023-01-23 13:14:38.861781072 +0100
|
||||||
|
+++ rasqal-0.9.33/configure 2023-01-23 16:57:03.874250005 +0100
|
||||||
|
@@ -13712,6 +13712,7 @@
|
||||||
|
$as_echo_n "checking whether __FUNCTION__ is available... " >&6; }
|
||||||
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
/* end confdefs.h. */
|
||||||
|
+extern int printf(const char *);
|
||||||
|
int main() { printf(__FUNCTION__); }
|
||||||
|
_ACEOF
|
||||||
|
if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
diff -ruN rasqal-0.9.33.orig/configure.ac rasqal-0.9.33/configure.ac
|
||||||
|
--- rasqal-0.9.33.orig/configure.ac 2014-11-23 23:11:33.000000000 +0100
|
||||||
|
+++ rasqal-0.9.33/configure.ac 2023-01-23 15:49:44.885025978 +0100
|
||||||
|
@@ -312,7 +312,7 @@
|
||||||
|
AC_C_BIGENDIAN
|
||||||
|
|
||||||
|
AC_MSG_CHECKING(whether __FUNCTION__ is available)
|
||||||
|
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([int main() { printf(__FUNCTION__); }])],
|
||||||
|
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([extern int printf(const char *s); int main() { printf(__FUNCTION__); }])],
|
||||||
|
[AC_DEFINE([HAVE___FUNCTION__], [1], [Is __FUNCTION__ available])
|
||||||
|
AC_MSG_RESULT(yes)],
|
||||||
|
[AC_MSG_RESULT(no)])
|
@ -0,0 +1,31 @@
|
|||||||
|
Fix incompatible pointer type due to misuse of the gcry_md_open
|
||||||
|
function.
|
||||||
|
|
||||||
|
Submitted upstream: <https://github.com/dajobe/rasqal/pull/13>
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index 038ea7c3efaf06a0..17a107cda735a257 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -14541,7 +14541,7 @@ elif test "$ac_cv_header_gcrypt_h" = "yes"; then
|
||||||
|
int
|
||||||
|
main ()
|
||||||
|
{
|
||||||
|
- gcry_md_hd_t hash; gcry_md_open(hash, GCRY_MD_MD5, 0);
|
||||||
|
+ gcry_md_hd_t hash; gcry_md_open(&hash, GCRY_MD_MD5, 0);
|
||||||
|
;
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 7bfc38e9261d6c96..eea4d34e7dc9fd4b 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -631,7 +631,7 @@ elif test "$ac_cv_header_gcrypt_h" = "yes"; then
|
||||||
|
LIBS="$LIBS `$LIBGCRYPT_CONFIG --libs`"
|
||||||
|
|
||||||
|
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
|
||||||
|
- #include <gcrypt.h>]], [[ gcry_md_hd_t hash; gcry_md_open(hash, GCRY_MD_MD5, 0); ]])],[have_digest_gcrypt=yes],[have_digest_gcrypt=no])
|
||||||
|
+ #include <gcrypt.h>]], [[ gcry_md_hd_t hash; gcry_md_open(&hash, GCRY_MD_MD5, 0); ]])],[have_digest_gcrypt=yes],[have_digest_gcrypt=no])
|
||||||
|
|
||||||
|
CPPFLAGS="$oCPPFLAGS"
|
||||||
|
LIBS="$oLIBS"
|
Loading…
Reference in new issue