parent
1ddd42bed4
commit
eda5d65137
@ -1,82 +0,0 @@
|
|||||||
From c575fbe6646fa37ed5759d0011ac7cd0d4cea22b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andrew Stitcher <astitcher@apache.org>
|
|
||||||
Date: Thu, 28 May 2020 12:34:58 -0400
|
|
||||||
Subject: [PATCH] Temporary patch to enable installed examples to build.
|
|
||||||
|
|
||||||
---
|
|
||||||
c/examples/CMakeLists.txt | 22 ----------------------
|
|
||||||
cpp/examples/CMakeLists.txt | 31 -------------------------------
|
|
||||||
2 files changed, 53 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/c/examples/CMakeLists.txt b/c/examples/CMakeLists.txt
|
|
||||||
index 9771ec59..1f448e9e 100644
|
|
||||||
--- a/c/examples/CMakeLists.txt
|
|
||||||
+++ b/c/examples/CMakeLists.txt
|
|
||||||
@@ -32,25 +32,3 @@ foreach (name broker send receive direct send-abort send-ssl)
|
|
||||||
set_target_properties(c-${name} PROPERTIES
|
|
||||||
OUTPUT_NAME ${name})
|
|
||||||
endforeach()
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-find_package (PythonInterp) # For test-driver script
|
|
||||||
-if (PYTHON_EXECUTABLE)
|
|
||||||
- if(WIN32)
|
|
||||||
- # NOTE: need to escape semicolons as cmake uses them as list separators.
|
|
||||||
- set(test_path "$<TARGET_FILE_DIR:c-broker>\;$<TARGET_FILE_DIR:qpid-proton-core>\;$<TARGET_FILE_DIR:qpid-proton-proactor>")
|
|
||||||
- else()
|
|
||||||
- set(test_path "$<TARGET_FILE_DIR:c-broker>:$ENV{PATH}")
|
|
||||||
- endif()
|
|
||||||
-
|
|
||||||
- set(test_env
|
|
||||||
- "PATH=${test_path}"
|
|
||||||
- "PYTHONPATH=../../tests/py")
|
|
||||||
-
|
|
||||||
- pn_add_test(
|
|
||||||
- UNWRAPPED
|
|
||||||
- NAME c-example-tests
|
|
||||||
- PREPEND_ENVIRONMENT "${test_env}"
|
|
||||||
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
|
||||||
- COMMAND ${PYTHON_EXECUTABLE} testme -v)
|
|
||||||
-endif()
|
|
||||||
diff --git a/cpp/examples/CMakeLists.txt b/cpp/examples/CMakeLists.txt
|
|
||||||
index 4c6dc9f4..74e41de4 100644
|
|
||||||
--- a/cpp/examples/CMakeLists.txt
|
|
||||||
+++ b/cpp/examples/CMakeLists.txt
|
|
||||||
@@ -102,34 +102,3 @@ if(HAS_ENOUGH_CPP11)
|
|
||||||
endforeach()
|
|
||||||
endif()
|
|
||||||
endif()
|
|
||||||
-
|
|
||||||
-find_package (PythonInterp) # For test-driver script
|
|
||||||
-if (PYTHON_EXECUTABLE)
|
|
||||||
- if(WIN32)
|
|
||||||
- # NOTE: need to escape semicolons as cmake uses them as list separators.
|
|
||||||
- set(test_path "$<TARGET_FILE_DIR:broker>\;$<TARGET_FILE_DIR:qpid-proton-core>\;$<TARGET_FILE_DIR:qpid-proton-cpp>")
|
|
||||||
- else()
|
|
||||||
- set(test_path "$<TARGET_FILE_DIR:broker>:$ENV{PATH}")
|
|
||||||
- endif()
|
|
||||||
-
|
|
||||||
- set(test_env
|
|
||||||
- "PATH=${test_path}"
|
|
||||||
- "PYTHONPATH=../../tests/py"
|
|
||||||
- "HAS_CPP11=$<$<BOOL:${HAS_ENOUGH_CPP11}>:1>")
|
|
||||||
-
|
|
||||||
- pn_add_test(
|
|
||||||
- UNWRAPPED
|
|
||||||
- NAME cpp-example-container
|
|
||||||
- PREPEND_ENVIRONMENT "${test_env}"
|
|
||||||
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
|
||||||
- COMMAND ${PYTHON_EXECUTABLE} testme -v ContainerExampleTest)
|
|
||||||
-
|
|
||||||
- if (NOT SSL_IMPL STREQUAL none)
|
|
||||||
- pn_add_test(
|
|
||||||
- UNWRAPPED
|
|
||||||
- NAME cpp-example-container-ssl
|
|
||||||
- PREPEND_ENVIRONMENT "${test_env}"
|
|
||||||
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
|
||||||
- COMMAND ${PYTHON_EXECUTABLE} testme -v ContainerExampleSSLTest)
|
|
||||||
- endif()
|
|
||||||
-endif()
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (qpid-proton-0.32.0.tar.gz) = 4d1265308b685d5cdd28fd8746f13704c6e36a8dc35a2c121e07b9db21cabaf440da8dd1cf76892fc366845e7f472af2c29ae94dedee19d53756bba2bd4470b6
|
SHA512 (qpid-proton-0.33.0.tar.gz) = d82cade354fd01f2cf7a3e0c17d48cdfa3bde263c8571762cdeb0b4da6ef2d6fd6f97cdba4fa4e8fc1b5368c54ccd2ca860fb56f46f58091c91deab843a17cf2
|
||||||
|
Loading…
Reference in new issue